GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: Telnet Problems [7:16108] posted 01/06/2005
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Good day,

If the router has a connection to your Linksys, forward the telnet port (23)

to the ip of the router if it's under the same range.

For instance:

Internet (Public IP - 24.x.x.222) -> Linksys (Private IP - 192.x.x.1) -> 
Cisco (Private IP - 192.x.x.10)

Step 1:  Setup Dynamic DNS on your public ip using a free dns provider 
(Dyndns.org or No-ip.com)

Step 2: Enter you linksys configuration and enable port forwarding for the 
ip you assigned the cisco router to telnet

Step 3: Configure your Cisco router:

           - enable rip from the global configuration or for your e0 
interface, and enter the network -

               conf t
                router rip
                network 192.x.x.0
                Ctrl^Z

            - you could also enable different version of rip, but since you 
are using ip classless by default rip version 2 will be enabled -

            To verify you route settings run: show ip route (to view the 
routes), then run show ip interface brief (to view interface stats)

Step 4:  Try pinging your linksys from the cisco device, if it works then 
try telnet from a pc on you linksys to your router

If you are outside of your network then you could use the dynamic DNS you 
will have to created to access your cisco device. (telnet xx.dyndns.org:23 -

what ever port number you set it to on you linksys).  Always check for 
firmware updates especially for linksys products.  There are multiple ways 
to enable telnet access to your cisco router on a private network -> public.

I hope this helped.


Regards,

Chika



""Melvin Molder""  wrote in message 
news:200501032330.j03NUIqk005190@xxxxxxxxxxxxxxxxx
> Correction!  The ip address on the backside of the router is 192.168.1.1.
>
> Thanks,
> M. Molder
>
> Melvin Molder wrote:
>>
>> Firsts of all, let me start off by saying that I am totally new
>> to Cisco and routers, so if I say something that doesn't quite
>> make sense, please bear with me (smile).
>>
>> I have just begun to study for 640-801 and decided to purchase
>> some routers and switches to set up a lab.  My problem is that
>> I am not able to telnet into the lab from outside of my home
>> network.
>>
>> My lab sits behind a Linksys WRV54G Wireless-G VPN Broadband
>> Router.  The IP address on the backside of the router is
>> 192.168.1.2 (default) and the IP address of the Ethernet
>> interface that I am trying to telnet to is 192.168.1.10. I have
>> also setup a default gateway which points back to 192.168.1.1
>> (I think).
>>
>> Below is a copy of my configuration.  I've been working on this
>> for two days and it's driving me crazy.  Time to get some
>> advice from the pros (smile).
>>
>> -----------------------------------
>>
>> Building configuration...
>>
>> Current configuration : 689 bytes
>> !
>> version 12.3
>> service timestamps debug datetime msec
>> service timestamps log datetime msec
>> service password-encryption
>> !
>> hostname LabA-2503
>> !
>> !
>> ip subnet-zero
>> !
>> !
>> !
>> !
>> interface Ethernet0
>>  description Ehternet connection to Linksys Router
>>  ip address 192.168.1.10 255.255.255.0
>> !
>> interface Serial0
>>  description Serial connection to LabB Router
>>  ip address 192.168.2.1 255.255.255.0
>> !
>> interface Serial1
>>  no ip address
>>  shutdown
>> !
>> interface BRI0
>>  no ip address
>>  shutdown
>> !
>> ip default-gateway 192.168.1.1
>> ip http server
>> ip classless
>> !
>> !
>> !
>> !
>> line con 0
>>  password 7 104D0A17041B1309
>>  login
>> line aux 0
>>  password 7 104D0A17041B1309
>>  login
>> line vty 0 4
>>  password 7 104D0A17041B1309
>>  login
>> !
>> !
>> end
>>
>> LabA-2503#
>>
>> -----------------------------------
>>
>>
>> Thanks in advance!
>>
>> Melvin Molder.




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=95825&t=16108
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html