GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: RE: OSPF redistribute to rip does not work.CISCO gods [7:94468] posted 11/08/2004
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Chen,
Few observations, firstly you haven't pasted the redistribute connected
subnets command into the router ospf section below, secondly forgetting
about summary routes ospf will not redistribute into rip routes it learnt
from another source - that is you have to redistribute connected / static
into rip as well. Not being a Cisco guru, I wouldn't be certain what the
ABSR will do with the external ospf summary routes it creates (type-5) it
would seem logical that it wouldn't re-inject these into rip.  I imagine
that Doyle -  Cisco guru - has a technical explanation.
regards,
Alan


> -----Original Message-----
> From:	zc521@xxxxxxx [SMTP:zc521@xxxxxxx]
> Sent:	05 November 2004 23:00
> To:	cisco@xxxxxxxxxxxxxx
> Subject:	Re: RE: OSPF redistribute to rip does not work.CISCO gods
> [7:94427]
> 
> Hi All Cisco Gurus
> thanks you all for the replay, now i figure out on solution that uses
> static
> redistribution null 0 on R1 or use ip route command on R2  point to R1.
> Now i have done some research tonight,and come with another question
> 
> i have issues Summary-address command under OSPF to
> redistribute summarized route 131.108.3.0/24 to rip and then rip should
> pick
> up the update and send to rear router, but i am wrong debug out put tell
> me
> still just 1 route update to R2.
> what went wrong?
> ------------
> R1 sh run
> router ospf 1
>  log-adjacency-changes
>  summary-address 131.108.3.0 255.255.255.0     summary-address 131.108.4.0
255.255.255.0     summary-address 131.108.5.0 255.255.255.0     network
131.108.2.1 0.0.0.0 area 333
>  network 131.108.3.1 0.0.0.0 area 333
>  network 131.108.3.129 0.0.0.0 area 333
>  network 131.108.4.1 0.0.0.0 area 333
>  network 131.108.5.1 0.0.0.0 area 333
> !
> router rip
>  version 1
>  redistribute ospf 1 metric 1  (summarized)
>  passive-interface Loopback0
>  passive-interface Loopback1
>  passive-interface Loopback2
>  passive-interface Loopback3
>  passive-interface Loopback4
>  network 131.108.0.0  
> 
> any comment, answer best appreciated.
> Thank all cisco gurus & have a nice weekend
> Chen
***********************************************************************************

This email is for use by the addressee only.  If the message is received
by anyone other than the addressee, please return the message to the sender
by replying to it and then delete the message from your computer.

Internet Emails are not necessarily secure.  Ulster Bank Group / Royal Bank
of Scotland does not accept responsibility for changes made to this message
after it was sent.

***************************www.ulsterbank.com********************************




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=94468&t=94468
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html