GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
OSPF redistribute to rip does not work.CISCO gods HLEP [7:94402] posted 11/04/2004
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Hi list
here i follow a Secenario in Chapter 8 CCNP practical studies and got a
problem
Why dose my ospf doest not redistribute loopback1-5 to rip properly?

R1's loopback
lo0 131.108.2.1/24
lo1 131.108.3.1/25
lo2 131.108.3.129/25
lo3 131.108.4.1/29
lo4 131.108.5.1/29

R1-R2 131.108.1.0/24

R1
R1#sh run
Building configuration...

Current configuration : 1933 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
router ospf 1
 log-adjacency-changes
 summary-address 131.108.3.0 255.255.255.0
 summary-address 131.108.4.0 255.255.255.0
 summary-address 131.108.5.0 255.255.255.0
 redistribute connected subnets
 network 131.108.2.1 0.0.0.0 area 333
 network 131.108.3.1 0.0.0.0 area 333
 network 131.108.3.129 0.0.0.0 area 333
 network 131.108.4.1 0.0.0.0 area 333
 network 131.108.5.1 0.0.0.0 area 333
!
router rip
 version 1
 redistribute ospf 1 metric 1
 passive-interface Loopback0
 passive-interface Loopback1
 passive-interface Loopback2
 passive-interface Loopback3
 passive-interface Loopback4
 network 131.108.0.0


R2 sh run
nterface Ethernet0/0
 ip address 131.108.1.2 255.255.255.0
 half-duplex
 no cdp enable
!
router rip
 version 1
 network 131.108.0.0
 distribute-list 1 in
!
ip classless
ip http server
!
access-list 1 permit 131.108.5.0
access-list 1 permit 131.108.4.0
access-list 1 permit 131.108.3.0
access-list 1 permit 131.108.2.0
no cdp run

and my R2 Show ip route
R2#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     131.108.0.0/24 is subnetted, 2 subnets
R       131.108.2.0 [120/1] via 131.108.1.1, 00:00:09, Ethernet0/0
C       131.108.1.0 is directly connected, Ethernet0/0

i should get ------------

     131.108.0.0/24 is subnetted, 2 subnets
R       131.108.5.0 [120/1] via 131.108.1.1, 00:00:09, Ethernet0/0
R       131.108.4.0 [120/1] via 131.108.1.1, 00:00:09, Ethernet0/0
R       131.108.3.0 [120/1] via 131.108.1.1, 00:00:09, Ethernet0/0
R       131.108.2.0 [120/1] via 131.108.1.1, 00:00:09, Ethernet0/0
C       131.108.1.0 is directly connected, Ethernet0/0


where is my redistributed loopback 1-5? what went wrong ?
Many thanks all Cisco Gurus :X

Chen




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=94402&t=94402
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html