GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: Large file transfer issue. [7:86111] posted 03/19/2004
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


I can definitely relate to problems with Dell switches.  We have a stack
of 7 (1 12port copper Gig and 6 10/100) serving a single floor.  Until a
firmware upgrade a couple of months ago we had a strange issue which
occurred every 3-4 months.  All the switches would lock up and only a
couple of reboots of all switches got them working again. Some of the
Dell switches had this error, "sif_pkt_alloc: dblk allocate failed" 

Dell support said that this was a CPU overload error. An upgrade to
firmware 6.1.2.3291 of all the switches was necessary to fix the
problem. 

Vijay Ramcharan 
 


-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of
rich
Sent: Friday, March 19, 2004 8:59 AM
To: cisco@xxxxxxxxxxxxxx
Subject: Re: Large file transfer issue. [7:86111]


Hi Everyone. First I would like to thank all the people that shot idea's
at the below problem that I was having with a large file transfer issue
off a Dell switch. So after I found out what the problem was, I though
it would be appropriate to post.

Well all the suggestions that where posted back I tried. Nothing worked.

In the nutshell the problem turned out to be the Dell switch itself (go
figure :).

To recap the architecture, I have a Dell 5225 switch, that is Copper GIG
attached to a 6000 for an uplink. Large file transfers (FTP) from inside
the Dell switch where fast, but transfers OUT (FTP) of the Dell switch
going thought the uplink where horribly slow. No errors on any ports
(including the uplinks). The servers are all HP 11i machines running
same kernel and patch levels.

This is what sparked me. On the Dell switch we have servers that are on
ports 1-13. The uplink being on port 24.

If you transfer a file (FTP) from any server to any other server ON the
Dell switch BETWEEN ports 1-12. Smoken. On a hunch, I tried to do an
INTERSWTICH transfer from a server on port 13, to a server on port say
3. SLOW! So going from port 13, to any left hand port INSIDE that switch
was slow. Transfer from server to server on a port's between 1-12. Fast.

So we made some concessions, and put the UPLINK as well as the server on
port 13 on the "left side" of the switch. So now all nodes including the
UPLINK where on ports 1-12. All problems resolved.

So evidently, there seems to be a problem with certain large files
(don!&t know which) and transferring from ports 1-12 to ports 13-24.

I searched Dell forums. And there seems to be a lot of strange issues
with there switches. I!&m running firmware version 1 right now. They are
up to 3...BUT 3 is known to have a little issue with REBOOTING!

So that was it folks. Thanks for the help. And beware of Dell switches.

---------- Original Message ----------------------------------
From: "rich" 
Reply-To: 
Date:  Mon, 15 Mar 2004 16:00:13 -0500

>Hello Group. IV been wresting with an issue for a while now. And 
>thought I
would throw it out to see if anyone has ran across similar situation.
>
>I have a HP UX server (version 11i) connected to a Gigabit Dell switch
(5224). The uplink to this switch goes back to a 6500 Ethernet into a
Copper GBIC. So I have a Gigabit uplink back to the main network.
>
>Now from the HP UX server if I open an FTP session to a host that is 
>past
the uplink, and transfer a "small file" (below 60 megs), the speed is
blazing. Same thing with NFS, small file. Really fast.
>
>When I try to transfer a LARGE file, using the same process. The 
>connection
is significantly slower (under 200K per sec).
>
>Iv checked both sides of the connection for port errors, including the
uplink. Clean.
>
>As a test, I put my laptop on the dell and same segment as the HP UX
machine, and transferred the large file. BAM. Fast, really fast.
>
>So the problem only manifests itself when the HP UX on the dell is 
>trying
to talk to a client that is not local to the switch of the subnet, and
goes out the gigabit uplink.
>
>The thing that is bewildering me is that file transfers of 60 Megs are
extremely fast. As soon as you transfer a 100 Meg. The speed goes down
to nothing.
>
>Any ideas? Thanks.
**Please support GroupStudy by purchasing from the GroupStudy Store:
http://shop.groupstudy.com FAQ, list archives, and subscription info:
http://www.groupstudy.com/list/cisco.html




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=86119&t=86111
--------------------------------------------------
**Please support GroupStudy by purchasing from the GroupStudy Store:
http://shop.groupstudy.com
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html