GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: ospf type 5 lsas [7:74699] posted 09/04/2003
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


someone requested the configs; i'm sorry, i'm not sure who.

and the links are numbered, btw.


7500:

interface atm 0/1/0.101
 ip address 192.168.10.1 255.255.255.252
 
!

!
router ospf 120
 network 192.168.10.0 0.0.0.3 area 0
 network 10.64.0.0 0.0.0.255 area 14
 
!



2500:

interface ethernet 0
 ip address 172.16.10.5 255.255.255.252
!
interface serial 0/0.101 point-to-point
 ip address 192.168.10.2 255.255.255.252
 
!

!
router ospf 120
 network 192.168.10.0 0.0.0.3 area 0
 network 172.16.10.4 0.0.0.3 area 15
 area 15 nssa no-summary
!

the only other router in area 15 is at 172.16.10.6, and is configured as an
nssa asbr.

the 7500 has all the type 5 lsas in its database, but none entered in its
route table.

eg:

7500#show ip ospf database external  200.88.200.220

            OSPF Router with ID (200.55.10.244) (Process ID 20)

                Type-5 AS External Link States

  LS age: 2576
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.88.200.220 (External Network Number )
  Advertising Router: 200.27.100.154
  LS Seq Number: 80000008
  Checksum: 0x1A8B
  Length: 36
  Network Mask: /32
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 2
        Forward Address: 0.0.0.0
        External Route Tag: 3221225472

7500#show ip route | include 200.88.200.220

7500#




thomas



----- Original Message -----
From: Thomas Salmen
To: cisco@xxxxxxxxxxxxxx
Sent: Tuesday, September 02, 2003 3:43 PM
Subject: ospf type 5 lsas


i have a problem with ospf that someone may be able to help with.

i have a 2500 connected to a 7500 via a frame (2500 end) to atm (7500 end)
link. the 2500 is an abr for area 15 (serial area 0, ethernet area 15); the
7500 is an abr for area 14 (atm area 0, other interfaces area 14).

area 15 is configured as an nssa, as it is attached to another router which
is
redistributing static routes. area 14 is a standard ospf area, not stub or
nssa.

the 2500 (abr) is recieving type 7 lsas and converting them to type 5 and
flooding them into area 0, no problems. the 7500 has them in its lsa
database.
the problem is that none of the type 5 lsas are being entered in the 7500s
route table.

i have run through everything i can think of, and i'm a bit stuck. the
forwarding address of each lsa is 0.0.0.0. the network type is correct (ptp).
the 7500 can reach the abr and the asbr. subnet masks are all correct. i'm
not
sure what to look for next...

anyone?

thomas
**Please support GroupStudy by purchasing from the GroupStudy Store:
http://shop.groupstudy.com
FAQ, list archives, and subscription info:
http://www.groupstudy.com/list/cisco.html




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=74766&t=74699
--------------------------------------------------
**Please support GroupStudy by purchasing from the GroupStudy Store:
http://shop.groupstudy.com
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html