GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: OSPF over FR [7:70025] posted 06/03/2003
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Hi Catherine, 

Because you are using point to point sub interfaces on the one routea and
one the other just using the real interface, OSPF behaves differently and
has different helo / dead timers etc, and this is why you are not getting
all your routes.  You need to make sure that all ospf interfaces in the same
area are of the same "network type" using the interface command ip ospf
network

Below is a link to a quick ref 

http://www.chuckslongroad.info/OSPF_Frame_Reference.htm

Catherine Wu wrote:
> 
> I am testing Hub-Spoke for OSPF over FR,
> 
> I verified the neighbor adjacency,but I couldn't see route
> 2.2.2.2 and
> 3.3.3.3 in the routing table, 
> 
> RouterA#sh ip ospf nei
> 
> Neighbor ID     Pri   State           Dead Time  
> Address         Interface
> 3.3.3.3           1   FULL/  -        00:01:41    10.1.1.6
> Serial0/0.2
> 2.2.2.2           1   FULL/  -        00:01:39    10.1.1.2
> Serial0/0.1
> RouterB#sh ip ospf nei
> 
> Neighbor ID     Pri   State           Dead Time  
> Address         Interface
> 1.1.1.1           1   FULL/BDR        00:01:38   
> 10.1.1.1        Serial0/0
> RouterC#sh ip ospf nei
> 
> Neighbor ID     Pri   State           Dead Time  
> Address         Interface
> 1.1.1.1           1   FULL/BDR        00:01:34   
> 10.1.1.5        Serial0/0
> 
> RouterA#sh ip ro
> Codes: C - connected, S - static, I - IGRP, R - RIP, M -
> mobile, B - BGP
>        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF
> inter area
>        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external
> type 2
>        E1 - OSPF external type 1, E2 - OSPF external type 2, E
> - EGP
>        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia -
> IS-IS inter
> area
>        * - candidate default, U - per-user static route, o - ODR
>        P - periodic downloaded static route
> 
> Gateway of last resort is not set
> 
>      1.0.0.0/32 is subnetted, 1 subnets
> C       1.1.1.1 is directly connected, Loopback0
>      10.0.0.0/30 is subnetted, 2 subnets
> C       10.1.1.0 is directly connected, Serial0/0.1
> C       10.1.1.4 is directly connected, Serial0/0.2
> 
> Please help.
> 
> Thanks 
> 
> Catherine
> ----------------------------------------------------
> RouterA
> interface Loopback0
>  ip address 1.1.1.1 255.255.255.255
> !
> interface Serial0/0
>  no ip address
>  encapsulation frame-relay
>  frame-relay lmi-type ansi
>  no sh
> !
> interface Serial0/0.1 point-to-point
>  ip address 10.1.1.1 255.255.255.252
>  ip ospf hello-interval 30
>  frame-relay interface-dlci 101
> !
> interface Serial0/0.2 point-to-point
>  ip address 10.1.1.5 255.255.255.252
>  ip ospf hello-interval 30
>  frame-relay interface-dlci 102
> !
> router ospf 1
>  log-adjacency-changes
>  network 1.1.1.1 0.0.0.0 area 1
>  network 10.1.1.0 0.0.0.3 area 0
>  network 10.1.1.4 0.0.0.3 area 0
> 
> RouterB
> !
> interface Loopback0
>  ip address 2.2.2.2 255.255.255.255
> !
> interface Serial0/0
>  ip address 10.1.1.2 255.255.255.252
>  encapsulation frame-relay
>  frame-relay map ip 10.1.1.1 110 broadcast
>  no frame-relay inverse-arp
>  frame-relay lmi-type ansi
>  no sh
> !
> router ospf 1
>  log-adjacency-changes
>  network 2.2.2.2 0.0.0.0 area 2
>  network 10.1.1.0 0.0.0.3 area 0
>  neighbor 10.1.1.1 
> !
> RouterC
> interface Loopback0
>  ip address 3.3.3.3 255.255.255.255
> !
> interface Serial0/0
>  ip address 10.1.1.6 255.255.255.252
>  encapsulation frame-relay
>  frame-relay map ip 10.1.1.5 120 broadcast
>  no frame-relay inverse-arp
>  frame-relay lmi-type ansi
>  no sh
> !
> router ospf 1
>  log-adjacency-changes
>  network 3.3.3.3 0.0.0.0 area 3
>  network 10.1.1.4 0.0.0.3 area 0
>  neighbor 10.1.1.5 
> 
> [GroupStudy removed an attachment of type application/ms-tnef
> which had a name of winmail.dat]
> 
> 


Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=70054&t=70025
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to abuse@xxxxxxxxxxxxxx