GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: OSPF neighbor problem [7:64176] posted 03/02/2003
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


the spokes are in NBMA and have a priority of 0, the
hub is the DR and i changed the ospf network type as
NBMA exactly as with the spokes. I also staticaly
defined the neighbor at the hub and the spokes but it
does'nt appear in the config ( i don't know why)
So the way in which the two DROTHER stay is like if
they didn't se each other trough the hello packets.
But they can reach other because the ping between them
(directly) is good.

Another idea please.
--- Juan Blanco  wrote:
> The following is the replay that Churc send you and
> it make sense....
> 
> The problem is that the router with the multipoint
> subinterface considers
> that it is on an NMBA, and therefore considers
> itself as the DR, while the
> router using the point-to-point subinterface
> considers that it is on a
> point-to-point link, and therefore does not believe
> in the necessity for a
> DR.
> 
> if you look at the "show ip ospf neigh" result, your
> see the
> "attempt/DRother"  the DR is expecting a response
> from it's partner
> indicating the partner is neither a DR or BDR.
> 
> in L2 terms, a multipoint subinterface connected to
> point-to-point
> subinterfaces treats all connections as a series of
> point-to-point links.
> due to the manner in which OSPF interacts with frame
> relay, you can easily
> get situations like this.
> 
> off the top of my head, without knowing the
> partciulars, I would advise that
> you change the ospf network type to NMBA on the
> spokes, and use neighbor
> statements on the hub. Also, don't forget to
> manipulate the priorities so
> that the hub router becomes the DR.
> 
> Juan
> 
> -----Original Message-----
> From: Arnaud V. [mailto:arnaudv87@xxxxxxxxx]
> Sent: Sunday, March 02, 2003 7:41 AM
> To: blancoj@xxxxxxxxxxxxx
> Subject: RE: OSPF neighbor problem [7:64176]
> 
> 
> Hi,
> 
> I've got the same symptom without authentication.
> U can also see that hello packets are not dropped to
> any neighbor.
> 
> Have u another idea ?
> 
> Thks for u response
> --- Juan Blanco  wrote:
> > Why don't you remove the authentication first and
> > see how it works, and then
> > enable authentication.....
> >
> > -----Original Message-----
> > From: nobody@xxxxxxxxxxxxxx
> > [mailto:nobody@xxxxxxxxxxxxxx]On Behalf Of
> > Arnaud V.
> > Sent: Saturday, March 01, 2003 4:55 PM
> > To: cisco@xxxxxxxxxxxxxx
> > Subject: OSPF neighbor problem [7:64176]
> >
> >
> > Hello,
> >
> > I have an ospf problem. Two neighbors on a nbma
> > network who have connectivity are unable to go in
> > the
> > two state, but have establish adjacency with the
> DR.
> > I include the configurations and  ospf neighbor
> > states.
> > Perhaps have I done a mistake or don't know ospf
> > enough. Can u help please.
> >
> > Thanks in advance
> >
> > __________________________________________________
> > Do you Yahoo!?
> > Yahoo! Tax Center - forms, calculators, tips, more
> > http://taxes.yahoo.com/
> > R2
> >
> > interface Serial1/0
> >  no ip address
> >  encapsulation frame-relay IETF
> >  no fair-queue
> >  frame-relay traffic-shaping
> >  frame-relay class R2-ts
> > !
> > interface Serial1/0.1 point-to-point
> >  ip address 150.50.24.1 255.255.255.252
> >  ip ospf message-digest-key 1 md5 cisco
> >  frame-relay interface-dlci 204
> > !
> > interface Serial1/0.2 multipoint
> >  ip address 150.50.100.1 255.255.255.224
> >  ip ospf message-digest-key 1 md5 cisco
> >  ip ospf network non-broadcast
> >  ip ospf priority 0
> >  frame-relay map ip 150.50.100.2 205 broadcast
> >  frame-relay map ip 150.50.100.3 203 broadcast
> > !
> > router ospf 1
> >  log-adjacency-changes
> >  area 0 authentication message-digest
> >  redistribute connected subnets
> >  network 150.50.24.0 0.0.0.3 area 0
> >  network 150.50.100.0 0.0.0.127 area 0
> >
>
----------------------------------------------------------------------------
> > ----
> >
> > ROUTERp1R2#sh ip ospf neigh
> >
> > Neighbor ID     Pri   State           Dead Time
> > Address         Interface
> > 172.32.1.1        1   FULL/  -        00:00:38
> > 150.50.24.2
> > Serial1/0.1
> > N/A               0   ATTEMPT/DROTHER    -
> > 150.50.100.3
> > Serial1/0.2
> > 5.5.5.5         255   FULL/DR         00:01:39
> > 150.50.100.2
> > Serial1/0.2
> >
>
----------------------------------------------------------------------------
> > -----
> >
> > ROUTERp1R2#sh ip ospf int
> > Serial1/0.1 is up, line protocol is up
> >   Internet Address 150.50.24.1/30, Area 0
> >   Process ID 1, Router ID 2.2.2.2, Network Type
> > POINT_TO_POINT, Cost: 48
> >   Transmit Delay is 1 sec, State POINT_TO_POINT,
> >   Timer intervals configured, Hello 10, Dead 40,
> > Wait 40, Retransmit 5
> >     Hello due in 00:00:02
> >   Index 1/1, flood queue length 0
> >   Next 0x0(0)/0x0(0)
> >   Last flood scan length is 1, maximum is 6
> >   Last flood scan time is 0 msec, maximum is 0
> msec
> >   Neighbor Count is 1, Adjacent neighbor count is
> 1
> >     Adjacent with neighbor 172.32.1.1
> >   Suppress hello for 0 neighbor(s)
> >   Message digest authentication enabled
> >     Youngest key id is 1
> > Serial1/0.2 is up, line protocol is up
> >   Internet Address 150.50.100.1/27, Area 0
> >   Process ID 1, Router ID 2.2.2.2, Network Type
> > NON_BROADCAST, Cost: 48
> >   Transmit Delay is 1 sec, State DROTHER, Priority
> 0
> >   Designated Router (ID) 5.5.5.5, Interface
> address
> > 150.50.100.2
> >   No backup designated router on this network
> >   Timer intervals configured, Hello 30, Dead 120,
> > Wait 120, Retransmit 5
> >     Hello due in 00:00:10
> >   Index 2/2, flood queue length 0
> >   Next 0x0(0)/0x0(0)
> >   Last flood scan length is 1, maximum is 6
> >   Last flood scan time is 0 msec, maximum is 0
> msec
> >   Neighbor Count is 1, Adjacent neighbor count is
> 1
> >     Adjacent with neighbor 5.5.5.5  (Designated
> > Router)
> >   Suppress hello for 0 neighbor(s)
> >   Message digest authentication enabled
> >     Youngest key id is 1
> > FastEthernet4/0 is up, line protocol is up
> >   Internet Address 150.50.17.2/24, Area 3
> >   Process ID 1, Router ID 2.2.2.2, Network Type
> > POINT_TO_MULTIPOINT, Cost: 1
> >   Transmit Delay is 1 sec, State
> > POINT_TO_MULTIPOINT,
> >   Timer intervals configured, Hello 30, Dead 120,
> > Wait 120, Retransmit 5
> >     Hello due in 00:00:07
> >   Index 1/3, flood queue length 0
> >   Next 0x0(0)/0x0(0)
> >   Last flood scan length is 0, maximum is 0
> >   Last flood scan time is 0 msec, maximum is 0
> msec
> >   Neighbor Count is 0, Adjacent neighbor count is
> 0
> >   Suppress hello for 0 neighbor(s)
> > R3
> >
> > interface Serial2/0
> >  ip address 150.50.100.3 255.255.255.224
> >  encapsulation frame-relay IETF
> 
=== message truncated ===


__________________________________________________
Do you Yahoo!?
Yahoo! Tax Center - forms, calculators, tips, more
http://taxes.yahoo.com/




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=64200&t=64176
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to abuse@xxxxxxxxxxxxxx