GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: QOS on 2621xm [7:61353] posted 01/20/2003
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


In QoS now, there is more than just setting the bandwidth allocated to each
class. What you need to do is combine this with  the diffserv bit. This is
basically the newer version of the TOS bit in the IP header that defines
what sort of service happens to the packet. In a nut shell, this means which
packets gets sent first in the output queue.
As telnet is very delay sensitive, you should give it a higher diffserv bit.

What you basically do is create class maps for each traffic type and apply
it to the Ethernet interface so that the router modifies the packets as it
enters the router. As the packet leaves the interface, you use normal
service policies.

Sample config below:

class-map match-all Gold
  match access-group 170
class-map match-all Bronze
  match access-group 172
class-map match-all Telnet_SSH
  match access-group 131
class-map match-all Silver
  match access-group 171
!
policy-map SET_DIFFSERV
   class Telnet_SSH
   set ip dscp cs5
policy-map 
  class Gold
   bandwidth percent (%)
  class Bronze
   bandwidth percent (%)
!         
interface FastEthernet0/0
 description Link to LAN
 ip address x.x.x.x y.y.y.y
 speed 100
 full-duplex
 service-policy input SET_DIFFSERV
!
interface Serial0/0
 bandwidth 512
 ip address a.a.a.a b.b.b.b
 service-policy output 

access-list 131 remark Prioritise Telnet and SSH
access-list 131 permit tcp any any eq telnet
access-list 131 permit tcp any any eq 22
access-list 170 remark Gold Class QoS
access-list 170 permit ip host xxxxxx host xxxxxxx
access-list 170 permit ip host xxxxxxx host xxxxxxx
access-list 170 permit tcp host xxxxxxxx eq 443 any
access-list 170 permit tcp host xxxxxxxx eq www any
access-list 170 permit udp any any eq domain
access-list 172 remark Bronze Class QoS
access-list 172 permit ip host xxxxxxxx host xxxxxxxxx




>
> -----Original Message-----
> From: Julian P [mailto:julian@xxxxxxxxxxxxxx]
> Sent: 20 January 2003 10:02
> To: cisco@xxxxxxxxxxxxxx
> Subject: QOS on 2621xm [7:61353]
>
>
> Hi
>
>
> We would like to prioritize incoming traffic on our 256k internet link to
> uunet .We need to give telnet at least 64k incoming bandwidth.
>
> Any ideas on the best way to do this ?
>
> Thanks in advance
>
> Julian




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=61365&t=61353
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to abuse@xxxxxxxxxxxxxx