GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: EIGRP network 0.0.0.0 to redistribute static route [7:61241] posted 01/17/2003
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


""Wei Zhu""  wrote in message
news:200301170027.AAA28878@xxxxxxxxxxxxxxxxx
> Thank you everyone for your response,
>
> The reason I am confused is not becasuse the NULL0 in routing table,
that's
> the way eigrp does.

only if you have automatic summarization enabled. if you enter the command
"no auto-summary" under the eigrp process, the route to null 0 will
disappear.


> The reason is when I set the "network 0.0.0.0" in eigrp, it distribute the
> 172.22.0.0 network to S0 side(I have another router running eigrp at S0
> side, its routing table shows up 172.22.0.0 or 172.22.2.0/24 when I enable
> no summary).

>
> Chuck, does network 0.0.0.0 mean to enable all interface to participate
into
> route distribution?


starting with IOS 12.0, Cisco made it possible to enter interfaces ( not
whole networks ) into the eigrp process similar to the way you enter ospf
interfaces into the ospf process.

recall that with ospf you can use the command "network 0.0.0.0
255.255.255.255 area x" to place all interfaces into the ospf process.

apparently eigrp can be handled the same way. when you used the comand
"network 0.0.0.0" you placed all interfaces into the eigrp process.

my routers are asleep at the moment, but it occurs to me to look into
whether or not ospf will accept just the 0.0.0.0 notation.


> My idea is to put S0 in eigrp and S1 in BGP, while only set "network
> 192.168.1.0" won't put S1 into eigrp, thus won't distribute the 172.22.0.0
> network info into S0 side.

yep.

>
> I am using IOS12.1.5(10T).
>
> Regards
> Wei
>
> ----- Original Message -----
> From: "The Long and Winding Road"
> To:
> Sent: Thursday, January 16, 2003 2:37 AM
> Subject: Re: EIGRP network 0.0.0.0 to redistribute static route [7:61186]
>
>
> > ""The Long and Winding Road""  wrote in
> > message news:200301160552.FAA05571@xxxxxxxxxxxxxxxxx
> > > well, now that I've set it up, looked at it, and given it some
thought,
> > the
> > > answer is really quite simple.
> > > being a simple person myself, I like it when answers are simple. think
> > > "classful nature of eigrp"
> > >
> > > see below
> > >
> > >
> > > ""Wei Zhu""  wrote in message
> > > news:200301160146.BAA24069@xxxxxxxxxxxxxxxxx
> > > > ---EIGRP 100--(S0)---R1---(S1)--BGP AS 200---
> > > >
> > > > R1
> > > > S0 192.168.1.1 255.255.255.240
> > > > S1 172.22.2.1 255.255.255.0
> > > > S0 side run EIGRP, S1 side run BGP
> > > >
> > > > (1)
> > > > router eigrp 200
> > > > network 192.168.1.0
> > > >
> > > > router bgp
> > > > nei XXXX remote-as XXX
> > > >
> > > > R1 will send 192.168.1.0 route info through S0, but won't send the
> > > > 172.22.2.0 network info.
> > > >
> > > > (2)
> > > > ip route 0.0.0.0 0.0.0.0 S1
> > > >
> > > > router eigrp 200
> > > > network 192.168.1.0
> > > > redistrib static
> > > >
> > > > Everything works fine
> > > >
> > > > (3)
> > > > If using network 0.0.0.0 to redistribute static info as:
> > > > ip route 0.0.0.0 0.0.0.0 S1
> > > >
> > > > router eigrp 200
> > > > network 192.168.1.0
> > > > network 0.0.0.0
> > > >
> > > > In addition of distribute the 0.0.0.0, R1 will also distribute
> > 172.22.0.0
> > > > (summury) network info through S0
> > >
> > > first of all, you are not seeing the whole picture because of the
limited
> > > numbers of interfaces you have in your basic setup.
> > >
> > > second of all, let me ask you a question. what exactly is 0.0.0.0?
> > >
> > > thirdly, having answered and understood what exactly 0.0.0.0 really
> > > represents, let me ask you another question. what happens when you put
> the
> > > entry "network 0.0.0.0" into the eigrp process? will eigrp still work
if
> > you
> > > were to now remove the "network 192.168.1.0" statement? why not?
> > >
> > > this is starting to feel like another homily.
> > >
> > >
> > > > It will also put 172.22.0.0/16 null0 route entry into its routing
> table.
> > >
> > > nature of the beast. I don't believe it is true of all protocols, but
> some
> > > of them will automatically place a summary to null 0 when a summary is
> > > advertised out. This is done as proof against black holes and helps
> > prevent
> > > routing loops
> > >
> > > BTW, I enjoy your posts. Keep up the good work.
> > >
> > > >
> > > > Can anyone explain why this happens?
> >
> >
> > oh, you know what, while composing a reply to cebuano, I realized - you
> > probably have automaticic summarization enabled under eigrp
> >
> > enter the command "no auto-summary" and watch the staic to null 0
> disappear.
> >
> >
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> > > >
> > > > Thanks
> > > > Wei




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=61241&t=61241
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to abuse@xxxxxxxxxxxxxx