GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: Possible CDP bug? Check it out! [7:59929] posted 01/03/2003
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


""steve""  wrote in message
news:200301031620.QAA04616@xxxxxxxxxxxxxxxxx
> hey..
>
>
> AT Last i think i can try and properly help someone ....yippe..
>
> on your switches type this message
>
> no cdp advertise V2
>
> i have had this all over my network ..and you are correct it is a bug in
CDP


yep - changing to ver 1 eliminates the problem. interesting.

the other part of this is the duplex issue on the 2611.  CDP ver 2 claims
the port is half duplex. the router and the switch claim it is full duplex.
I know that originally the 2610/11 were 10 meg half, and that IOS
12.something allowed one to bring this up to full. I suspect there is still
an IOS bug someplace that is involved. I do not recall this issue when I was
writing my VPN tunnel lab for Cert Zone. At the time I was using my
employer's engineering lab, and IIRC the routers in question were 2621 -
different hardware beast.

live and learn.



> ..
>
> according to cisco ,this isn`t a fix just a work around
>
> H(and i mean HOPE)TH
>
> steve skinner
> (CCxx MCxx HPxx SCxx CSxx.....you know i wish i had some proper certs and
> not just the xx ones)
> ----- Original Message -----
> From: "The Long and Winding Road"
> To:
> Sent: Sunday, December 29, 2002 9:06 AM
> Subject: Possible CDP bug? Check it out! [7:59929]
>
>
> > I've run into this situation while doing some practicing with the 3550s
> and
> > some routers
> >
> > 2611------3550-------3550--------3640
> >
> > all ethernet ports are set at full duplex 10 megabit speed.
> >
> > the 2611 and the 3640 are connected via a vlan tunnel.
> >
> > everything is working fine, until I turn on l2protocol-tunnel cdp on
both
> > switches, at which point I get the following error:
> >
> > 3640
> > FrameSwitch#
> > 1w0d: %CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on Ethernet0/1
> (not
> > hal
> > f duplex), with Router_14_2611 Ethernet0/1 (half duplex).
> >
> > 2611
> > 1w0d: %CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on Ethernet0/1
> (not
> > ful
> > l duplex), with FrameSwitch Ethernet0/1 (full duplex).
> >
> > as near as I can tell, there are no errors on any of the interfaces. no
> > collisions, etc. not that I'm sending a lot of traffic during these
> studies,
> > but extended pings don't come up with anything either.
> >
> > relevant configurations for all interfaces. as you can see, everything
> > agrees all along the line. everyone is set for speed 10 and duplex full.
> if
> > I turn off l2protocol-tuinnel cdp on the interfaces, the error messages
> > disappear. I suspect a bug in CDP, but I'm wondering if I have missed
> > anything.
> >
> > 2611
> > -------
> > interface Ethernet0/1
> >  no ip address
> >  full-duplex
> > !
> > interface Ethernet0/1.1
> >  encapsulation dot1Q 121
> >  ip address 122.1.1.1 255.255.255.0
> > !
> > interface Ethernet0/1.2
> >  encapsulation dot1Q 122
> >  ip address 122.1.2.1 255.255.255.0
> > !
> > interface Ethernet0/1.3
> >  encapsulation dot1Q 123
> >  ip address 122.1.3.1 255.255.255.0
> > !
> > interface Ethernet0/1.4
> >  encapsulation dot1Q 124
> >  ip address 122.1.4.1 255.255.255.0
> > !
> >
> > Switch_24#sri f0/1
> > Building configuration...
> >
> > Current configuration : 200 bytes
> > !
> > interface FastEthernet0/1
> >  switchport access vlan 100
> >  switchport mode dot1q-tunnel
> >  no ip address
> >  duplex full
> >  speed 10
> >  l2protocol-tunnel cdp
> >  no cdp enable
> >  spanning-tree bpdufilter enable
> > end
> >
> > interface FastEthernet0/26
> >  switchport access vlan 100
> >  switchport mode dot1q-tunnel
> >  no ip address
> >  duplex full
> >  speed 10
> >  l2protocol-tunnel cdp
> >  no cdp enable
> >  spanning-tree bpdufilter enable
> > end
> >
> > 3640
> > -------
> > interface Ethernet0/1
> >  no ip address
> >  no ip redirects
> >  full-duplex
> >  priority-group 1
> > !
> > interface Ethernet0/1.1
> >  encapsulation dot1Q 121
> >  ip address 122.1.1.2 255.255.255.0
> > !
> > interface Ethernet0/1.2
> >  encapsulation dot1Q 122
> >  ip address 122.1.2.2 255.255.255.0
> > !
> > interface Ethernet0/1.3
> >  encapsulation dot1Q 123
> >  ip address 122.1.3.2 255.255.255.0
> > !
> > interface Ethernet0/1.4
> >  encapsulation dot1Q 124
> >  ip address 122.1.4.2 255.255.255.0
> > !
> >
> > Chuck
> > --
> > TANSTAAFL
> > "there ain't no such thing as a free lunch"




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=60230&t=59929
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to abuse@xxxxxxxxxxxxxx