GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: DHCP Server on Multiple VLANs [7:49403] posted 07/24/2002
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


That's exactly what he should do........

"Winston Shaw"  wrote in message
news:200207232132.VAA03791@xxxxxxxxxxxxxxxxx
> Hello Don,
>
> I think you could set up DHCP scopes on a server and use the "ip helper
> address" command to direct dhcp discover broadcasts from your clients. The
> router should place its own sub-interface address in the packet and send
it
> to the DHCP server. The server should then pick from the corresponding
scope
> depending on the router IP address. I know of at least one server which
does
> that but I do not want to mention it here.
>
> Winston V. Shaw
> CCIE(#7991)
>
>
>
> -----Original Message-----
> From: Don Pezet [mailto:dpezet@xxxxxxxxxxxx]
> Sent: Monday, July 22, 2002 1:15 PM
> To: cisco@xxxxxxxxxxxxxx
> Subject: DHCP Server on Multiple VLANs [7:49403]
>
>
> Hey guys,
>
>      I have a Cisco 3620 connected to a 2948G-L3 which
> in turn provides layer three services to a cluster of
> 3548XLs. I have 9 operating VLANs and have been trying
> to work out a scenario for DHCP in my environment.
> Right now, we assign static IPs in all 9 vlans because
> we do not want to provide seperate DHCP servers for
> each. If we could find a way to get one server to
> provide DHCP to all the VLANs then we could implement
> it. The trick is, each VLAN is a different subnet.
>
>      I had heard that if you use the 3620 as a DHCP
> server, create subinterfaces on a FE port using ISL and
> assign IP addresses appropriately, and create multiple
> DHCP pools, then the router would issues IPs from pools
> that matched the interface it drew the request from.
> However, when I try this it just issues IPs from the
> first pool until it is full and then moves to the next.
>
>      Is there a way to make sure the router assigns
> correct IPs on the correct sub-interfaces? Is there a
> 3rd party DHCP server that would do this better?
>
>      Let me do a sample config to show what I tried.
> Each network has a network printer at .200 (don't ask)
> and a router sub-interface at .1 except the 10.10.10.0
> network which has reserved IPs through 100, but still a
> router interface at .1
>
> Here's the Cisco 3620 DHCP portion of the config:
> !
> ip dhcp excluded-address 10.10.10.1 10.10.10.100
> ip dhcp excluded-address 192.168.1.1
> ip dhcp excluded-address 192.168.1.200
> ip dhcp excluded-address 192.168.2.1
> ip dhcp excluded-address 192.168.2.200
> ip dhcp excluded-address 192.168.3.1
> ip dhcp excluded-address 192.168.3.200
> ip dhcp excluded-address 192.168.4.1
> ip dhcp excluded-address 192.168.4.200
> ip dhcp excluded-address 192.168.5.1
> ip dhcp excluded-address 192.168.5.200
> ip dhcp excluded-address 192.168.6.1
> ip dhcp excluded-address 192.168.6.200
> ip dhcp excluded-address 192.168.7.1
> ip dhcp excluded-address 192.168.7.200
> ip dhcp excluded-address 192.168.8.1
> ip dhcp excluded-address 192.168.8.200
> !
> ip dhcp pool Vlan1
>   network 10.10.10.0 /24
>   dns-server 4.2.2.1
>   default-router 10.10.10.1
> !
> ip dhcp pool Vlan10
>   network 192.168.1.0 /24
>   dns-server 4.2.2.1
>   default-router 192.168.1.1
> !
> ip dhcp pool Vlan20
>   network 192.168.2.0 /24
>   dns-server 4.2.2.1
>   default-router 192.168.2.1
> !
> ip dhcp pool Vlan30
>   network 192.168.3.0 /24
>   dns-server 4.2.2.1
>   default-router 192.168.3.1
> !
> ip dhcp pool Vlan40
>   network 192.168.4.0 /24
>   dns-server 4.2.2.1
>   default-router 192.168.4.1
> !
> ip dhcp pool Vlan50
>   network 192.168.5.0 /24
>   dns-server 4.2.2.1
>   default-router 192.168.5.1
> !
> ip dhcp pool Vlan60
>   network 192.168.6.0 /24
>   dns-server 4.2.2.1
>   default-router 192.168.6.1
> !
> ip dhcp pool Vlan70
>   network 192.168.7.0 /24
>   dns-server 4.2.2.1
>   default-router 192.168.7.1
> !
> ip dhcp pool Vlan80
>   network 192.168.8.0 /24
>   dns-server 4.2.2.1
>   default-router 192.168.8.1
> !
> interface FastEthernet1/0
>  description connected to Private Network
>  no ip address
>  duplex auto
>  speed auto
> !
> interface FastEthernet1/0.1
>  encapsulation isl 1
>  ip address 10.10.10.1 255.255.255.0
>  no ip redirects
> !
> interface FastEthernet1/0.10
>  encapsulation isl 10
>  ip address 192.168.1.1 255.255.255.0
>  no ip redirects
> !
> interface FastEthernet1/0.20
>  encapsulation isl 20
>  ip address 192.168.2.1 255.255.255.0
>  no ip redirects
> !
> interface FastEthernet1/0.30
>  encapsulation isl 30
>  ip address 192.168.3.1 255.255.255.0
>  no ip redirects
> !
> interface FastEthernet1/0.40
>  encapsulation isl 40
>  ip address 192.168.4.1 255.255.255.0
>  no ip redirects
> !
> interface FastEthernet1/0.50
>  encapsulation isl 50
>  ip address 192.168.5.1 255.255.255.0
>  no ip redirects
> !
> interface FastEthernet1/0.60
>  encapsulation isl 60
>  ip address 192.168.6.1 255.255.255.0
>  no ip redirects
> !
> interface FastEthernet1/0.70
>  encapsulation isl 70
>  ip address 192.168.7.1 255.255.255.0
>  no ip redirects
> !
> interface FastEthernet1/0.80
>  encapsulation isl 80
>  ip address 192.168.8.1 255.255.255.0
>  no ip redirects
> !
>
>
> Thanks,
>
> Don Pezet
> dpezet@xxxxxxxxxxxx




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=49505&t=49403
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to abuse@xxxxxxxxxxxxxx