GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: ISDN and PPP multilink posted 03/26/1999
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Does your ISP uses PAP or CHAP for authentication? It seams that you have
the PAP defined on the BRI0 interface and PAP AND CHAP defined on the
Dialer1 interface.

Usually the ISPs use CHAP. 

Also, I don't see any advantage on you case to use a Dialer interface,
though there is no problem. You can try to make your configuration as simple
as:

interface BRI0
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 714577xxxxxxxx 714577xxxx
 isdn spid2 714577yyyyyyyy 714577yyyy
 isdn incoming-voice modem ---------> remove this line just to test
 ppp authentication pap callin  ---------> remove this line
 ppp pap sent-username mkpettit password 7 xxxxxxxx ->remove this line
!
interface Dialer1
 description ISP
 ip address negotiated
 no ip directed-broadcast
 no ip proxy-arp
 ip nat outside
 encapsulation ppp
 no ip split-horizon
 dialer remote-name Cisco1
 dialer idle-timeout 300
 dialer string 692xxxx
 dialer hold-queue 10
 dialer load-threshold 50 either
 dialer pool 1
 dialer-group 1
 pulse-time 0
 no cdp enable
 ppp authentication chap ---> remove this part: pap callin
 ppp chap hostname mkpettit
 ppp chap password 7 xxxxxxxx
 ppp pap sent-username mkpettit password 7 xxxxxxxx ->remove this line
 ppp multilink


Something else I noticed that could be problem (on the BRI0):

 isdn spid1 714577xxxxxxxx 714577xxxx
 isdn spid2 714577yyyyyyyy 714577yyyy

Is 714 your area code? If so, try to change this line to (remove the area
code from the number):

 isdn spid1 714577xxxxxxxx 577xxxx
 isdn spid2 714577yyyyyyyy 577yyyy

If it does not work yet, set the debug as follows and send the results:

deb ppp aut
deb ppp neg
deb ppp mult eve
deb isd q931
deb isd eve

Good luck!

Guilherme.



-----Original Message-----
From: Mark K. Pettit [mailto:mpettit@xxxxxxxxxxxx]
Sent: March 26, 1999 4:52 AM
To: cisco@xxxxxxxxxxxxxx
Subject: ISDN and PPP multilink


Hi, all.

Thanks for all of the helpful input about my bootflash problems on my
4000 recently.  I haven't had time to try them all out, since it's a
production router, but I'll definitely give it a shot when I set my
other one up in the next week or so.

I have a separate question now about an ISDN problem.  I have a Cisco
804 at home, and am trying to get PPP multilink to work.  It used to
work with my 3Com ImpactIQ modem with the same ISP, so I'm pretty sure
that I just have something configured wrong on the router.

The symptoms are that DDR seems to work great.  I can get the router to
dial my ISP whenever I need it to.  But when I configure a "dialer
load-threshold", the 2nd B channel comes up and goes down over and over
again, never coming all the way up.

Here are some relevant sections of the configure file.  I'm running
12.0(3)T1, BTW:

===============================================================
isdn switch-type basic-ni
!
interface BRI0
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 714577xxxxxxxx 714577xxxx
 isdn spid2 714577yyyyyyyy 714577yyyy
 isdn incoming-voice modem
 ppp authentication pap callin
 ppp pap sent-username mkpettit password 7 xxxxxxxx
!
interface Dialer1
 description ISP
 ip address negotiated
 no ip directed-broadcast
 no ip proxy-arp
 ip nat outside
 encapsulation ppp
 no ip split-horizon
 dialer remote-name Cisco1
 dialer idle-timeout 300
 dialer string 692xxxx
 dialer hold-queue 10
 dialer load-threshold 50 either
 dialer pool 1
 dialer-group 1
 pulse-time 0
 no cdp enable
 ppp authentication chap pap callin
 ppp chap hostname mkpettit
 ppp chap password 7 xxxxxxxx
 ppp pap sent-username mkpettit password 7 xxxxxxxx
 ppp multilink
!
ip nat inside source list 18 interface Dialer1 overload
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 18 permit 10.0.0.0 0.255.255.255
access-list 100 deny   udp any any eq netbios-ns log
access-list 100 deny   udp any any eq netbios-dgm log
access-list 100 deny   udp 10.0.0.0 0.255.255.255 eq netbios-ns any log
access-list 100 deny   tcp any 207.46.0.0 0.0.255.255 log
access-list 100 permit ip any any log
dialer-list 1 protocol ip list 100
!
===============================================================

Some of that is cruft from my attempt to use the "Cisco Fast Step"
software, which didn't work because of a bug in their software.  My
"access-list 100" has the extra stuff in there because of a lot of
hacking with packet sniffers trying to find out why my connection was
almost always up.  :-)

Here's what some output from "debug isdn events", "debug ppp auth", and
"debug ppp multilink events":

Near as I can tell, the connection succeeds, PAP authenticates
correctly, and then the interface is immediately unbound from the
"profile Dialer1", which causes the call to be hung up.  It's all very
strange.

===============================================================
00:47:03: ISDN BR0: Outgoing call id = 0x801D, dsl 0
00:47:12884942848: ISDN BR0: Event: Call to 692xxxx at 64 Kb/s
00:47:12890928736: ISDN BR0: process_bri_call(): call id 0x801D,
called_number 692xxxx, speed 64, call type DATA
00:47:04: ISDN BR0: Event: incoming ces value = 2
00:47:04: ISDN BR0: received HOST_PROCEEDING call_id 0x801D
00:47:05: ISDN BR0: Event: incoming ces value = 2
00:47:05: ISDN BR0: received HOST_ALERTING call_id 0x801D
00:47:05: ISDN BR0: HOST_PROGRESS: VOICE ERROR FB: bchan -1, call id 801D
00:47:05: ISDN BR0: Event: incoming ces value = 2
00:47:05: ISDN BR0: received HOST_CONNECT call_id 0x801D
00:47:05: %LINK-3-UPDOWN: Interface BRI0:2, changed state to up
00:47:05: %DIALER-6-BIND: Interface BRI0:2 bound to profile Dialer1
00:47:05: BR0:2 PPP: Treating connection as a callout
00:47:05: ISDN BR0: Event: Connected to 692xxxx on B2 at 64 Kb/s
00:47:25769803775: ISDN BR0: L1 ERR IF_ACTIVE
00:47:07: BR0:2 PPP: Phase is AUTHENTICATING, by the peer
00:47:07: BR0:2 PAP: O AUTH-REQ id 22 len 21 from "mkpettit"
00:47:07: BR0:2 PAP: I AUTH-ACK id 22 len 5
00:47:09: %DIALER-6-UNBIND: Interface BRI0:2 unbound from profile Dialer1
00:47:38660732108: ISDN BR0: Event: Hangup call to call id 0x801D  ces = 2
00:47:38660732340: ISDN BR0: process_disconnect(): call id 0x801D, call type
is DATA, b_idb 0x2720FB8, ces 2
00:47:42949672971: %ISDN-6-DISCONNECT: Interface BRI0:2  disconnected from
692xxxx , call lasted 4 seconds
00:47:42949673024: ISDN BR0: Event: Hangup call to call id 0x801D  ces =1
00:47:42955699636: ISDN BR0: process_disconnect(): call id 0x801D, call type
is DATA, b_idb 0x2720FB8, ces 1
00:47:10:     CC: dsl 0 No CCB Src->HOST cid 0x801D, ev 0x5 ces 1
00:47:10: ISDN BR0: received HOST_QUERY_RESPONSE call_id 0x801D
00:47:10: ISDN BR0: Outgoing call id = 0x801E, dsl 0
00:47:42949713920: ISDN BR0: Event: Call to 692xxxx at 64 Kb/s
00:47:42955699808: ISDN BR0: process_bri_call(): call id 0x801E,
called_number 692xxxx, speed 64, call type DATA
00:47:10: ISDN BR0: Event: incoming ces value = 2
00:47:10: ISDN BR0: received HOST_DISCONNECT_ACK call_id 0x80000
00:47:10: ISDN BR0: Error: Unfound B-channel on Disconnect_Ack - callid
0x801E
00:47:10: ISDN BR0: HOST_DISC_ACK Voice cid 0x801E error
00:47:10: ISDN BR0: Event: incoming ces value = 2
00:47:10: ISDN BR0: received HOST_DISCONNECT_ACK call_id 0x80000
00:47:10: ISDN BR0: HOST_DISCONNECT_ACK: call type is DATA
===============================================================

Thanks in advance for any help with this.  You guys are great!  :-)

-- 
Mark K. Pettit, CCNA
mpettit@xxxxxxxxxxxx
Sr. System Administrator / Network Administrator
GeoCities, 4499 Glencoe Ave., Marina del Rey, CA, 90292
---------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com
---------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com