GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: IOS DHCP server - how to test assigned backup default gateway? posted 11/10/2008
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Hi Luan,
 
Thanks for your help, and the link. Obviously, if we have a choice, then one
of next hop redundancy protocols would be better, than the secondary default
IP here. But this is in the lab scenario context, where we might not have such
a choice.
 
According to that the dead gateway detection is a feature implemented by
Windows TCP/IP stack,
 
"Dead gateway detection is used by the TCP component of Windows TCP/IP to
detect the failure of the default gateway and to adjust the IP routing table
to use the next default gateway when there are multiple default gateways
configured."
 
This means, that IOS may or maynot support this feature.
 
I tried telnet (using TCP in stead of ICMP pings) from the DHCP client (R1),
to see if it helps, but it does not. If IOS does not suport dead gateway
detection, then we just use best effort, put the config in, and move on then.
 
 
Rack1R1#telnet 155.1.45.4
Trying 155.1.45.4 ...
% Connection timed out; remote host not responding
Rack1R1#telnet 155.1.45.4
Trying 155.1.45.4 ...
% Connection timed out; remote host not responding
 
Rack1R1#sh ip route
Default gateway is 155.1.146.6
Host               Gateway           Last Use    Total Uses  Interface
ICMP redirect cache is empty

 


--- On Tue, 11/11/08, Luan Nguyen <luan@xxxxxxxxxxxxxxxx> wrote:

From: Luan Nguyen <luan@xxxxxxxxxxxxxxxx>
Subject: RE: IOS DHCP server - how to test assigned backup default gateway?
To: "'Huan Pham'" <pnhuan@xxxxxxxxx>, "'CCIE Lab'" <ccielab@xxxxxxxxxxxxxx>
Date: Tuesday, November 11, 2008, 1:02 AM

Microsoft has a feature Dead Gateway Detection
http://technet.microsoft.com/en-us/library/bb878104.aspx

In term of network design, I would suggest provide a couple of downstream
devices to do HSRP/VRRP/GLBP and hand out the virtual address.

Luan Nguyen
Chesapeake NetCraftsmen, LLC.
www.NetCraftsmen.net



-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of Huan
Pham
Sent: Monday, November 10, 2008 7:48 AM
To: CCIE Lab
Subject: IOS DHCP server - how to test assigned backup default gateway?

Hi GS,

The IOS DHCP server feature allows us to specify up to 8 default gateways,
in
order of preference. My question are:

- How DHCP clients keep track of the the primary default gateway, so that
when
it dies, clients can switch to the backup gateway?

- How to verify if this feature works.

I have set up a similar scenario, with R6 as the primary gateway, and R4 as
the backup. R1 is a DHCP client. All three belong to VLAN146. R1 correctly
picks up R6 as the default gateway. But I do not know how to verify if R1
picks up R4 as the backup gateway. When R6 dies, it seems that R1 still
points
its default gateway to R6 :((

Thanks in advance for your help.


Rack1R6#

ip dhcp pool VLAN146_POOL
   network 155.1.146.0 255.255.255.0
   default-router 155.1.146.6 155.1.146.4
!
interface FastEthernet0/0.146
 description **** connect to VLAN146
 encapsulation dot1Q 146
 ip address 155.1.146.6 255.255.255.0
! to simulate as DHCP client
Rack1R1#
!
interface FastEthernet0/0
 description **** connect to VLAN146
 ip address dhcp
no ip routing

Rack1R1#sh ip int fa0/0
FastEthernet0/0 is up, line protocol is up
  Internet address is 155.1.146.2/24
  Broadcast address is 255.255.255.255
  Address determined by DHCP

Rack1R1#sh ip route
Default gateway is 155.1.146.6
Host               Gateway           Last Use    Total Uses  Interface
ICMP redirect cache is empty

Rack1R1#sh arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  155.1.146.1             -   000b.5f76.7280  ARPA   FastEthernet0/0

Rack1R1#ping 155.1.146.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 155.1.146.6, timeout is 2 seconds:
...
Success rate is 0 percent (0/3)
Rack1R1#sh arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  155.1.146.1             -   000b.5f76.7280  ARPA   FastEthernet0/0
Internet  155.1.146.6             0   Incomplete      ARPA


Blogs and organic groups at http://www.ccie.net

_______________________________________________________________________
Subscription information may be found at:
http://www.groupstudy.com/list/CCIELab.html


Blogs and organic groups at http://www.ccie.net

_______________________________________________________________________
Subscription information may be found at:
http://www.groupstudy.com/list/CCIELab.html