GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: undo in IOS posted 11/05/2008
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


reload in...   works for me but does not do so good on CatOS or for the VLAN
Database or VTP and a few other things like System MTU and SDM etc.  To name
a few...





On Wed, Nov 5, 2008 at 1:04 PM, Victor Cappuccio <vcappuccio@xxxxxxxxx>wrote:

> how about configure replace?
>
>
> http://www.cisco.com/en/US/docs/ios/12_3t/12_3t7/feature/guide/gtrollbk.html
>
> these is a greate article http://www.nil.si/ipcorner/ConfigReplacement/
>
> that states:
>
> strongly recommend using it to track changes that Cisco IOS made to the
> current configuration.
>
> Listing 1
>
> Changing interface IP addresses
>
> fw#configure terminal
>
> Enter configuration commands, one per line.  End with CNTL/Z.
>
> fw(config)#interface loopback 0
>
> fw(config-if)#ip address 10.1.1.1 255.255.255.255
>
> fw(config-if)#exit
>
> fw(config)#interface FastEthernet 0/0
>
> fw(config-if)#shutdown
>
> fw(config-if)#ip address 1.2.3.4 255.255.0.0
>
> fw(config-if)#^Z
>
> Listing 2
>
> Rollback to the startup configuration
>
> fw#*configure replace nvram:startup-config list*
>
> This will apply all necessary additions and deletions
>
> to replace the current running configuration with the
>
> contents of the specified configuration file, which is
>
> assumed to be a complete configuration, not a partial
>
> configuration. Enter Y if you are sure you want to proceed. ? [no]: *y*
>
> !Pass 1
>
> !List of Commands:
>
> no interface Loopback0
>
> interface FastEthernet0/0
>
>  no ip address 1.2.3.4 255.255.0.0
>
>  no shutdown
>
> interface FastEthernet0/0
>
>  ip address 10.0.0.1 255.255.255.0
>
> end
>
> Total number of passes: 1
>
> Rollback Done
>
> Most commonly, the configuration rollback would be used to replace the
> current configuration with the startup one. You can, however, use any file
> transfer method supported by Cisco IOS to fetch the target configuration.
> For example, if you have configured the Configuration Archive feature, you
> can use the *show archive* command to identify the URL of a previously
> saved
> router configuration and use that URL in the *configur**e** replace*
> command
> (Listing 3).
>
> Listing 3
>
> Rollback to an archived configuration
>
> fw#*show archive*
>
> The next archive file will be named tftp://10.0.0.2/fw.cfg-67
>
>  Archive #  Name
>
>   0       tftp://10.0.0.2/fw.cfg-60
>
>   1       tftp://10.0.0.2/fw.cfg-61
>
>   2       tftp://10.0.0.2/fw.cfg-62
>
>   3       tftp://10.0.0.2/fw.cfg-63
>
>   4       tftp://10.0.0.2/fw.cfg-64
>
>   5       tftp://10.0.0.2/fw.cfg-65
>
>   6       tftp://10.0.0.2/fw.cfg-66 <- Most Recent
>
>   7       tftp://10.0.0.2/fw.cfg-52
>
>   8       tftp://10.0.0.2/fw.cfg-53
>
>   9       tftp://10.0.0.2/fw.cfg-54
>
>   10       tftp://10.0.0.2/fw.cfg-55
>
>   11       tftp://10.0.0.2/fw.cfg-56
>
>   12       tftp://10.0.0.2/fw.cfg-57
>
>   13       tftp://10.0.0.2/fw.cfg-58
>
>   14       tftp://10.0.0.2/fw.cfg-59
>
> fw#*configure replace tftp://10.0.0.2/fw.cfg-66 list*
>
> This will apply all necessary additions and deletions
>
> to replace the current running configuration with the
>
> contents of the specified configuration file, which is
>
> assumed to be a complete configuration, not a partial
>
> configuration. Enter Y if you are sure you want to proceed. ? [no]: *y*
>
> Loading fw.cfg-66 from 10.0.0.2 (via FastEthernet0/0): !
>
> [OK - 2150 bytes]
>
>  rest deleted
>
>
>
> On Wed, Nov 5, 2008 at 5:58 PM, Ovais Iqbal <ovais.iqball@xxxxxxxxx>
> wrote:
>
> > Well pardon me if i am mistaken but what i understand is that
> > If start-up config is at default and by copying it to running-config, all
> > of the running config will be rolled backed or kinda erased right ? if
> that
> > what you mean then i have tried it before and it doesnt work. If a
> command
> > is there in running-config and you are not issuing its negate through
> "no",
> > then the command will remain present in running-config.
> >
> > Correct me if i am wrong
> >
> > --- On Wed, 11/5/08, Fahad Khan <fahad.khan@xxxxxxxxx> wrote:
> > From: Fahad Khan <fahad.khan@xxxxxxxxx>
> > Subject: Re: undo in IOS
> > To: "Supreme Nkosi" <supreme.nkosi@xxxxxxxxx>
> > Cc: yungli2008@xxxxxxxxx, ccielab@xxxxxxxxxxxxxx
> > Date: Wednesday, November 5, 2008, 10:39 AM
> >
> > by "copy start run" , all the configurations made from the start will
> > be
> > rolled back. I think youngli2008 is asking for single command rollback.
> >
> > On 11/5/08, Supreme Nkosi <supreme.nkosi@xxxxxxxxx> wrote:
> > >
> > > If I understand your question correctly - you can as stated below use
> the
> > > "no" keyword or alternatively, that`s if you have not saved do a
> >  "copy
> > > start run" to rollback.
> > >
> > > hope this helps
> > > spin
> > >
> > >
> > > On Wed, Nov 5, 2008 at 11:51 AM, <yungli2008@xxxxxxxxx> wrote:
> > >
> > > > Is any UNDO method is there in IOS?
> > > > I mean If I wrongly entered a command I want to undo it. is it
> > possible?
> > > > Thanks
> > > > Li
> > > >
> > > >
> > > > Blogs and organic groups at http://www.ccie.net
> > > >
> > > >
> > _______________________________________________________________________
> > > > Subscription information may be found at:
> > > > http://www.groupstudy.com/list/CCIELab.html
> > >
> > >
> > > Blogs and organic groups at http://www.ccie.net
> > >
> > > _______________________________________________________________________
> > > Subscription information may be found at:
> > > http://www.groupstudy.com/list/CCIELab.html
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> >
> >
> > --
> > Fahad Khan
> >
> >
> > Blogs and organic groups at http://www.ccie.net
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> >
> > Blogs and organic groups at http://www.ccie.net
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> >
> >
> >
> >
> >
> >
> >
>
>
> --
> Victor Cappuccio
> CCIE R/S# 20657
> CCSI# 30452
> www.anetworkerblog.com
>
>
> Blogs and organic groups at http://www.ccie.net
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html