GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: Cisco DOCS confusion posted 09/20/2008
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


You can also disable automatic summarization in eigrp and get over the network wildcard mask hassles to some extent.

no auto-summary

Doyle Vol I pp315-316

I have seen a number of variants in practice lab examples.



----- Original Message ----- From: "Huan Pham" <pnhuan@xxxxxxxxx>
To: <ccielab@xxxxxxxxxxxxxx>; "CCIE unnumbered" <ccie.unnumbered@xxxxxxxxx>
Sent: Saturday, September 20, 2008 11:12 AM
Subject: Re: Cisco DOCS confusion



This is a terrible example in the DOC CD. I cannot understand why it exists in the DOC CD!!! It is just a terriblly wrong example, in my opinion.

(1) I thought all three routes were advertised by
"network" command under router eigrp 1

No, you are not correct. All three routes are advertized by the redistribute static command.


In the EIGRP, similar to all IGP, the network command is to specify what interface(s) take part in the routing protocol. It is not to advertize the subnets specify by that statement.

EIGRP also requires you to put the wildcard mask. If you do not, then EIGRP a classfull network is specified.

In the example

router eigrp 1
network 10.10.10.0

is the same as

router eigrp 1
network 10.0.0.0

or

router eigrp 1
network 10.0.0.0 0.255.255.255

In EIGRP there's one special case where the network statement also advertizes the route, is when you do network 0.0.0.0 and you have a static default route. In this case, the network 0.0.0.0 statement also enables EIGRP on all interfaces as well.

router eigrp 1
network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 null0

In the DOC CD examle, these network statments for 192.168.0.0 and 10.10.10.0 have nothing to do with the usage of distribute-list to control redistribution from Static to EIGRP!

(2) the access-list 3 permit 192.168.x.0 should have
wildcard mask 0.0.0.255?

You are right. Doc CD is wrong.


(3) I thought all three routes were redistributed by the
*redistribute
static* router configuration?

You are right. I do not know what they meant to blocked here ;) Maybe they mean "deny 10.10.10.0 0.0.0.255" to block the last one (???!!!)


(4) what does the *distribute-list 3 out static* command do
in this case?

Nothing, unless they change the ACL 3 to block one of the three subnets. In that case, the one blocked by the ACL will not be advertized into EIGRP.






--- On Sat, 9/20/08, CCIE unnumbered <ccie.unnumbered@xxxxxxxxx> wrote:

From: CCIE unnumbered <ccie.unnumbered@xxxxxxxxx>
Subject: Cisco DOCS confusion
To: ccielab@xxxxxxxxxxxxxx
Date: Saturday, September 20, 2008, 3:20 PM
Dear Groupstudy Experts:

Please find a digest from
http://www.cisco.com/en/US/docs/ios/iproute/configuration/guide/irp_ip_prot_indep_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1057083
in the end of this message, and help me explain the
description of the
section.  (1) I thought all three routes were advertised by
"network"
command under router eigrp 1
(2) the access-list 3 permit 192.168.x.0 should have
wildcard mask 0.0.0.255?
(3) I thought all three routes were redistributed by the
*redistribute
static* router configuration?
(4) what does the *distribute-list 3 out static* command do
in this case?

Static Routing Redistribution Example

In the example that follows, three static routes are
specified, two of which
are to be advertised. The static routes are created by
specifying the
*redistribute
static* router configuration command and then specifying an
access list that
allows only those two networks to be passed to the EIGRP
process. Any
redistributed static routes should be sourced by a single
router to minimize
the likelihood of creating a routing loop.

Router(config)# *ip route 192.168.2.0 255.255.255.0
192.168.7.65
*

 Router(config)# *ip route 192.168.5.0 255.255.255.0
192.168.7.65
*

 Router(config)# *ip route 10.10.10.0 255.255.255.0
10.20.1.2
*

 Router(config)# *!
*

 Router(config)# *access-list 3 permit 192.168.2.0
0.0.255.255
*

 Router(config)# *access-list 3 permit 192.168.5.0
0.0.255.255
*

 Router(config)# *access-list 3 permit 10.10.10.0 0.0.0.255
*

 Router(config)# *!
*

 Router(config)# *router eigrp 1
*

 Router(config-router)# *network 192.168.0.0
*

 Router(config-router)# *network 10.10.10.0
*

 Router(config-router)# *redistribute static metric 10000
100 255 1 1500
*

 Router(config-router)# *distribute-list 3 out static
*


Thanks, -- CCIE unnumbered


Blogs and organic groups at http://www.ccie.net


_______________________________________________________________________
Subscription information may be found at:
http://www.groupstudy.com/list/CCIELab.html


Blogs and organic groups at http://www.ccie.net

_______________________________________________________________________
Subscription information may be found at:
http://www.groupstudy.com/list/CCIELab.html