GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
OSPF virtual-link - Strange behaviour posted 05/08/2008
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Hi All,

--------R4---------------R1------------------R2
  Area0        Area10         Area20

In the above topology, as R1 is not directly connected to backbone, it is
not suppose to send any inter-area routes to R2. But when I configure "area
10 virtual-link 135.15.104.1" without any config in R4(ie, without any
neighborship over virtual-link between R1 and R4), R1 starts sending IA
routes to R2. Is this expected?. I checked the virtual-link status in R1 and
it seems to be up...I tried removing virtual-link command from R1 and
applied in R4. But the virtual-link is down. Is it expected?.


Logs:
------
R1(config-router)#do sh run | sec ospf
 ip ospf network point-to-point
 ip ospf network point-to-point
 ip ospf network non-broadcast
router ospf 1
 router-id 135.15.101.1
 log-adjacency-changes
 area 10 virtual-link 135.15.104.1
 network 135.15.12.0 0.0.0.255 area 20
 network 135.15.13.0 0.0.0.255 area 10
 network 135.15.14.0 0.0.0.255 area 10
 neighbor 135.15.12.2
R1(config-router)#
R1(config-router)#do sh ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface
135.15.103.1      0   FULL/  -        00:00:30    135.15.13.3
Ethernet0/0.10
135.15.104.1      0   FULL/  -        00:00:36    135.15.14.4
Serial5/0.1
135.15.102.1      0   FULL/DROTHER    00:01:30    135.15.12.2
Serial5/0.2
R1(config-router)#
R1(config-router)#do sh ip ospf virtual
Virtual Link OSPF_VL5 to router 135.15.104.1 is up
  Run as demand circuit
  DoNotAge LSA allowed.
  Transit area 10, via interface Serial5/0.1, Cost of using 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:00
R1(config-router)#
R2(config-subif)#do sh ip route ospf
     135.15.0.0/24 is subnetted, 9 subnets
O IA    135.15.13.0 [110/74] via 135.15.12.1, 00:02:25, Serial5/0.2
O IA    135.15.14.0 [110/128] via 135.15.12.1, 00:02:25, Serial5/0.2
O IA    135.15.34.0 [110/138] via 135.15.12.1, 00:02:25, Serial5/0.2
R2(config-subif)#