GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: Can't filter prefix longer than 24 from OSPF to RIP posted 12/31/2007
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


This is my show commands:

Rack1R1#sh ip ro ospf
O E2 204.12.1.0/24 [110/20] via 163.1.12.2, 02:01:57, Serial0/0/0
     163.1.0.0/16 is variably subnetted, 18 subnets, 3 masks
O E2    163.1.0.128/25 [110/20] via 163.1.15.5, 02:01:57, Tunnel0
O       163.1.35.0/24 [110/128] via 163.1.13.3, 02:01:57, Serial0/1/0
O E2    163.1.38.0/24 [110/20] via 163.1.13.3, 02:01:57, Serial0/1/0
O E2    163.1.45.5/32 [110/20] via 163.1.15.5, 02:01:57, Tunnel0
O E2    163.1.45.0/24 [110/20] via 163.1.15.5, 02:01:57, Tunnel0
O       163.1.54.0/24 [110/11175] via 163.1.15.5, 02:01:57, Tunnel0
O E2    163.1.57.0/24 [110/20] via 163.1.15.5, 02:01:57, Tunnel0
O E2    163.1.3.0/24 [110/20] via 163.1.15.5, 02:01:57, Tunnel0
O E2    163.1.0.0/25 [110/20] via 163.1.15.5, 01:49:21, Tunnel0
O E2    163.1.6.0/24 [110/20] via 163.1.12.2, 01:55:53, Serial0/0/0
O E2    163.1.7.0/24 [110/20] via 163.1.15.5, 02:01:57, Tunnel0
O       163.1.4.0/24 [110/11176] via 163.1.15.5, 02:01:57, Tunnel0
O       163.1.5.0/24 [110/11112] via 163.1.15.5, 02:01:57, Tunnel0
O E2 10.0.0.0/8 [110/20] via 163.1.15.5, 02:01:58, Tunnel0
O E2 192.10.1.0/24 [110/20] via 163.1.15.5, 02:01:58, Tunnel0
     150.1.0.0/16 is variably subnetted, 9 subnets, 3 masks
O E2    150.1.7.0/24 [110/20] via 163.1.15.5, 02:01:58, Tunnel0
O E2    150.1.6.0/24 [110/20] via 163.1.12.2, 01:55:55, Serial0/0/0
O       150.1.4.0/23 is a summary, 02:01:58, Null0
O E2    150.1.3.0/24 [110/20] via 163.1.13.3, 02:01:58, Serial0/1/0
O E2    150.1.2.0/24 [110/20] via 163.1.12.2, 02:01:58, Serial0/0/0
O       150.1.5.5/32 [110/11112] via 163.1.15.5, 02:02:01, Tunnel0
O       150.1.4.4/32 [110/11176] via 163.1.15.5, 02:02:01, Tunnel0
O E2    150.1.8.0/24 [110/20] via 163.1.13.3, 02:02:01, Serial0/1/0
Rack1R1#show run | se router ospf1
Rack1R1#show run | se router ospf
router ospf 1
 router-id 150.1.1.1
 log-adjacency-changes
 area 0 range 150.1.4.0 255.255.254.0
 redistribute connected subnets route-map CONNECTED->OSPF
 redistribute rip subnets route-map RIP->OSPF
 network 163.1.12.1 0.0.0.0 area 2
 network 163.1.13.1 0.0.0.0 area 1
 network 163.1.15.1 0.0.0.0 area 0
 neighbor 163.1.13.3
 neighbor 163.1.12.2
Rack1R1#sh run | sec interface
interface Loopback0
 ip address 150.1.1.1 255.255.255.0
interface Tunnel0
 ip address 163.1.15.1 255.255.255.0
 tunnel source 163.1.13.1
 tunnel destination 163.1.35.5
interface FastEthernet0/0
 ip address 163.1.18.1 255.255.255.0
 duplex auto
 speed auto
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
interface Serial0/0/0
 ip address 163.1.12.1 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 163.1.12.2 102 broadcast
 frame-relay lmi-type cisco
interface Serial0/1/0
 ip address 163.1.13.1 255.255.255.0
 encapsulation ppp
 ip ospf network non-broadcast
 clock rate 2000000
 ppp authentication pap
 ppp pap sent-username Rack1R1 password 0 CISCO
 passive-interface default
 no passive-interface FastEthernet0/0
 match interface Loopback0
Rack1R1#



On Dec 31, 2007 5:44 PM, Joseph Saad <joseph.samir.saad@xxxxxxxxx> wrote:

> I prefer to see "show ip route ospf" on R1 along with "sh runn | s router
> ospf 1" and "sh runn | s interface".
>
> Those routes may have been learnt via RIP itself.
>
> Joseph.
>
> On Dec 31, 2007 2:08 PM, nhatphuc <nhatphuc@xxxxxxxxx> wrote:
>
> > HI Group,
> >
> > Please help why I can't filter prefix longer than 24 redistributed into
> > RIP
> > from OSPF:
> >
> > This is my config:
> >
> > R1
> >
> > router rip
> >  version 2
> >  redistribute ospf 1 metric 1 route-map OSPF->RIP
> >  passive-interface default
> >  no passive-interface FastEthernet0/0
> >  network 163.1.0.0
> >  no auto-summary
> > !
> > ip forward-protocol nd
> > !
> > ip http server
> > no ip http secure-server
> > !
> > ip prefix-list NOT_LONGER24 seq 5 permit 0.0.0.0/0 le 24
> > !
> > route-map OSPF->RIP permit 10
> >  match ip address prefix-list NOT_LONGER24
> >
> > DEBUG IP RIP on R1:
> >
> > *Dec 31 17:42:39.209: RIP: sending v2 update to 224.0.0.9 via
> > FastEthernet0/0 (163.1.18.1)
> > *Dec 31 17:42:39.209: RIP: build update entries
> > *Dec 31 17:42:39.209:   10.0.0.0/8 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   150.1.2.0/24 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   150.1.3.0/24 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   150.1.4.0/23 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   150.1.4.4/32 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   150.1.5.5/32 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   150.1.6.0/24 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   150.1.7.0/24 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   150.1.8.0/24 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   163.1.0.0/25 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   163.1.0.128/25 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   163.1.3.0/24 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   163.1.4.0/24 via 0.0.0.0, metric 1, tag 0
> > Rack1R1#
> > *Dec 31 17:42:39.209:   163.1.5.0/24 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   163.1.6.0/24 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   163.1.7.0/24 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   163.1.12.0/24 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   163.1.13.0/24 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   163.1.13.3/32 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   163.1.15.0/24 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   163.1.35.0/24 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   163.1.38.0/24 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   163.1.45.0/24 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   163.1.45.5/32 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   163.1.54.0/24 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209: RIP: build update entries
> > *Dec 31 17:42:39.209:   163.1.57.0/24 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   192.10.1.0/24 via 0.0.0.0, metric 1, tag 0
> > *Dec 31 17:42:39.209:   204.12.1.0/24 via 0.0.0.0, metric 1, tag 0
> >
> > SW2 still see route longer than 24 from R1 (163.1.18.1)
> > SW2#
> > R    204.12.1.0/24 [120/1] via 163.1.18.1, 00:00:04, FastEthernet0/21
> > R       163.1.0.0/25 [120/4] via 163.1.18.1, 00:00:04, FastEthernet0/21
> > R       163.1.6.0/24 [120/1] via 163.1.18.1, 00:00:04, FastEthernet0/21
> > R       163.1.13.3/32 [120/4] via 163.1.18.1, 00:00:04, FastEthernet0/21
> > R       163.1.12.0/24 [120/1] via 163.1.18.1, 00:00:04, FastEthernet0/21
> > R       150.1.6.0/24 [120/4] via 163.1.18.1, 00:00:04, FastEthernet0/21
> > R       150.1.3.0/24 [120/4] via 163.1.18.1, 00:00:04, FastEthernet0/21
> > R       150.1.2.0/24 [120/1] via 163.1.18.1, 00:00:04, FastEthernet0/21
> > R       150.1.5.5/32 [120/4] via 163.1.18.1, 00:00:05, FastEthernet0/21
> > R       150.1.4.4/32 [120/4] via 163.1.18.1, 00:00:05, FastEthernet0/21
> >
> > Thanks
> >
> > Phuc
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html