GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: 3560 rate limiting posted 11/26/2007
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Thanks Antonio for your suggestion.

It seems that I forgot to enable mls qos globally. I tried again today and
it works fine. 

Cheers,
 
Huan
-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of
Antonio Soares
Sent: Tuesday, 27 November 2007 10:25 AM
To: 'Huan Pham'; ccielab@xxxxxxxxxxxxxx
Subject: RE: 3560 rate limiting

Try to increase the burst-byte option gradually until you get what you want.
And read this to help you understand how it works:

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat3560/12240se/scg/swqo
s.htm#wp1408392


Regards,

Antonio Soares
CCIE #18473 (R&S),CCNP,CCIP,JNCIA-ER
http://pwp.netcabo.pt/amsoares/

-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of Huan
Pham
Sent: domingo, 25 de Novembro de 2007 22:44
To: ccielab@xxxxxxxxxxxxxx
Subject: 3560 rate limiting

Hi Group,

 

I would like to rate limit traffic in and out of an interface on C3560. 

 

The rate-limiting on incoming traffic is working fine using interface
command:

 

interface fa0/2

 srr-queue bandwidth limit 20

 

(BTW, service-policy can not be applied to outgoing direction of an
interface).

 

However, rate limiting on outgoing traffic using policy map does not seem to
work. Under policy-map configuration, I tried both class-default, as well as
the one I manually created (Class ALL), but none seems to work. When I do
extended ping from R2 to R4, I still see traffic reaching about 4Mbps
although the C3560 meant to shape traffic at 2M. 

 

Would you pls see if there's any error in my config, or any better ideas
doing rate-limiting on C3560.

 

Thanks,

 

 

 

 

R2 ----- SW2 ----- R4

 

 

SW2#

 

SW2#sh ver | in Ver

Cisco IOS Software, C3560 Software (C3560-ADVIPSERVICESK9-M), Version
12.2(40)SE, RELEASE SOFTWARE (fc3)

BOOTLDR: C3560 Boot Loader (C3560-HBOOT-M) Version 12.2(35r)SE2, RELEASE
SOFTWARE (fc1)

Version ID                      : V01

Switch   Ports  Model              SW Version              SW Image    

 

SW2#

ip access-list extended all

 permit ip any any

 

class-map match-all ALL

  match access-group name all

!

policy-map POLICE_2M

  class ALL

    police 2048000 25600 exceed-action drop

 

 

interface FastEthernet0/2

 desc Connect to R2 FE0/0

 service-policy input POLICE_2M

 

interface FastEthernet0/4

 desc Connect to R4 FE0/0

 

R2#

interface FastEthernet0/0

 desc Connect to SW2 FE0/2

 ip address 10.0.0.2 255.0.0.0

 

ping ip 10.0.0.4 size 1500 timeout 0 rep 10000

 

R4#

interface FastEthernet0/0

 desc Connect to SW2 FE0/4

 ip address 10.0.0.4 255.0.0.0

 

R4#sh int fa0/0 | in rate 

  30 second input rate 3469000 bits/sec, 286 packets/sec

  30 second output rate 3469000 bits/sec, 286 packets/sec

 

 

 

Cheers,

 

Huan Pham

_______________________________________________________________________
Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html

_______________________________________________________________________
Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html