GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: native vlan posted 10/24/2007
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Hard to say, no idea where to start... Check if the following is true on
the switch:
VOIP_3560_B(config)#no vlan dot1q tag native

Andrew

-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of
kuldip singh
Sent: Wednesday, October 24, 2007 9:45 AM
To: Group Study
Subject: native vlan

Hi,

 It seems like I can't get the native VLAN to work. As shown below I
have two sub-interfaces configured on R4, vlan 10 and vlan 555. if the
sub-interfaces are configured as trunk ports and the switchport is
configured as trunk port I can ping the 10.10.10.201 and 131.10.160.5
(R5 connected to switch 3). If I change the sub-interface on R4 (e0/1.10
) to mark vlan 10 as native and change the config on switch 4 to mark
the vlan 10 as native. I can't ping 10.10.10.201 address,  but I can
still ping vlan 555 ok.
Can somebody spot the issue. (This is from one of the NMC documents).


Thanks


R4: (R4 connected to Switch 4)


interface Ethernet0/1
 no ip address
 half-duplex
!
interface Ethernet0/1.10
 encapsulation dot1Q 10
 ip address 10.10.10.1 255.255.255.0
 no snmp trap link-status
!
interface Ethernet0/1.555
 encapsulation dot1Q 555
 ip address 131.10.160.1 255.255.255.0
 no snmp trap link-status



SW4:

interface FastEthernet0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk

interface Vlan10
 ip address 10.10.10.201 255.255.255.0


SW3;

interface FastEthernet0/5
 switchport access vlan 555
 switchport mode access



Ping from R4;

Rack9SW4#ping 10.10.10.201

Sending 1, 100-byte ICMP Echos to 10.10.10.201, timeout is 2 seconds:
!
Success rate is 100 percent (1/1), round-trip min/avg/max = 4/4/4 ms
Rack9SW4#

Sending 1, 100-byte ICMP Echos to 131.10.160.5, timeout is 2 seconds:
!
Success rate is 100 percent (1/1), round-trip min/avg/max = 1/1/1 ms
Rack9SW4#




Now change the config on R4 and SW4 to make VLAN 10 native.

R4:

interface Ethernet0/1.10
 encapsulation dot1Q 10 native
 ip address 10.10.10.1 255.255.255.0
 no snmp trap link-status
end



SW4:

interface FastEthernet0/4
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 10
 switchport mode trunk
end


Ping from R4:

Rack9R4#ping 10.10.10.201

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.201, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Rack9R4#

Rack9R4#ping 131.10.160.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 131.10.160.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
Rack9R4#


debug on the route R4 indicates encapsulation failure when vlan 10 is
made native.

Oct 24 08:34:38.682: IP: s=10.10.10.1 (local),
d=10.10.10.201(Ethernet0/1.10), len 100, sending Oct 24 08:34:38.686:
IP: s=10.10.10.1 (local), d=10.10.10.201(Ethernet0/1.10), len 100,
encapsulation failed.
Oct 24 08:34:40.682: IP: tableid=0, s=10.10.10.1 (local),
d=10.10.10.201(Ethern et0/1.10), routed via RIB Oct 24 08:34:40.682: IP:
s=10.10.10.1 (local), d=10.10.10.201(Ethernet0/1.10), len 100, sending

_______________________________________________________________________
Subscription information may be found at:
http://www.groupstudy.com/list/CCIELab.html

The content contained in this electronic message is not intended to
constitute formation of a contract binding TWTC.  TWTC will be
contractually bound only upon execution, by an authorized officer, of
a contract including agreed terms and conditions or by express
application of its tariffs.

This message is intended only for the use of the individual or entity
to which it is addressed. If the reader of this message is not the
intended recipient, or the employee or agent responsible for
delivering the message to the intended recipient, you are hereby
notified that any dissemination, distribution or copying of this
message is strictly prohibited. If you have received this
communication in error, please notify us immediately by replying to
the sender of this E-Mail or by telephone.