GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: PSTN Links not working on IPexpert Voice topology - Please Help !!! posted 10/16/2007
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Hey J P,

Also - we have posted our PSTN configs over at our proctorlabs support forum.
They have been there for a few years now - I believe that they are up to date and recently posted - but I will check to make sure and if for some reason they are older - will update them.


Cheers,

Mark Snow
CCIE #14073 (Voice, Security)
CCSI #31583
Senior Technical Instructor - IPexpert, Inc.
A Cisco Learning Partner - We Accept Learning Credits!
Telephone: +1.810.326.1444
Fax: +1.309.413.4097
Mailto: msnow@xxxxxxxxxxxx

IPexpert - The Global Leader in Self-Study, Classroom-Based, Video On Demand and Audio Certification Training Tools for the Cisco CCIE R&S Lab, CCIE Security Lab, CCIE Service Provider Lab , CCIE Voice Lab and CCIE Storage Lab Certifications.


On Oct 16, 2007, at 5:10 PM, Irfan Siddiqui wrote:


Dear All



I am working on Ipexpert voice Section 4 - Gateway lab and I cant get my
PSTN links up. Please help as im stuck.




I have attached the config for my PSTN switch, Branch 1 and branch 2 ,
none of my PSTN links are coming up,



I have T1 on BR1 and E1 on BR2 and HQ.



Can someone please help me with the PSTN issue...



One other thing I fail to understand why Ipexpert cannot provide its
customers with Base configs ie PSTN config



Thanks in advance



Regards

JP Singh



**********************************************************************
Any opinions expressed in the email are those of the individual and not
necessarily the company. This email and any files transmitted with it are
confidential and solely for the use of the intended recipient. If you are not
the intended recipient or the person responsible for delivering it to the
intended recipient, be advised that you have received this email in error and
that any dissemination, distribution, copying or use is strictly prohibited.


If you have received this email in error, or if you are concerned with the
content of this email please e-mail to: e-security.support@xxxxxxxxxx


The contents of an attachment to this e-mail may contain software viruses
which could damage your own computer system. While the sender has taken every
reasonable precaution to minimise this risk, we cannot accept liability for
any damage which you sustain as a result of software viruses. You should carry
out your own virus checks before opening any attachments to this e- mail.


Vanco UK Ltd Registered in England No: 2296733 Registered Office: John Busch
House, 277 London Road, Isleworth, Middlesex TW7 5AX


Please consider the environment before printing this e-mail
**********************************************************************
Building configuration...

Current configuration : 1359 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PSTN_WAN
!
boot-start-marker
boot-end-marker
!
card type e1 0 2
card type t1 0 3
!
no aaa new-model
!
resource policy
!
network-clock-participate wic 2
network-clock-participate wic 3
ip subnet-zero

!
ip cef
!
!
!
isdn switch-type primary-ni
!
voice-card 0
 no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!

!
!
controller E1 0/2/0
 clock source internal
 pri-group timeslots 1-3,16
!
controller E1 0/2/1
!
controller T1 0/3/0
 framing esf
 clock source internal
 linecode b8zs
 pri-group timeslots 1-3,24
!
controller T1 0/3/1
 framing esf
 linecode b8zs
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/2/0:15
 no ip address
 isdn switch-type primary-net5
 isdn incoming-voice voice
 no cdp enable
!
interface Serial0/3/0:23
 no ip address
 isdn switch-type primary-ni
 isdn protocol-emulate network
 isdn incoming-voice voice
no cdp enable
!
ip classless
!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
voice-port 0/3/0:23
!
voice-port 0/2/0:15
!
!
!
!
 --More--
!
!
!
gatekeeper
 shutdown
!
!
line con 0
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
!
end

PSTN_WAN# sh isdn status
Global ISDN Switchtype = primary-ni
ISDN Serial0/3/0:23 interface
******* Network side configuration *******
dsl 0, interface ISDN Switchtype = primary-ni
Layer 1 Status:
ACTIVE
Layer 2 Status:
TEI = 0, Ces = 1, SAPI = 0, State = AWAITING_ESTABLISHMENT
Layer 3 Status:
0 Active Layer 3 Call(s)
Active dsl 0 CCBs = 0
The Free Channel Mask: 0x80000007
Number of L2 Discards = 0, L2 Session ID = 151
ISDN Serial0/2/0:15 interface
dsl 1, interface ISDN Switchtype = primary-net5
Layer 1 Status:
ACTIVE
Layer 2 Status:
TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
Layer 3 Status:
0 Active Layer 3 Call(s)
Active dsl 1 CCBs = 0
The Free Channel Mask: 0x80000007
Number of L2 Discards = 0, L2 Session ID = 140
Total Allocated ISDN CCBs = 0
PSTN_WAN#sh contr
PSTN_WAN#sh controllers e1 0/2/0
E1 0/2/0 is up.
Applique type is Channelized E1 - balanced
No alarms detected.
alarm-trigger is not set
Version info Firmware: 20060707, FPGA: 13, spm_count = 0
Framing is CRC4, Line Code is HDB3, Clock Source is Internal.
CRC Threshold is 320. Reported from firmware is 320.
Data in current interval (524 seconds elapsed):
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
Data in Interval 1:
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
Data in Interval 2:
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
Data in Interval 3:
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs


PSTN_WAN#sh controllers t1 0/3/0
T1 0/3/0 is up.
Applique type is Channelized T1
Cablelength is long gain36 0db
No alarms detected.
alarm-trigger is not set
Soaking time: 3, Clearance time: 10
AIS State:Clear LOS State:Clear LOF State:Clear
Version info Firmware: 20060707, FPGA: 13, spm_count = 0
Framing is ESF, Line Code is B8ZS, Clock Source is Internal.
CRC Threshold is 320. Reported from firmware is 320.
Data in current interval (537 seconds elapsed):
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
Data in Interval 1:
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
Data in Interval 2:
0 Line Code Violations, 0 Path Code Violations
0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
Data in Interval 3:
--More--  
PSTN_WAN#u
BR1-RTR#sh isdn status
Global ISDN Switchtype = primary-ni


%Q.931 is backhauled to CCM MANAGER 0x0003 on DSL 1. Layer 3 output may not apply

ISDN Serial0/1/0:23 interface
	dsl 1, interface ISDN Switchtype = primary-ni
	L2 Protocol = Q.921 0x0000  L3 Protocol(s) = CCM MANAGER 0x0003
    Layer 1 Status:
	ACTIVE
    Layer 2 Status:
	TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED
    Layer 3 Status:
	0 Active Layer 3 Call(s)
    Active dsl 1 CCBs = 0
    The Free Channel Mask:  0x80000007
    Number of L2 Discards = 0, L2 Session ID = 2
Total Allocated ISDN CCBs = 0
BR1-RTR#
BR1-RTR#
BR1-RTR#sh runn
Building configuration...

Current configuration : 3500 bytes
!
! Last configuration change at 20:11:54 edt Tue Oct 16 2007 by cisco
! NVRAM config last updated at 11:46:50 edt Tue Oct 16 2007 by cisco
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BR1-RTR
!
boot-start-marker
boot-end-marker
!
card type t1 0 1
logging buffered 51200 warnings
enable secret 5 $1$Y2JP$847ZRa95fZTBkyoNpXXen0
!
no aaa new-model
!
resource policy

clock timezone est -5
clock summer-time edt recurring
network-clock-participate wic 1
ip subnet-zero
!
!
ip cef
!
!
ip domain name yourdomain.com
!
isdn switch-type primary-ni
!
voice-card 0
 dspfarm
 dsp services dspfarm
!
!
!
!
!

!
!
!
!
!
!
!
username cisco password 0 cisco
!
!
controller T1 0/1/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-3,24 service mgcp
!
controller T1 0/1/1
 framing esf
 linecode b8zs
!
!
!
!
interface Loopback0
 ip address 172.4.101.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay IETF
 no fair-queue
 frame-relay lmi-type ansi
 --More--         !
interface Serial0/0/0.1 point-to-point
 ip address 162.4.101.2 255.255.255.0
 ip ospf mtu-ignore
 frame-relay interface-dlci 101
!
interface Serial0/1/0:23
 no ip address
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface FastEthernet1/0
 switchport trunk native vlan 140
 switchport mode trunk
 switchport voice vlan 240
!
interface FastEthernet1/1
!
interface FastEthernet1/2
 shutdown
!interface FastEthernet1/3
 shutdown
!
interface FastEthernet1/4
 shutdown
!
interface FastEthernet1/5
 shutdown
!
interface FastEthernet1/6
 shutdown
!
interface FastEthernet1/7
 shutdown
!
interface FastEthernet1/8
 shutdown
!
interface FastEthernet1/9
 shutdown
!
interface FastEthernet1/10
 switchport trunk native vlan 140
 switchport mode trunk
 switchport voice vlan 240
!
interface FastEthernet1/11
 shutdown
!
interface FastEthernet1/12
 shutdown
!
interface FastEthernet1/13
 shutdown
!
interface FastEthernet1/14
 shutdown
!
interface FastEthernet1/15
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan240
ip address 10.4.201.1 255.255.255.0
 ip helper-address 10.4.200.21
!
router ospf 1
 router-id 172.4.101.1
 log-adjacency-changes
 network 10.4.201.0 0.0.0.255 area 0
 network 162.4.101.0 0.0.0.255 area 0
 network 172.4.101.0 0.0.0.255 area 0
!
ip classless
!
!
ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
!
!
!
control-plane
!
!
!
voice-port 0/1/0:23
!
ccm-manager mgcp
!
mgcp
mgcp call-agent 10.4.200.21 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp bind control source-interface Vlan240
mgcp bind media source-interface Vlan240
!
mgcp profile default
!
!
!
dial-peer voice 1 pots
 service mgcpapp
 port 0/1/0:23
!
!
 --More--         !
!
gatekeeper
 shutdown
!
!
line con 0
 login local
line aux 0
line vty 0 4
 access-class 23 in
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 access-class 23 in
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
ntp clock-period 17179989
ntp server 10.4.200.3
 --More--         !
end
BR2-RTR#sh runn
Building configuration...

Current configuration : 5493 bytes
!
! Last configuration change at 20:38:12 edt Tue Oct 16 2007 by cisco
! NVRAM config last updated at 20:38:13 edt Tue Oct 16 2007 by cisco
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BR2-RTR
!
boot-start-marker
boot-end-marker
!
card type e1 0 0
! card type command needed for slot/vwic-slot 0/3
logging buffered 51200 warnings
enable secret 5 $1$QV1t$IR5/yJLcfNWjDv7dBR3cC0
!
no aaa new-model
!
 --More--         resource policy
!
clock timezone est -5
clock summer-time edt recurring
network-clock-participate wic 0
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.4.202.1 10.4.202.119
ip dhcp excluded-address 10.4.202.130 10.4.202.254
!
ip dhcp pool br2
   network 10.4.202.0 255.255.255.0
   default-router 10.4.202.1
   option 150 ip 10.4.202.1
!
!
no ip domain lookup
ip domain name yourdomain.com
!
isdn switch-type primary-net5
 --More--         !
voice-card 0
 dspfarm
 dsp services dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username cisco password 0 cisco
!
!
controller E1 0/0/0
 ds0-group 1 timeslots 1-3 type r2-digital r2-semi-compelled ani
 cas-custom 1
  dnis-digits min 3 max 11
!
controller E1 0/0/1
!
!
!
!
!
interface Loopback0
 ip address 172.4.102.1 255.255.255.255
 ip ospf network point-to-point
!
interface FastEthernet0/0
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.140
 encapsulation dot1Q 140 native
 no snmp trap link-status
!
interface FastEthernet0/0.240
 encapsulation dot1Q 240
 ip address 10.4.202.1 255.255.255.0
 no snmp trap link-status
!
interface Service-Engine0/0
 no ip address
 shutdown
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1/0
 no ip address
 encapsulation frame-relay IETF
 no fair-queue
 frame-relay lmi-type ansi
!
interface Serial0/1/0.1 point-to-point
 ip address 162.4.102.2 255.255.255.0
 frame-relay interface-dlci 102
!
router ospf 1
 log-adjacency-changes
 network 10.4.202.0 0.0.0.255 area 0
 network 162.4.102.0 0.0.0.255 area 0
 network 172.4.102.0 0.0.0.255 area 0
!
ip classless
!
!
ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip http path flash:
!
!
!
!
!
control-plane

!
!
voice-port 0/0/0:1
!
!
!
sccp local FastEthernet0/0.240
sccp ccm 10.4.202.1 identifier 1
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate profile 1 register mtp001c58bb3448
!
dspfarm profile 1 transcode
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec gsmfr
 codec g729r8
 maximum sessions 6
 associate application SCCP
 shutdown
!
dial-peer cor custom
 name pt-911
 name pt-loc
 name pt-ld
 name pt-int
!
!
dial-peer cor list css-911
 member pt-911
!
dial-peer cor list css-loc
 member pt-loc
!
dial-peer cor list css-ld
 member pt-ld
!
dial-peer cor list css-int
 member pt-int
!
dial-peer cor list css-911-loc
 member pt-911
 member pt-loc
!
dial-peer cor list css-all
 member pt-911
 member pt-loc
 member pt-ld
 member pt-int
!
!
dial-peer voice 911 pots
 corlist outgoing css-911
!
dial-peer voice 1 pots
 corlist outgoing css-loc
!
dial-peer voice 2 pots
 corlist outgoing css-ld
!
dial-peer voice 3 pots
 corlist outgoing css-int
!
!

!
gatekeeper
 shutdown
!
!
telephony-service
 max-ephones 20
 max-dn 48
 ip source-address 10.4.202.1 port 2000
 auto assign 1 to 4
 timeouts interdigit 7
 system message BR2-JPSINGH
 sdspfarm units 1
 sdspfarm transcode sessions 6
 sdspfarm tag 1 mtp001c58bb3448
 network-locale GB
 create cnf-files version-stamp 7960 Oct 13 2007 11:57:46
 dialplan-pattern 1 3313243... extension-length 4
 max-conferences 8 gain -6
 web admin system name cisco password cisco
 dn-webedit
 time-webedit
 --More--          transfer-system full-consult
 after-hours block pattern 1 9011
 after-hours day Sun 23:59 09:00
 after-hours day Mon 17:00 09:00
 after-hours day Tue 17:00 09:00
 after-hours day Wed 17:00 09:00
 after-hours day Thu 17:00 09:00
 after-hours day Fri 17:00 09:00
 after-hours day Sat 09:00 23:59
!
!
ephone-dn  1  dual-line
 number 3001
 corlist incoming css-911-loc
!
!
ephone-dn  2  dual-line
 number 3002
 corlist incoming css-all
!
!
ephone-dn  3  dual-line
 number 3003
  corlist incoming css-all
!
!
ephone-dn  4  dual-line
 number 3004
!
!
ephone-dn  5  dual-line
 number 3010
 huntstop channel
 no huntstop
!
!
ephone-dn  6  dual-line
 number 3010
 preference 1
 huntstop channel
 no huntstop
!
!
ephone-dn  11
 number 1007
 paging ip 239.0.1.20 port 2000

!
ephone-dn  12
 number 1008
 paging ip 239.0.1.20 port 2000
!
!
ephone-dn  13
 number 1009
 paging ip 239.0.1.20 port 2000
 paging group 11,12
!
!
ephone  1
 mac-address 001B.D460.6FEF
 paging-dn 11
 type 7960
 button  1:1 2c5,6
!
!
!
ephone  2
 mac-address 001B.D460.6FCF
 paging-dn 12
 type 7960
 button  1:2
!
!
!
ephone  3
 mac-address 000D.654B.92D7
 type 7960
 button  1:3 2c5,6
!
!
!
ephone  4
 mac-address 0030.94C2.6C78
 type 7960
 button  1:4
!
!
!
line con 0
 login local
line aux 0
 line 194
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 access-class 23 in
 privilege level 15
 login local
 transport input telnet
line vty 5 15
 access-class 23 in
 privilege level 15
 login local
 transport input telnet
!
warm-reboot
scheduler allocate 20000 1000
ntp clock-period 17179811
ntp server 10.4.200.3
!
end

BR2-RTR#

______________________________________________________________________ _
Subscription information may be found at:
http://www.groupstudy.com/list/CCIELab.html