GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: Issue with RIPng over Frame Relay NBMA posted 10/11/2007
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Well it all depends on the topology.

If you're using point-to-point subif with the frame-relay interface-dlci
command then you don't need any of them (same as IPv4).

If you're using the physical interface or a point-to-multipoint subif with
frame maps - then solution 1 works if it's a point to point topology.

If you have HUB and spoke like (R1 <-> R2 <-> R3) with R2 as the hub then
you'd need something like:

R1:
--
frame map ipv6 <link local address R2> <R2 DLCI>
frame map ipv6 <link local address R3> <R2 DLCI>
frame map ipv6 <global address R2> <R2 DLCI> broadcast
frame map ipv6 <global address R3> <R2 DLCI>

R2:
--
frame map ipv6 <link local address R1> <R1 DLCI>
frame map ipv6 <link local address R3> <R3 DLCI>
frame map ipv6 <global address R1> <R1 DLCI> broadcast
frame map ipv6 <global address R3> <R3 DLCI> broadcast

R3:
--
frame map ipv6 <link local address R1> <R2 DLCI>
frame map ipv6 <link local address R2> <R2 DLCI>
frame map ipv6 <global address R1> <R2 DLCI> 
frame map ipv6 <global address R2> <R2 DLCI> broadcast  

I think that's right but I've been at it all day so my brain is a little
fried.
Same logic applies as for IPv4 F/R really - just have the extra config for
the link-local addresses.

That's my current understanding of it to date.

gl...

-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of Toh
Soon, Lim
Sent: Thursday, 11 October 2007 18:00
To: Gustavo Novais
Cc: ccielab@xxxxxxxxxxxxxx
Subject: Re: Issue with RIPng over Frame Relay NBMA

Hi Guys,

Thanks for all your inputs. If the lab doesn't prohibit from configuring a
static link-local address and I proceed to configure routers R2 and R6 as
follows:

R2
--
int s0/0/0
 ipv6 address 2001:1:1:26::2/64
 ipv6 address FE80::2 link-local

R6
--
int s0/0/0
 ipv6 address 2001:1:1:26::6/64
 ipv6 address FE80::6 link-local

Can you kindly verify which of the following map statements on R2 are
correct:

Solution 1
----------
frame-relay map ipv6 FE80::6 106
frame-relay map ipv6 2001:1:1:26::6 106 broadcast

Or

Solution 2
----------
int s 0/0/0
 frame-relay map ipv6 FE80::6 106 broadcast  frame-relay map ipv6
2001:1:1:26::6 106

Or

Solution 3
----------
int s 0/0/0
 frame-relay map ipv6 FE80::6 106 broadcast  frame-relay map ipv6
2001:1:1:26::6 106 broadcast


I'm keeping the maps for global unicast addresses to ensure other routers
have reachability to these addresses. Am I right?

I'm currently using Solution 2 for the static maps and it works. I guess all
3 methods should work. But which one is the correct configuration?

Appreciate further comments and guidance.


Thank you.

B.Rgds,
Lim TS


On 10/12/07, Gustavo Novais <gustavo.novais@xxxxxxxxxxx> wrote:
>
> Have you tried to also map the remote link local address on the FR Map?
>
> Gustavo Novais
>
>
>
>
> -----Original Message-----
> From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf 
> Of Toh Soon, Lim
> Sent: quinta-feira, 11 de Outubro de 2007 15:58
> To: ccielab@xxxxxxxxxxxxxx
> Subject: Issue with RIPng over Frame Relay NBMA
>
> Hi Group,
>
> I'm facing an issue running RIPng over frame relay NBMA. Any help is 
> welcome. My config as follows:
>
> R6
> --
> ipv6 unicast-routing
> !
> interface Serial0/0/0
> no ip address
> encapsulation frame-relay
> ipv6 address 2001:1:1:26::6/64
> ipv6 rip big enable
> frame-relay map ipv6 2001:1:1:26::2 601 broadcast no frame-relay 
> inverse-arp !
> ipv6 router rip big
>
> R2
> --
> interface Loopback1
> no ip address
> ipv6 address 2000:1:2:2::2/64
> ipv6 rip big enable
> !
> interface Serial0/0/0
> no ip address
> encapsulation frame-relay
> ipv6 address 2001:1:1:26::2/64
> ipv6 rip big enable
> frame-relay map ipv6 2001:1:1:26::6 106 broadcast !
> ipv6 router rip big
>
> Verification:
> -------------
> R2#sh ipv int s 0/0/0
> Serial0/0/0 is up, line protocol is up
> IPv6 is enabled, link-local address is FE80::21B:54FF:FECE:2072 Global 
> unicast address(es):
>    2001:1:1:26::2, subnet is 2001:1:1:26::/64
>
> R6#pi FE80::21B:54FF:FECE:2072
> Output Interface: serial0/0/0
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to FE80::21B:54FF:FECE:2072, timeout is 
> 2
> seconds:
> Packet sent with a source address of FE80::21B:54FF:FEBC:5EEE .....
> Success rate is 0 percent (0/5)
>
> R6#pi 2001:1:1:26::2
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 2001:1:1:26::2, timeout is 2 seconds:
> !!!!!
> Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 
> ms
>
> R6#sh ipv ro ri
> R   2000:1:2:2::/64 [120/2]
>     via FE80::21B:54FF:FECE:2072, Serial0/0/0
>
> R6#pi 2000:1:2:2::2
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 2000:1:2:2::2, timeout is 2 seconds:
> .....
> Success rate is 0 percent (0/5)
>
>
> (1) I'm not able to ping to R2's link-local address from R6 but can 
> ping its global unicast address.
> (2) R6 learns R2's loopback1 subnet address via RIP but can't ping 
> R2's
> loopback1 address.
> (3) I notice the next-hop address of the RIP route is R2's link-local 
> address. I guess the reason why R6 can't ping R2's loopback1 has to do 
> with the issue of not being able to ping R2's link-local address.
> (4) I have no issue if I re-configured the frame relay to p2p 
> subinterfaces.
>
> Did I miss anything in my config? Reloading both routers doesn't help.
> Please advise.
>
>
> Thank you.
>
> B.Rgds,
> Lim TS
>
> ______________________________________________________________________
> _ Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

_______________________________________________________________________
Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html