GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: Issue with RIPng over Frame Relay NBMA posted 10/11/2007
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Iirc you have to specify the link-local address for the other end in your
frame maps for dynamic routing protocols to work otherwise your route
recursion will break. The dynamic routing protocol will use the link local
address of the destination router - not the global address.

Therefore add in something like (you may want to double check the link local
addresses on each side or if the scenario allows make them something like
FE80:16::1 and FE80:16::6) ;

R2
--
frame map ipv6 FE80::21B:54FF:FEBC:5EEE 106

R6
--
frame map ipv6 FE80::21B:54FF:FECE:2072 601

You don't need the broadcast keyword for the link local mappings.

I hope I'm on the mark!

Cheers!


-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of Toh
Soon, Lim
Sent: Thursday, 11 October 2007 15:58
To: ccielab@xxxxxxxxxxxxxx
Subject: Issue with RIPng over Frame Relay NBMA

Hi Group,

I'm facing an issue running RIPng over frame relay NBMA. Any help is
welcome. My config as follows:

R6
--
ipv6 unicast-routing
!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay
 ipv6 address 2001:1:1:26::6/64
 ipv6 rip big enable
 frame-relay map ipv6 2001:1:1:26::2 601 broadcast  no frame-relay
inverse-arp !
ipv6 router rip big

R2
--
interface Loopback1
 no ip address
 ipv6 address 2000:1:2:2::2/64
 ipv6 rip big enable
!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay
 ipv6 address 2001:1:1:26::2/64
 ipv6 rip big enable
 frame-relay map ipv6 2001:1:1:26::6 106 broadcast !
ipv6 router rip big

Verification:
-------------
R2#sh ipv int s 0/0/0
Serial0/0/0 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::21B:54FF:FECE:2072
  Global unicast address(es):
    2001:1:1:26::2, subnet is 2001:1:1:26::/64

R6#pi FE80::21B:54FF:FECE:2072
Output Interface: serial0/0/0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE80::21B:54FF:FECE:2072, timeout is 2
seconds:
Packet sent with a source address of FE80::21B:54FF:FEBC:5EEE .....
Success rate is 0 percent (0/5)

R6#pi 2001:1:1:26::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1:1:26::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/56 ms

R6#sh ipv ro ri
R   2000:1:2:2::/64 [120/2]
     via FE80::21B:54FF:FECE:2072, Serial0/0/0

R6#pi 2000:1:2:2::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2000:1:2:2::2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)


(1) I'm not able to ping to R2's link-local address from R6 but can ping its
global unicast address.
(2) R6 learns R2's loopback1 subnet address via RIP but can't ping R2's
loopback1 address.
(3) I notice the next-hop address of the RIP route is R2's link-local
address. I guess the reason why R6 can't ping R2's loopback1 has to do with
the issue of not being able to ping R2's link-local address.
(4) I have no issue if I re-configured the frame relay to p2p subinterfaces.

Did I miss anything in my config? Reloading both routers doesn't help.
Please advise.


Thank you.

B.Rgds,
Lim TS

_______________________________________________________________________
Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html