GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: Redistributing connected interfaces into rip posted 09/29/2007
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Hello,

I had labed your config and working fine, i have only one comment on your
config (Why do you use permit any at the end of the route-map, if you wanna
redistribute everything so no need for route-map unless you need to set tags
or other stuff)


Rack1R1#show run int s1/0
Building configuration...

Current configuration : 158 bytes
!
interface Serial1/0
 ip address 155.1.0.1 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 155.1.0.2 102 broadcast
end

Rack1R1#show run | be router rip
router rip
 version 2
 redistribute connected metric 1 route-map LOOPBACK->RIP
 passive-interface default
 network 155.1.0.0
 neighbor 155.1.0.2
 no auto-summary

!
!
!
route-map LOOPBACK->RIP permit 10
 match interface Loopback1



Rack1R1#deb ip rip
RIP protocol debugging is on
*Mar  1 00:13:37.823: RIP: sending v2 update to 155.1.0.2 via Serial1/0 (
155.1.0.1)
*Mar  1 00:13:37.827: RIP: build update entries
*Mar  1 00:13:37.827:   150.1.1.0/24 via 0.0.0.0, metric 1, tag 0

*Mar  1 00:15:40.439: RIP: sending v2 flash update to 155.1.0.2 via
Serial1/0 (155.1.0.1)
*Mar  1 00:15:40.443: RIP: build flash update entries
*Mar  1 00:15:40.443:   150.1.2.0/24 via 155.1.0.2, metric 2, tag 0

Rack1R1#show ip route rip
R       150.1.2.0 [120/1] via 155.1.0.2, 00:00:07, Serial1/0

Rack1R2#;;;
Rack1R2#show ip route rip
R       150.1.1.0 [120/1] via 155.1.0.1, 00:00:20, Serial1/0

Best Regards,

Mounir Mohamed
On 9/29/07, vignesh sethuraman <sethuvignesh@xxxxxxxxxxx> wrote:
>
> Hello,
>
> I have 2 routers connected via framerelay network (R1 <----------> R2).
>
> R1 is the C3725 running Version 12.3(4)T1 and  R2 is C2600 running IOS
> Version 12.4(7).
>
> The loop back interfaces ip address R1 and R2 are 150.1.1.1 and 150.1.2.2
>
> I have configured rip on both the routers and redistributed  loop back
> interface into rip using the command # redistribute connected route-map rip
> metric 1
>
> But I could not find the R1's loop back in the R2 routing table.
>
> Below is my configuration
>
> Rack1R1#sh run int s1/0
> Building configuration...
> Current configuration : 164 bytes
> !
> interface Serial1/0
> ip address 161.1.12.1 255.255.255.0
> encapsulation frame-relay
> frame-relay map ip 161.1.12.2 102 broadcast
> no frame-relay inverse-arp
> !
> !
> router rip
> version 2
> redistribute connected metric 1 route-map rip
>   passive-interface default
> network 161.1.0.0
> neighbor 161.1.12.2
> no auto-summary
>
> !
> route-map rip permit 10
> match interface Loopback0
> route-map rip permit 20
> !
> !
>
> R2 #sh run
> Building configuration...
> Current configuration : 164 bytes
> !
> interface Serial1/0
> ip address 161.1.12.2 255.255.255.0
> encapsulation frame-relay
> frame-relay map ip 161.1.12.1 201 broadcast
> no frame-relay inverse-arp
> !
> !
> router rip
> version 2
> redistribute connected metric 1 route-map rip
>   passive-interface default
> network 161.1.0.0
> neighbor 161.1.12.1
> no auto-summary
>
> !
> route-map rip permit 10
> match interface Loopback0
> route-map rip permit 20
>
>
> Coudl you please anyone help on this issue.
>
> Thanks,
> Vignesh
>
>
>
>
>
>
> ---------------------------------
> Forgot the famous last words? Access your message archive online. Click
> here.
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>



-- 
Best Reagrds,
Mounir Mohamed