GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: switching problem posted 09/23/2007
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


George

 

As I remember , when port is in switchport mode, it doesn't capture packets
(I mean it just do the forwarding in Layer 2, not bringing up the frame).
Because the SW1 port is in switch mode, its not expected to show the debug
arp. I think its better to turn on arp debug on R6 to check the ARP is
coming or not.

 

Actually I myself had some problems with FastEthernet links on Dynamips, for
example when connect 2 Fast Ethernet ports together, you may receive lots of
Speed , Duplex errors on consol.

But why it says encapsulation failed ??? I think R1 cannot send anything
though its Fast ethernet.

Maybe by playing with speed and duplex it will be solved, but I'm not sure.

 

Regards

Reza

 

 

 

From: George Goglidze [mailto:goglidze@xxxxxxxxx] 
Sent: Sunday, September 23, 2007 8:30 PM
To: Reza Toghraee
Subject: Re: switching problem

 

Yep, that's theoretically how it "SHOULD" work...

but in my situation, R5 does send out ARP request, but SW1 never receives
it.

let see all this with debug ip packet, and debug arp on both R5 and SW1. 

R5 output:

R5#sh deb
ARP:
  ARP packet debugging is on
Generic IP:
  IP packet debugging is on



R5#ping 150.50.7.6 rep 1

Type escape sequence to abort. 
Sending 1, 100-byte ICMP Echos to 150.50.7.6, timeout is 2 seconds:

*Mar  1 06:01:39.918: IP: tableid=0, s=150.50.7.5 (local), d= 150.50.7.6
<http://150.50.7.6>  (FastEthernet0/0), routed via RIB
*Mar  1 06:01:39.918: IP: s=150.50.7.5 (local), d=150.50.7.6
(FastEthernet0/0), len 100, sending
*Mar  1 06:01: 39.918: IP ARP: sent req src 150.50.7.5 cc03.6c7c.0000,
                 dst 150.50.7.6 0000.0000.0000 FastEthernet0/0
*Mar  1 06:01:39.918: IP: s= 150.50.7.5 <http://150.50.7.5>  (local),
d=150.50.7.6 (FastEthernet0/0), len 100, encapsulation failed.
Success rate is 0 percent (0/1)

at the same time we have no output on SW1.... 

Cat3550-1#sh deb 
ARP:
  ARP packet debugging is on
Generic IP:
  IP packet debugging is on



I really don't think this is dynamips issue, 
because it's something I'm sure someone would've found out already. 
vlan-s is something I'm sure many people use.


Many thanks, 



On 9/23/07, Reza Toghraee <reza@xxxxxxxxxxxx  <mailto:reza@xxxxxxxxxxxx> >
wrote:

Hi

Let's do a trace.

1) R5 with local IP of 150.50.7.5/25 tries to send an ICMP packet to
150.50.7.6/25
2) R5 founds that the destination address is a member of the 150.50.7.0/25
network  which F0/0 is an attached interface to it. 
3) R5 sends an ARP request with source of F0/0 MAC address and destination
of broadcast (FF:FF:FF:FF) out the F0/0 interface.
4) SW1 receives the ARP frame from its F1/5 interface which is inside the
VLAN 567 
5) SW1 checks the destination address which is broadcast frame, so it should
be forwarded over all ports in VLAN 567 and trunk ports.
6) SW1 encapsulates the arp in a .1Q or ISL frame and sends out to F1/6
7) Sw2 receives a frame for VLAN 567, cut off the vlan headers, it knows 
it's a broadcast frame, and forwards to all ports on 567 vlan
8) SW2 forwards the frame to F1/6 interface
9) R6 receives an ARP with its IP as destination. Creates the REPLY, through
the R1
10) the same way from R6 to R1 for ARP-REPLY 

So maybe the problem from the Dynamips ?

Reza



-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto: nobody@xxxxxxxxxxxxxx
<mailto:nobody@xxxxxxxxxxxxxx> ] On Behalf Of
George Goglidze
Sent: Sunday, September 23, 2007 5:35 PM
To: ccielab@xxxxxxxxxxxxxx
Subject: switching problem

Hello all, 

I've started to do ip3xpert labs, and it's one of the first ones.
but I got stuck in one problem, which I don't know if is dynamips bug, or my
config,
most probably it's my config :)

the routers are 3640 model, switches are the 3640 routers too but with
switch module NM-16ESW.

diagram is following -> R5 f0/0 <----> f1/5 SW1 f0/1 <----> f0/1 SW2
f1/6<----> f0/0 R6

link between SW1 and SW2 is trunk.

following config:

SW1#sh run int f0/1
Building configuration...

Current configuration : 56 bytes
!
interface FastEthernet0/1
switchport mode trunk

SW2#sh run int f0/1
Building configuration...

Current configuration : 56 bytes
!
interface FastEthernet0/1
switchport mode trunk


------------

I have created VLAN 567 on SW1, and i can see that vlan replicates ok to 
SW2.
on SW1 port f1/5 is in VLAN 567, and in SW2 port f1/6 is in VLAN 567 too.

here's config:

SW1#sh run int f1/5
Building configuration...

Current configuration : 61 bytes
!
interface FastEthernet1/5 
switchport access vlan 567
end

SW2#sh run int f1/6
Building configuration...

Current configuration : 61 bytes
!
interface FastEthernet1/6
switchport access vlan 567
end


the link's are all UP UP. 

on R1 int f0/0 has ip: 150.50.7.5 255.255.255.128
on R2 int f0/0 has ip: 150.50.7.6 255.255.255.128

but I can't ping one from another.

I tried following tests.

1) on SW1 I created interface VLAN 567, and put ip: 150.50.7.13
255.255.255.128
SW1#sh run int vlan 567
Building configuration...

Current configuration : 84 bytes
!
interface Vlan567
ip address 150.50.7.13 255.255.255.128
no ip route-cache
end


and from R1 I still can't ping this ip, output with debug on:
R5#debug ip packet
IP packet debugging is on
R5#ping 150.50.7.13  <http://150.50.7.13> rep 1

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 150.50.7.13, timeout is 2 seconds:

*Mar 1 03:00:43.279: IP: tableid=0, s= 150.50.7.5 <http://150.50.7.5>
(local),
d=150.50.7.13(FastEthernet0/0), routed via RIB
*Mar 1 03:00:43.279: IP: s=150.50.7.5 (local),
d=150.50.7.13(FastEthernet0/0), len 100, sending
*Mar 1 03:00: 43.279: IP: s=150.50.7.5 (local),
d=150.50.7.13(FastEthernet0/0), len 100, encapsulation failed.
Success rate is 0 percent (0/1)
R5#

I have encapsulation failed, it can't resolve IP to MAC address. 

2) if on SW1 I remove switchport on f1/5 and make it ip interface everything
works fine when I put ip 150.50.7.13 255.255.255.128.
I can ping this ip from R5. 


If anyone has any idea, please let me know, I'm really frustrated...


Thank you very much.
**

_______________________________________________________________________
Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html