GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: Need to nail "Autorp Listener" . posted 08/21/2007
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Victor /  Bajo,  

Appreciate your efforts.

Guess there was some attachment issue thus sending individual files.

Shukla.

Victor Cappuccio <vcappuccio@xxxxxxxxxxxxxx> wrote: 
Hi Shukla,

Note that before 12.2(7), Auto-RP only worked with Sparse-Dense mode because it relied on Dense mode to distribute information about the RP used for Sparse mode. Starting with 12.2(7), you can cause IP multicast traffic for the two Auto-RP groups 224.0.1.39 and 224.0.1.40 to be PIM dense mode flooded across interfaces operating in PIM sparse mode using the ip pim autorp listener command in global configuration mode.

Also, can you please post your show ip pim interfaces, show ip pim rp mapping, show run of your routers.

thanks,
Victor Cappuccio.-
- CCSI# 31452

CCBOOTCAMP - A Cisco Sponsored Organization (SO)
vcappuccio@xxxxxxxxxxxxxx
Toll Free: 877-654-2243
Direct: +1-702-968-5100 = Outside the USA
FAX: +1-702-446-8012
YES! We take Cisco Learning Credits!
Training And Remote Racks: http://www.ccbootcamp.com

Register to win a free iPhone! http://www.ccbootcamp.com/iphone.html



-----Original Message-----
From: nobody@xxxxxxxxxxxxxx on behalf of Prashant Shukla
Sent: Tue 21-Aug-07 11:32 AM
To: ccielab@xxxxxxxxxxxxxx
Subject: Need to nail "Autorp  Listener" .
 
Gurus, 

Simple scenario:

R4------------R3-------------R6.

R4 is the RP/MA  with the "ip igmp join-group for 224.9.9.9" , am using only sparse mode.

Now, R3 can ping the multicast address .

As "autorp listener"  cmd is not configured on  R4 and R3 , R3  still gets the RP mappings  bcos R4 sends all its RP/MA  traffic out its interfaces and even though the interface is not dense enabled,  R3 will process the multicast traffic for RP/MA and use it.

Technically R3 should not send the same MA traffic to R6 . but it is.

AFAIK, R3 does not have the "listener" command enabled thus should only process the packet for itself and should not send it to other interfaces for R6.

Is my understanding correct ?

pls share your views.

Shukla.

       
---------------------------------
 Unlimited freedom, unlimited storage. Get it now

_______________________________________________________________________
Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html



       
---------------------------------
 DELETE button is history. Unlimited mail storage is just a click away.
R103#
R103#run
Building configuration...

Current configuration : 1853 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R103
!
boot-start-marker
boot-end-marker
!
!
ip subnet-zero
ip cef
no ip domain-lookup
!
ip multicast-routing 
no mpls traffic-eng auto-bw timers frequency 0
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 ip pim sparse-mode
 ip igmp join-group 224.2.2.2
 no clns route-cache
!
interface Ethernet0/0
 ip address 5.5.26.2 255.255.255.0
 ip directed-broadcast
 ip pim sparse-mode
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 shukla
 no clns route-cache
!
interface Serial1/0
 ip address 5.5.24.2 255.255.255.0
 ip pim sparse-mode
 ip multicast helper-map 224.2.2.2 172.16.2.255 100
 encapsulation frame-relay
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 ccie
 ip ospf network broadcast
 no fair-queue
 serial restart-delay 0
 frame-relay interface-dlci 204
 no clns route-cache
!
router ospf 1
 log-adjacency-changes
 no auto-cost
 network 0.0.0.0 255.255.255.255 area 2
!
!
ip classless
ip forward-protocol udp 2000
no ip http server
!
!
!
access-list 100 permit udp host 150.2.100.1 any eq 2000
!
!
!
control-plane
!
alias configure r router rip
alias configure o router ospf
alias configure e router eigrp
alias configure b router bgp
alias exec c config t
alias exec run show run
alias exec sir show ip route
alias exec runr show run | begin router rip
alias exec runo show run | begin router ospf
alias exec rune show run | begin router eigrp
alias exec runb show run | begin router bgp
alias exec sion show ip ospf neigh
alias exec sin show ip ospf int
alias exec cio clear ip ospf process
alias exec sib show ip bgp
alias exec bb clear ip bgp *
alias exec ii clear ip route *
!
line con 0
line aux 0
line vty 0 4
 no login
!
!         
end

R103# 
R103#
R103#sh ip pim rp
Group: 224.2.2.2, RP: 5.5.24.4, v2, v1, uptime 00:00:35, expires 00:02:20
R103#sh ip pim rp map
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
  RP 5.5.24.4 (?), v2v1
    Info source: 5.5.24.4 (?), elected via Auto-RP
         Uptime: 00:00:37, expires: 00:02:18
R103#
R103#sh ip pim int

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
2.2.2.2          Loopback0                v2/S   0      30     1      2.2.2.2
5.5.26.2         Ethernet0/0              v2/S   1      30     1      5.5.26.6
5.5.24.2         Serial1/0                v2/S   1      30     1      5.5.24.4
R103#
R103#
R103#sh ip mro
R103#sh ip mroute    
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.2.2.2), 00:01:51/00:02:11, RP 5.5.24.4, flags: SJCL
  Incoming interface: Serial1/0, RPF nbr 5.5.24.4
  Outgoing interface list:
    Loopback0, Forward/Sparse, 00:01:48/00:02:11

(*, 224.0.1.39), 00:01:30/stopped, RP 0.0.0.0, flags: DC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial1/0, Forward/Sparse, 00:01:30/00:01:35

(5.5.24.4, 224.0.1.39), 00:01:17/00:02:52, flags: PT
  Incoming interface: Serial1/0, RPF nbr 0.0.0.0
  Outgoing interface list: Null

(*, 224.0.1.40), 00:01:51/stopped, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial1/0, Forward/Sparse, 00:01:30/00:01:35
    Loopback0, Forward/Sparse, 00:01:48/00:02:11

(5.5.24.4, 224.0.1.40), 00:00:53/00:02:13, flags: LT
  Incoming interface: Serial1/0, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 00:00:53/00:02:10

R103#
R103#sh ip mroute cou
IP Multicast Statistics
5 routes using 2628 bytes of memory
3 groups, 0.66 average sources per group
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)

Group: 224.2.2.2, Source count: 0, Packets forwarded: 0, Packets received: 0

Group: 224.0.1.39, Source count: 1, Packets forwarded: 0, Packets received: 6
  Source: 5.5.24.4/32, Forwarding: 0/-1/0/0, Other: 6/0/6

Group: 224.0.1.40, Source count: 1, Packets forwarded: 1, Packets received: 1
  Source: 5.5.24.4/32, Forwarding: 1/0/48/0, Other: 1/0/0
R103#
R103#sh ip pim int

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
2.2.2.2          Loopback0                v2/S   0      30     1      2.2.2.2
5.5.26.2         Ethernet0/0              v2/S   1      30     1      5.5.26.6
5.5.24.2         Serial1/0                v2/S   1      30     1      5.5.24.4
R103#
R104#run
Building configuration...

Current configuration : 2770 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R104
!
boot-start-marker
boot-end-marker
!
!
ip subnet-zero
ip cef
no ip domain-lookup
!
ip multicast-routing 
no mpls traffic-eng auto-bw timers frequency 0
!
!
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
 ip pim sparse-mode
 no clns route-cache
!
interface Loopback99
 ip address 99.1.1.1 255.255.255.255
 no clns route-cache
!
interface Ethernet0/0
 ip address 150.2.5.1 255.255.255.0
 ip pim sparse-mode
 ip multicast helper-map broadcast 224.2.2.2 100
 no clns route-cache
!
interface Serial1/0
 ip address 5.5.34.4 255.255.255.0
 encapsulation frame-relay
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 shukla
 ip ospf priority 0
 no fair-queue
 serial restart-delay 0
 clockrate 64000
 frame-relay map ip 5.5.34.4 406
 frame-relay map ip 5.5.34.6 406 broadcast
 frame-relay map ip 5.5.34.3 406
 no clns route-cache
!
interface Serial2/0
 ip address 5.5.24.4 255.255.255.0
 ip pim sparse-mode
 encapsulation frame-relay
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 ccie
 ip ospf network broadcast
 serial restart-delay 0
 frame-relay interface-dlci 402
 no clns route-cache
!
router ospf 1
 log-adjacency-changes
 no auto-cost
 network 4.4.4.4 0.0.0.0 area 0
 network 5.5.24.4 0.0.0.0 area 2
 network 5.5.34.4 0.0.0.0 area 0
!         
router bgp 5
 no synchronization
 bgp router-id 4.4.4.4
 bgp log-neighbor-changes
 network 99.1.1.1 mask 255.255.255.255
 neighbor 5.5.5.5 remote-as 5
 neighbor 5.5.5.5 update-source Loopback0
 neighbor 5.5.5.5 next-hop-self
 neighbor 6.6.6.6 remote-as 5
 neighbor 6.6.6.6 update-source Loopback0
 neighbor 6.6.6.6 next-hop-self
 neighbor 150.2.5.254 remote-as 254
 neighbor 150.2.5.254 filter-list 1 in
 no auto-summary
!
!
ip classless
ip forward-protocol udp 2000
no ip http server
!
ip as-path access-list 1 permit _254$
ip ospf name-lookup
ip pim send-rp-announce Serial2/0 scope 10 interval 15
ip pim send-rp-discovery Serial2/0 scope 10
!
!
access-list 100 permit udp any 172.16.2.0 0.0.0.255 eq 2000
!
!
!
control-plane
!
alias configure r router rip
alias configure o router ospf
alias configure e router eigrp
alias configure b router bgp
alias exec c config t
alias exec run show run
alias exec sir show ip route
alias exec runr show run | begin router rip
alias exec runo show run | begin router ospf
alias exec rune show run | begin router eigrp
alias exec runb show run | begin router bgp
alias exec sion show ip ospf neigh
alias exec sin show ip ospf int
alias exec cio clear ip ospf process
alias exec sib show ip bgp
alias exec bb clear ip bgp *
alias exec ii clear ip route *
!
line con 0
line aux 0
line vty 0 4
 no login
!
!
end

R104#
R104#
R104#sh ip pim rp
Group: 224.2.2.2, RP: 5.5.24.4, v2, v1, next RP-reachable in 00:00:42
R104#
R104#sh ip pim rp map
PIM Group-to-RP Mappings
This system is an RP (Auto-RP)
This system is an RP-mapping agent (Serial2/0)

Group(s) 224.0.0.0/4
  RP 5.5.24.4 (?), v2v1
    Info source: 5.5.24.4 (?), elected via Auto-RP
         Uptime: 00:02:54, expires: 00:00:40
R104#
R104#
R104#sh ip m
R104#sh ip mr
R104#sh ip mrou
R104#sh ip mroute 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.2.2.2), 00:02:37/00:02:44, RP 5.5.24.4, flags: SJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial2/0, Forward/Sparse, 00:02:37/00:02:44

(*, 224.0.1.39), 00:03:02/00:02:56, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet0/0, Forward/Sparse, 00:03:01/00:02:53
    Loopback0, Forward/Sparse, 00:03:01/00:02:50
    Serial2/0, Forward/Sparse, 00:03:02/00:02:56

(*, 224.0.1.40), 00:03:02/00:02:07, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial2/0, Forward/Sparse, 00:03:02/00:02:07

R104#R104#sh ip pim int

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
4.4.4.4          Loopback0                v2/S   0      30     1      4.4.4.4
150.2.5.1        Ethernet0/0              v2/S   0      30     1      150.2.5.1
5.5.24.4         Serial2/0                v2/S   1      30     1      5.5.24.4
R106#
R106#run
Building configuration...

Current configuration : 2727 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R106
!
boot-start-marker
boot-end-marker
!
!
ip subnet-zero
ip cef
no ip domain-lookup
!
ip multicast-routing 
no mpls traffic-eng auto-bw timers frequency 0
!
!
!
interface Loopback0
 ip address 6.6.6.6 255.255.255.255
 ip pim sparse-mode
 no clns route-cache
!
interface Ethernet0/0
 ip address 5.5.26.6 255.255.255.0
 ip pim sparse-mode
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 shukla
 no clns route-cache
!
interface Ethernet1/0
 ip address 150.3.5.1 255.255.255.0
 no clns route-cache
!
interface Ethernet2/0
 ip address 5.5.106.6 255.255.255.0
 no clns route-cache
!
interface Serial3/0
 ip address 5.5.34.6 255.255.255.0
 encapsulation frame-relay
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 shukla
 ip ospf priority 255
 serial restart-delay 0
 clockrate 64000
 frame-relay map ip 5.5.34.3 603 broadcast
 frame-relay map ip 5.5.34.6 603
 frame-relay map ip 5.5.34.4 604 broadcast
 no clns route-cache
!
router eigrp 100
 redistribute ospf 1 metric 1 1 1 1 1
 redistribute eigrp 10 metric 1 1 1 1 1
 network 150.3.5.0 0.0.0.255
 no auto-summary
!
router eigrp 10
 redistribute eigrp 100 metric 1 1 1 1 1
 redistribute ospf 1 metric 1 1 1 1 1
 network 5.5.106.6 0.0.0.0
 no auto-summary
!
router ospf 1
 ignore lsa mospf
 log-adjacency-changes
 no auto-cost
 redistribute eigrp 100 metric 1975 subnets
 redistribute eigrp 10 subnets
 network 5.5.26.6 0.0.0.0 area 2
 network 5.5.34.6 0.0.0.0 area 0
 network 6.6.6.6 0.0.0.0 area 0
 neighbor 5.5.34.4
 neighbor 5.5.34.3
!
router bgp 5
 no synchronization
 bgp router-id 6.6.6.6
 bgp log-neighbor-changes
 neighbor 4.4.4.4 remote-as 5
 neighbor 4.4.4.4 update-source Loopback0
 neighbor 5.5.5.5 remote-as 5
 neighbor 5.5.5.5 update-source Loopback0
 neighbor 7.7.7.7 remote-as 5
 neighbor 7.7.7.7 update-source Loopback0
 neighbor 8.8.8.8 remote-as 5
 neighbor 8.8.8.8 update-source Loopback0
 no auto-summary
!
!
ip classless
no ip http server
!
!
!
!
!
!
control-plane
!
alias configure r router rip
alias configure o router ospf
alias configure e router eigrp
alias configure b router bgp
alias exec c config t
alias exec run show run
alias exec sir show ip route
alias exec runr show run | begin router rip
alias exec runo show run | begin router ospf
alias exec rune show run | begin router eigrp
alias exec runb show run | begin router bgp
alias exec sion show ip ospf neigh
alias exec sin show ip ospf int
alias exec cio clear ip ospf process
alias exec sib show ip bgp
alias exec bb clear ip bgp *
alias exec ii clear ip route *
!
line con 0
line aux 0
line vty 0 4
 no login
!
!
end

R106#
R106#sh ip pim rp

R106#
R106#
R106#p 224.2.2.2

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:

Reply to request 0 from 5.5.26.2, 8 ms
R106#
R106#
R106#sh ip pim rp
Group: 224.2.2.2, RP: 0.0.0.0
R106#
R106#sh ip pim rp map
PIM Group-to-RP Mappings

R106#
R106#sh ip pim int

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
6.6.6.6          Loopback0                v2/S   0      30     1      6.6.6.6
5.5.26.6         Ethernet0/0              v2/S   1      30     1      5.5.26.6
R106#
R106#