GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: STRANGE OSPF ISSUE WITH VL posted 08/12/2007
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


I think the problem is with the 'max-metric router-lsa'. Look at the
Virtual-link costs, there both 65535. Try changing the them to something
lower. Maybe even use adjusting the link cost instead of the using the
max-metric to get the traffic to go around R1


-Ryan



On 8/11/07, NITIN NITIN <ccie_study_123@xxxxxxxxx> wrote:
>
> Hi ,
> I'm not able to get this why this virtual link not coming up , this is the
> 2nd day i'm putting on this and my exam is near....
>
> max-metric lsa is because there is a requirement that to transit R1 only
> if R2 is down ....
>
>
> R3 -----------
>
> Rack1R3#sh ip ospf nei
> Rack1R3#sh ip ospf neighbor
> Neighbor ID     Pri   State           Dead Time   Address
> Interface
> 150.1.2.2         0   FULL/  -           -        152.1.123.2     OSPF_VL7
> 150.1.7.7         1   FULL/DR         00:00:37    152.1.37.7
> FastEthernet0/0
> 150.1.1.1         0   FULL/DROTHER    00:01:45    152.1.123.1
> Serial2/0
> 150.1.2.2         0   FULL/DROTHER    00:01:45    152.1.123.2
> Serial2/0
> Rack1R3#sh ip os
> Rack1R3#sh ip ospf in
> Rack1R3#sh ip ospf interface
> OSPF_VL7 is up, line protocol is up
>   Internet Address 152.1.123.3/24, Area 0
>   Process ID 1, Router ID 150.1.3.3, Network Type VIRTUAL_LINK, Cost: 64
>   Configured as demand circuit.
>   Run as demand circuit.
>   DoNotAge LSA allowed.
>   Transmit Delay is 1 sec, State POINT_TO_POINT,
>   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
>     oob-resync timeout 40
>     Hello due in 00:00:04
>   Index 2/2, flood queue length 0
>   Next 0x0(0)/0x0(0)
>   Last flood scan length is 1, maximum is 2
>   Last flood scan time is 0 msec, maximum is 0 msec
>   Neighbor Count is 1, Adjacent neighbor count is 1
>     Adjacent with neighbor 150.1.2.2  (Hello suppressed)
>   Suppress hello for 1 neighbor(s)
> OSPF_VL6 is down, line protocol is down
>   Internet Address 0.0.0.0/0, Area 0
>   Process ID 1, Router ID 150.1.3.3, Network Type VIRTUAL_LINK, Cost:
> 65535
>   Configured as demand circuit.
>   Run as demand circuit.
>   DoNotAge LSA allowed.
>   Transmit Delay is 1 sec, State DOWN,
>   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
>     oob-resync timeout 40
> Tunnel3 is up, line protocol is up
>   Internet Address 0.0.0.0/0, Area 3
>   Process ID 1, Router ID 150.1.3.3, Network Type POINT_TO_POINT, Cost:
> 11111
>   Transmit Delay is 1 sec, State POINT_TO_POINT,
>   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
>     oob-resync timeout 40
>     No Hellos (Passive interface)
>   Index 2/5, flood queue length 0
>   Next 0x0(0)/0x0(0)
>   Last flood scan length is 0, maximum is 0
>   Last flood scan time is 0 msec, maximum is 0 msec
>   Neighbor Count is 0, Adjacent neighbor count is 0
>   Suppress hello for 0 neighbor(s)
> FastEthernet1/0 is up, line protocol is up
>   Internet Address 152.1.3.3/24, Area 3
>   Process ID 1, Router ID 150.1.3.3, Network Type NON_BROADCAST, Cost: 1
>   Transmit Delay is 1 sec, State DR, Priority 1
>   Designated Router (ID) 150.1.3.3, Interface address 152.1.3.3
>   No backup designated router on this network
>   Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
>     oob-resync timeout 120
>     Hello due in 00:00:22
>   Index 1/4, flood queue length 0
>   Next 0x0(0)/0x0(0)
>   Last flood scan length is 0, maximum is 0
>   Last flood scan time is 0 msec, maximum is 0 msec
>   Neighbor Count is 0, Adjacent neighbor count is 0
>   Suppress hello for 0 neighbor(s)
> FastEthernet0/0 is up, line protocol is up
>   Internet Address 152.1.37.3/24, Area 37
>   Process ID 1, Router ID 150.1.3.3, Network Type BROADCAST, Cost: 1
>   Transmit Delay is 1 sec, State BDR, Priority 1
>   Designated Router (ID) 150.1.7.7, Interface address 152.1.37.7
>   Backup Designated router (ID) 150.1.3.3, Interface address 152.1.37.3
>   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
>     oob-resync timeout 40
>     Hello due in 00:00:02
>   Index 2/6, flood queue length 0
>   Next 0x0(0)/0x0(0)
>   Last flood scan length is 1, maximum is 6
>   Last flood scan time is 0 msec, maximum is 4 msec
>   Neighbor Count is 1, Adjacent neighbor count is 1
>     Adjacent with neighbor 150.1.7.7  (Designated Router)
>   Suppress hello for 0 neighbor(s)
> Loopback0 is up, line protocol is up
>   Internet Address 150.1.3.3/24, Area 37
>   Process ID 1, Router ID 150.1.3.3, Network Type LOOPBACK, Cost: 1
>   Loopback interface is treated as a stub Host
> Serial2/0 is up, line protocol is up
>   Internet Address 152.1.123.3/24, Area 123
>   Process ID 1, Router ID 150.1.3.3, Network Type BROADCAST, Cost: 64
>   Transmit Delay is 1 sec, State DR, Priority 1
>   Designated Router (ID) 150.1.3.3, Interface address 152.1.123.3
>   No backup designated router on this network
>   Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
>     oob-resync timeout 120
>     Hello due in 00:00:07
>   Index 1/7, flood queue length 0
>   Next 0x0(0)/0x0(0)
>   Last flood scan length is 2, maximum is 18
>   Last flood scan time is 4 msec, maximum is 4 msec
>   Neighbor Count is 2, Adjacent neighbor count is 2
>     Adjacent with neighbor 150.1.1.1
>     Adjacent with neighbor 150.1.2.2
>   Suppress hello for 0 neighbor(s)
>
>
>
> R1 -
>
> Rack1R1#sh ip ospf neighbor
> Neighbor ID     Pri   State           Dead Time   Address
> Interface
> 150.1.2.2         1   FULL/DR         00:00:34    152.1.125.2
> FastEthernet0/0
> 150.1.5.5         0   2WAY/DROTHER    00:00:37    152.1.125.5
> FastEthernet0/0
> 150.1.3.3         1   FULL/DR         00:01:57    152.1.123.3
> Serial2/0
> Rack1R1#sh ip os
> Rack1R1#sh ip ospf int
> Rack1R1#sh ip ospf interface
> FastEthernet0/0 is up, line protocol is up
>   Internet Address 152.1.125.1/24, Area 0
>   Process ID 1, Router ID 150.1.1.1, Network Type BROADCAST, Cost: 1
>   Transmit Delay is 1 sec, State DROTHER, Priority 0
>   Designated Router (ID) 150.1.2.2, Interface address 152.1.125.2
>   No backup designated router on this network
>   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
>     oob-resync timeout 40
>     Hello due in 00:00:09
>   Index 2/4, flood queue length 0
>   Next 0x0(0)/0x0(0)
>   Last flood scan length is 1, maximum is 8
>   Last flood scan time is 0 msec, maximum is 4 msec
>   Neighbor Count is 2, Adjacent neighbor count is 1
>     Adjacent with neighbor 150.1.2.2  (Designated Router)
>   Suppress hello for 0 neighbor(s)
>   Message digest authentication enabled
>     Youngest key id is 1
> OSPF_VL2 is up, line protocol is up
>   Internet Address 152.1.123.1/24, Area 0
>   Process ID 1, Router ID 150.1.1.1, Network Type VIRTUAL_LINK, Cost:
> 65535
>   Configured as demand circuit.
>   Run as demand circuit.
>   DoNotAge LSA allowed.
>   Transmit Delay is 1 sec, State POINT_TO_POINT,
>   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
>     oob-resync timeout 40
>     Hello due in 00:00:04
>   Index 1/1, flood queue length 0
>   Next 0x0(0)/0x0(0)
>   Last flood scan length is 0, maximum is 0
>   Last flood scan time is 0 msec, maximum is 0 msec
>   Neighbor Count is 0, Adjacent neighbor count is 0
>   Suppress hello for 0 neighbor(s)
> Serial2/0 is up, line protocol is up
>   Internet Address 152.1.123.1/24, Area 123
>   Process ID 1, Router ID 150.1.1.1, Network Type NON_BROADCAST, Cost: 64
>   Transmit Delay is 1 sec, State DROTHER, Priority 0
>   Designated Router (ID) 150.1.3.3, Interface address 152.1.123.3
>   No backup designated router on this network
>   Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
>     oob-resync timeout 120
>     Hello due in 00:00:21
>   Index 2/3, flood queue length 0
>   Next 0x0(0)/0x0(0)
>   Last flood scan length is 4, maximum is 4
>   Last flood scan time is 0 msec, maximum is 4 msec
>   Neighbor Count is 1, Adjacent neighbor count is 1
>     Adjacent with neighbor 150.1.3.3  (Designated Router)
>   Suppress hello for 0 neighbor(s)
> Loopback0 is up, line protocol is up
>   Internet Address 150.1.1.1/24, Area 123
>   Process ID 1, Router ID 150.1.1.1, Network Type LOOPBACK, Cost: 1
>   Loopback interface is treated as a stub Host
>
> hostname Rack1R1
> !
> boot-start-marker
> boot-end-marker
> !
> enable password cisco
> !
> no aaa new-model
> ip subnet-zero
> !
> !
> no ip domain lookup
> !
> ip cef
> ipv6 unicast-routing
> ipv6 cef
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> !
> interface Loopback0
>  ip address 150.1.1.1 255.255.255.0
>  ipv6 address 2001:150:1:1::1/64
>  ipv6 rip RIPng enable
> !
> interface FastEthernet0/0
>  ip address 152.1.125.1 255.255.255.0
>  ip helper-address 152.1.123.3
>  ip ospf authentication message-digest
>  ip ospf message-digest-key 1 md5 CISCO
>  ip ospf priority 0
>  duplex full
>  ipv6 address 2001:152:1:125::/64 eui-64
>  ipv6 verify unicast reverse-path
>  standby 1 name j
>  glbp 1 ip 152.1.125.100
>  glbp 1 weighting 7
>  glbp 1 load-balancing weighted
> !
> interface FastEthernet1/0
>  no ip address
>  shutdown
>  duplex auto
>  speed auto
> !
> interface FastEthernet1/1
>  no ip address
>  shutdown
>  duplex auto
>  speed auto
> !
> interface Serial2/0
>  ip address 152.1.123.1 255.255.255.0
>  encapsulation frame-relay
>  ip ospf priority 0
>  ipv6 address 2001:152:1:123::1/64
>  ipv6 address FE80::1 link-local
>  ipv6 rip RIPng enable
>  serial restart-delay 0
>  no fair-queue
>  frame-relay traffic-shaping
>  frame-relay map ipv6 FE80::2 103
>  frame-relay map ipv6 FE80::3 103
>  frame-relay map ipv6 2001:152:1:123::2 103
>  frame-relay map ipv6 2001:152:1:123::3 103 broadcast
>  frame-relay interface-dlci 103
>   class R1
> !
> interface Serial2/0.1 multipoint
>  frame-relay interface-dlci 102
>  frame-relay interface-dlci 104
>  frame-relay interface-dlci 105
>  frame-relay interface-dlci 113
> !
> interface Serial2/1
>  no ip address
>  shutdown
>  serial restart-delay 0
> !
> interface Serial2/2
>  no ip address
>  shutdown
>  serial restart-delay 0
> !
> interface Serial2/3
>  no ip address
>  shutdown
>  serial restart-delay 0
> !
> router ospf 1
>  router-id 150.1.1.1
>  max-metric router-lsa
>  log-adjacency-changes
>  area 123 virtual-link 150.1.3.3
>  network 150.1.1.1 0.0.0.0 area 123
>  network 152.1.123.1 0.0.0.0 area 123
>  network 152.1.125.1 0.0.0.0 area 0
>  distribute-list 1 in Serial2/0
> !
> router bgp 1000
>  no synchronization
>  bgp router-id 150.1.1.1
>  bgp log-neighbor-changes
>  bgp confederation identifier 200
>  bgp confederation peers 3000
>  neighbor 152.1.123.3 remote-as 3000
>  neighbor 152.1.125.5 remote-as 100
>  no auto-summary
> !
> ip classless
> no ip http server
> !
> !
> !
> map-class frame-relay R1
>  frame-relay cir 896000
>  frame-relay bc 28672
> access-list 1 deny   150.1.2.2
> access-list 1 permit any
> ipv6 router rip RIPng
>  redistribute connected route-map k
> !
> !
> route-map k permit 10
>  match interface FastEthernet0/0
> !
> !
> !
> !
> !
> !
> !
> gatekeeper
>  shutdown
> !
> !
> line con 0
>  exec-timeout 0 0
>  privilege level 15
>  logging synchronous
>  stopbits 1
> line aux 0
>  exec-timeout 0 0
>  privilege level 15
>  stopbits 1
> line vty 0 4
>  password cisco
>  login
> !
> !
> end
>
>
>
>
>
>
>
>
> *Ryan <ryan95842@xxxxxxxxx>* wrote:
>
> Why do you have 'max-metric router-lsa' configured on R1?
>
> Can you post the configs for all of R1 as well?
>
> plus 'sh ip ospf nei' and 'sh ip ospf inter' for both R1 and R3
>
>
> -Ryan
>
>
>
>
>
>
> On 8/11/07, NITIN NITIN <ccie_study_123@xxxxxxxxx> wrote:
> >
> > HI ,
> >
> >   My mistake
> >
> >
> >   correct config
> >
> >   pasted wrong config
> >
> >
> >   R3
> >
> >   router ospf 1
> > router-id 150.1.3.3
> > log-adjacency-changes
> > area 123 virtual-link 150.1.1.1 authentication message-digest
> > area 123 virtual-link 150.1.1.1 message-digest-key 1 md5 CISCO
> > area 123 virtual-link 150.1.2.2 authentication message-digest
> > area 123 virtual-link 150.1.2.2 message-digest-key 1 md5 CISCO
> > passive-interface Tunnel3
> > network 150.1.3.3 0.0.0.0 area 37
> > network 152.1.3.3 0.0.0.0 area 3
> > network 152.1.37.3 0.0.0.0 area 37
> > network 152.1.123.3 0.0.0.0 area 123
> > distance 255 150.1.5.5 0.0.0.0 89
> >
> >
> >
> >
> > Herbert Maosa <asawilunda@xxxxxxxxxxxxxx> wrote:
> >   Why is R3 building its virtual link to 150.1.3.3 ? Isn't this R3's own
> > Router ID. Looking at your config below, I would expect R3 to have two
> > virtual links, one to 150.1.1.1 and the other to 150.1.2.2 ?
> >
> > Herbert
> >
> >   On 8/11/07, NITIN NITIN <ccie_study_123@xxxxxxxxx > wrote:  Hi
> > EXPERTS,
> >
> >   Sorry to bother again, but hope u understand exam is near
> >
> >   Issue I'm facing now is ----
> >   R1 and R2 are spokes and R3 is hub
> >
> >   R3 virtual link is not coming up after router rebbot with R1 , it was
> > up eralier
> >
> >
> >   WITH R2 ---- VL of R3 is up
> >
> >
> >   R3-------------
> >
> >   interface Serial2/0
> > ip address 152.1.123.1 255.255.255.0
> > encapsulation frame-relay
> > ip ospf priority 0
> > ipv6 address 2001:152:1:123::1/64
> > ipv6 address FE80::1 link-local
> > ipv6 rip RIPng enable
> > serial restart-delay 0
> > no fair-queue
> > frame-relay traffic-shaping
> > frame-relay map ipv6 FE80::2 103
> > frame-relay map ipv6 FE80::3 103
> > frame-relay map ipv6 2001:152:1:123::2 103
> > frame-relay map ipv6 2001:152:1:123::3 103 broadcast
> > frame-relay interface-dlci 103
> >   class R1
> >
> >
> >   router ospf 1
> > router-id 150.1.1.1
> > max-metric router-lsa
> > log-adjacency-changes
> > area 123 virtual-link 150.1.3.3 authentication message-digest
> > area 123 virtual-link 150.1.3.3 message-digest-key 1 md5 CISCO
> > network 150.1.1.1 0.0.0.0 area 123
> > network 152.1.123.1 0.0.0.0 area 123
> > network 152.1.125.1 0.0.0.0 area 0
> > distribute-list 1 in Serial2/0
> >
> >
> >
> >   R2-----
> >
> >
> >
> >   router ospf 1
> > router-id 150.1.2.2
> > log-adjacency-changes
> > area 123 virtual-link 150.1.3.3 authentication message-digest
> > area 123 virtual-link 150.1.3.3 message-digest-key 1 md5 CISCO
> > network 150.1.2.2 0.0.0.0 area 123
> > network 152.1.123.2 0.0.0.0 area 123
> > network 152.1.125.2 0.0.0.0 area 0
> > default-information originate always
> > distribute-list 1 in Serial2/0
> > !
> >
> >
> >
> >   R1----
> >
> >
> >   router ospf 1
> > router-id 150.1.1.1
> > max-metric router-lsa
> > log-adjacency-changes
> > area 123 virtual-link 150.1.3.3 authentication message-digest
> > area 123 virtual-link 150.1.3.3 message-digest-key 1 md5 CISCO
> > network 150.1.1.1 0.0.0.0 area 123
> > network 152.1.123.1 0.0.0.0 area 123
> > network 152.1.125.1 0.0.0.0 area 0
> > distribute-list 1 in Serial2/0
> >
> >
> >
> >   ISSUE
> >
> >
> >   Rack1R3#   sh ip ospf virtual-links
> > Virtual Link OSPF_VL7 to router 150.1.2.2 is up
> >   Run as demand circuit
> >   DoNotAge LSA allowed.
> >   Transit area 123, via interface Serial2/0, Cost of using 64
> >   Transmit Delay is 1 sec, State POINT_TO_POINT,
> >   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
> >     Hello due in 00:00:08
> >     Adjacency State FULL (Hello suppressed)
> >     Index 1/4, retransmission queue length 0, number of retransmission 0
> >
> >     First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
> >     Last retransmission scan length is 0, maximum is 0
> >     Last retransmission scan time is 0 msec, maximum is 0 msec
> > Virtual Link OSPF_VL6 to router 150.1.1.1 is down
> >   Run as demand circuit
> >   DoNotAge LSA allowed.
> >   Transit area 123, Cost of using 65535
> >   Transmit Delay is 1 sec, State DOWN,
> >   Timer intervals configured, Hello 10, Dead 40, Wa
> >
> >
> >
> >   Rack1R1#sh ip ospf virtual-links
> > Virtual Link OSPF_VL2 to router 150.1.3.3 is up
> >   Run as demand circuit
> >   DoNotAge LSA allowed.
> >   Transit area 123, via interface Serial2/0, Cost of using 65535
> >   Transmit Delay is 1 sec, State POINT_TO_POINT,
> >   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
> >     Hello due in 00:00:04
> >
> >
> >
> >
> >
> > ---------------------------------
> > Looking for a deal? Find great prices on flights and hotels with Yahoo!
> > FareChase.
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> >
> >
> >
> > --
> > Kindest regards,
> > hm
> >
> >
> > ---------------------------------
> > Shape Yahoo! in your own image.  Join our Network Research Panel today!
> >
> > ---------------------------------
> > Got a little couch potato?
> > Check out fun summer activities for kids.
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
>
>
> ------------------------------
> Looking for a deal? Find great prices on flights and hotels<http://us.rd.yahoo.com/evt=47094/*http://farechase.yahoo.com/;_ylc=X3oDMTFicDJoNDllBF9TAzk3NDA3NTg5BHBvcwMxMwRzZWMDZ3JvdXBzBHNsawNlbWFpbC1uY20->with Yahoo! FareChase.
>
> ------------------------------
> Pinpoint customers
> <http://us.rd.yahoo.com/evt=48250/*http://searchmarketing.yahoo.com/arp/sponsoredsearch_v9.php?o=US2226&cmp=Yahoo&ctv=AprNI&s=Y&s2=EM&b=50>who
> are looking for what you sell.