GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: default peer ip address ppp posted 03/28/2007
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Use DHCP.  With IPCP the subnet mask will not be learned.


interface Ethernet0/1
 no ip address
 pppoe enable
 pppoe-client dial-pool-number 1
!
interface Dialer1
 ip address dhcp
 encapsulation ppp
 dialer pool 1
 dialer persistent
 no cdp enable
 
 
 ************************************************
 
ip dhcp excluded-address 190.12.45.1 190.12.45.3
!
ip dhcp pool CISCO
   network 190.12.45.0 255.255.255.0
!
vpdn enable
!
vpdn-group CISCO
 accept-dialin
  protocol pppoe
  virtual-template 1
! 
interface Ethernet0/0
  no ip address
  pppoe enable
!
interface Virtual-Template1
 ip address 190.12.45.5 255.255.255.0
 peer default ip address dhcp-pool CISCO


-- 

Brian Dennis, CCIE4 #2210 (R&S/ISP-Dial/Security/SP)
bdennis@xxxxxxxxxxxxxxxxxxxxxx
 
Internetwork Expert, Inc.
http://www.InternetworkExpert.com
Toll Free: 877-224-8987
Direct: 775-745-6404 (Outside the US and Canada)


On 3/28/07 1:10 PM, "Koen Zeilstra" <koen@xxxxxxxxxxxxxxxx> wrote:

> Hi group,
> 
> When assiging an IP address to a PPP neighbor in, for example
> PPPoE, you may use a local pool or a DHCP pool. The neigbhor gets the ip
> address assigned during PPP negotiation. It always assigns a /32 mask to
> the dialer interface. Would it be possible to change this behaviour and
> assign for example a /24 to the PPP neighbor?
> 
> thanks in advance,
> 
> Koen
> 
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html