GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: RIP Summary Problem posted 03/01/2007
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Hi, 

I have the exact same configuration that you are running, and it is
working fine..
 

R1(config-router)#do show run | in netw|rip|auto- 
router rip
 network 192.168.0.0
 no auto-summary

R1(config-router)#do show run int f0/0
Building configuration...

Current configuration : 98 bytes
!
interface FastEthernet0/0
 ip address 192.168.0.1 255.255.255.252
 duplex auto
 speed auto
end

R2(config-router)#do show run | in netw|rip|auto-
router rip
 network 4.0.0.0
 network 192.168.0.0
 no auto-summary

R2(config)#int lo0
R2(config-if)#  interface Loopback1
R2(config-if)#  ip address 4.4.1.1 255.255.255.0
R2(config-if)#  !
R2(config-if)#  interface Loopback2
R2(config-if)#  ip address 4.4.2.1 255.255.255.0
R2(config-if)#  !
R2(config-if)#  interface Loopback3
R2(config-if)#  ip address 4.4.3.1 255.255.255.0
R2(config-if)#
R2(config-if)#do clear ip route *

R2(config-router)#do show run int f0/0                        
Building configuration...

Current configuration : 140 bytes
!
interface FastEthernet0/0
 ip address 192.168.0.2 255.255.255.252
 ip summary-address rip 4.0.0.0 255.0.0.0
 duplex auto
 speed auto
end


R1(config-router)#
*Mar  2 00:15:14.090: RIP: sending v2 flash update to 192.168.0.2 via
FastEthernet0/0 (192.168.0.1)
*Mar  2 00:15:14.090: RIP: build flash update entries - suppressing null
update
*Mar  2 00:15:16.634: RIP: received v2 update from 192.168.0.2 on
FastEthernet0/0
*Mar  2 00:15:16.634:      4.0.0.0/8 via 0.0.0.0 in 1 hops
R1(config-router)#do show ip route rip
R    4.0.0.0/8 [120/1] via 192.168.0.2, 00:00:05, FastEthernet0/0
R1(config-router)#do show ip route rip
R    4.0.0.0/8 [120/1] via 192.168.0.2, 00:00:18, FastEthernet0/0
R1(config-router)#do clear ip route *
R1(config-router)#do show ip route rip

R1(config-router)#do show ip route rip

R1(config-router)#do show ip route rip
R    4.0.0.0/8 [120/1] via 192.168.0.2, 00:00:00, FastEthernet0/0
R1(config-router)#do show ip route rip
R    4.0.0.0/8 [120/1] via 192.168.0.2, 00:00:01, FastEthernet0/0

Can you show us this information, from both routers please?

show ip proto
Show ip route
Show ip rip database
Show run | in router|rip|network|auto|summa|interface
show int | in up


Thanks,
Victor Cappuccio.
Network Learning Inc - A Cisco Sponsored Organization (SO) YES! We take
Cisco Learning credits!
victor@xxxxxxxxxxxxxx
http://www.ccbootcamp.com (Cisco Training and Rental Racks)
http://www.ccbootcamp.com/groupstudy.html (groupstudy member discounts!)
Voice: 702-968-5100
FAX: 702-446-8012

-----Original Message-----

>Andreson Chris wrote:
> > Hello GS,
> >
> > I am learning RIP recently and try create summary route to an other
> > Router. Both router are running version 2 with no summary
> >
> > R2 is trying to generate summary route to R1. However I can't find
the
> > any at R1. And debug message as below. Did i do something wrong? I
> > have tried use auto aummary is work but however i can't do it via
> > interface.
> >
> > Rgds Chris.
> >
> > R2#
> > *Mar 1 00:11:59.647: RIP: sending v2 flash update to 192.168.0.1 via
> > FastEthernet0/0 (192.168.0.2)
> > *Mar 1 00:11:59.651: RIP: build flash update entries - suppressing
> > null update
> >
> > 4.0.0.0/24 is subnetted, 3 subnets
> > C 4.4.1.0 is directly connected, Loopback1
> > C 4.4.2.0 is directly connected, Loopback2
> > C 4.4.3.0 is directly connected, Loopback3
> > 192.168.0.0/30 is subnetted, 1 subnets
> > C 192.168.0.0 is directly connected, FastEthernet0/0
> >
> >
> > R2#
> >
> >
> > The design is very simple
> >
> > fa0/0 192.168.0.0/30 fa0/0
> > R1 ============R2 lo1 4.4.1.1/24
> > lo2 4.4.2.1/24
> > lo3 4.4.3.1/24
> >
> > This is R1 config
> >
> > interface FastEthernet0/0
> > ip address 192.168.0.1 255.255.255.252
> > duplex auto
> > speed auto
> > !
> > interface FastEthernet0/1
> > no ip address
> > shutdown
> > duplex auto
> > speed auto
> > !
> > router rip
> > version 2
> > network 192.168.0.0
> > no auto-summary
> > !
> > This is R2 config
> >
> > interface Loopback1
> > ip address 4.4.1.1 255.255.255.0
> > !
> > interface Loopback2
> > ip address 4.4.2.1 255.255.255.0
> > !
> > interface Loopback3
> > ip address 4.4.3.1 255.255.255.0
> > !
> > interface FastEthernet0/0
> > ip address 192.168.0.2 255.255.255.252
> > ip summary-address rip 4.0.0.0 255.0.0.0
> > duplex auto
> > speed auto
> > !
> > interface FastEthernet0/1
> > no ip address
> > duplex auto
> > speed auto
> > !
> > router rip
> > version 2
> > passive-interface default
> > network 4.0.0.0
> > network 192.168.0.0
> > neighbor 192.168.0.1
> > no auto-summary
> >
_______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
>_______________________________________________________________________
>Subscription information may be found at:
>http://www.groupstudy.com/list/CCIELab.html

_________________________________________________________________
Don't just search. Find. Check out the new MSN Search! 
http://search.msn.click-url.com/go/onm00200636ave/direct/01/

_______________________________________________________________________
Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html

_______________________________________________________________________
Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html