GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: IEWBv4, Lab2, Q 1.6: VTP Pruning posted 02/28/2007
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Thanks DP for replying,

In solution, the verification shows that the trunk to sw2 prune some vlans.

So the solution output wasn't taken from the real devices? Anyone from
InternetworkExpert can make this clear?

Thanks

On 2/28/07, Derek P <rizacer@xxxxxxxxx> wrote:
>
> Without having the lab in front of me.
>
> I do see f0/6 on SW2 is set for tunking and is requesting all VLAN's this
> would cause your pruning to look as if its not working.
>
>
> DP
>
> On 2/27/07, nhatphuc <nhatphuc@xxxxxxxxx> wrote:
>
> > Hi Group,
> >
> > In Question 1.6, IEWBv4 Lab 2, I configure pruning on SW1, and vtp
> > pruning
> > is enabled on the other 3 switches. But when showing int trunk, the
> > trunk
> > link to switch 2 doesn't prune the nonexistence vlans. My config is the
> > same
> > as solution.
> >
> > What could the problem be?
> > If I encounter the same issue in real lab, what should I do to fix the
> > problem?
> >
> > Thanks
> >
> > This is my config:
> >
> > SW1#do sh int tru
> >
> > Port        Mode         Encapsulation  Status        Native vlan
> > Po1         on           isl            trunking      1
> > Po2         auto         n-802.1q       trunking      783
> > Po3         desirable    n-isl          trunking      1
> >
> > Port        Vlans allowed on trunk
> > Po1         1-4094
> > Po2         1-4094
> > Po3         1-4094
> >
> > Port        Vlans allowed and active in management domain
> > Po1         1,3,5-6,8,10,26,33,52,255,783
> > Po2         1,3,5-6,8,10,26,33,52,255,783
> > Po3         1,3,5-6,8,10,26,33,52,255,783
> >
> > Port        Vlans in spanning tree forwarding state and not pruned
> > Po1         1,3,5-6,8,10,26,33,52,255,783
> > Po2         1,33,52,255,783
> > Po3         1,255
> >
> >
> > SW1#sh run
> > Building configuration...
> >
> > Current configuration : 2535 bytes
> > !
> > version 12.2
> > no service pad
> > service timestamps debug uptime
> > service timestamps log uptime
> > no service password-encryption
> > !
> > hostname SW1
> > !
> > enable password cisco
> > !
> > aaa new-model
> > aaa authentication login default none
> > !
> > aaa session-id common
> > ip subnet-zero
> > no ip domain-lookup
> > !
> > lacp system-priority 1
> > no file verify auto
> > spanning-tree mode pvst
> > spanning-tree extend system-id
> > !
> > vlan internal allocation policy ascending
> > !
> > !
> > interface Loopback0
> > ip address 150.1.7.7 255.255.255.0
> > !
> > interface Port-channel1
> > switchport trunk encapsulation isl
> > switchport mode trunk
> > !
> > interface Port-channel2
> > switchport trunk native vlan 783
> > !
> > interface Port-channel3
> > switchport mode dynamic desirable
> > !
> > interface FastEthernet0/1
> > no switchport
> > ip address 132.1.17.7 255.255.255.0
> > !
> > interface FastEthernet0/2
> > !
> > interface FastEthernet0/3
> > switchport access vlan 3
> > !
> > interface FastEthernet0/4
> > !
> > interface FastEthernet0/5
> > switchport access vlan 5
> > !
> > interface FastEthernet0/6
> > !
> > interface FastEthernet0/7
> > !
> > interface FastEthernet0/8
> > !
> > interface FastEthernet0/9
> > !
> > interface FastEthernet0/10
> > switchport access vlan 10
> > !
> > interface FastEthernet0/11
> > switchport access vlan 10
> > !
> > interface FastEthernet0/12
> > !
> > interface FastEthernet0/13
> > switchport trunk encapsulation isl
> > switchport mode trunk
> > channel-group 1 mode on
> > !
> > interface FastEthernet0/14
> > switchport trunk encapsulation isl
> > switchport mode trunk
> > channel-group 1 mode on
> > !
> > interface FastEthernet0/15
> > switchport trunk encapsulation isl
> > switchport mode trunk
> > channel-group 1 mode on
> > !
> > interface FastEthernet0/16
> > switchport trunk native vlan 783
> > channel-group 2 mode active
> > !
> > interface FastEthernet0/17
> > switchport trunk native vlan 783
> > channel-group 2 mode active
> > !
> > interface FastEthernet0/18
> > switchport trunk native vlan 783
> > channel-group 2 mode active
> > !
> > interface FastEthernet0/19
> > switchport mode dynamic desirable
> > channel-group 3 mode active
> > !
> > interface FastEthernet0/20
> > switchport mode dynamic desirable
> > channel-group 3 mode active
> > !
> > interface FastEthernet0/21
> > shutdown
> > !
> > interface FastEthernet0/22
> > !
> > interface FastEthernet0/23
> > !
> > interface FastEthernet0/24
> > !
> > interface GigabitEthernet0/1
> > !
> > interface GigabitEthernet0/2
> > !
> > interface Vlan1
> > no ip address
> > shutdown
> > !
> > interface Vlan783
> > ip address 204.12.1.7 255.255.255.0
> > !
> > ip classless
> > ip http server
> > ip http secure-server
> > !
> > !
> > radius-server source-ports 1645-1646
> > !
> > control-plane
> > !
> > !
> > line con 0
> > exec-timeout 0 0
> > privilege level 15
> > logging synchronous
> > line vty 0 4
> > password cisco
> > line vty 5 15
> > password cisco
> > !
> > end
> >
> >
> > SW2#do s run
> > Building configuration...
> >
> > Current configuration : 2109 bytes
> > !
> > version 12.2
> > no service pad
> > service timestamps debug uptime
> > service timestamps log uptime
> > no service password-encryption
> > !
> > hostname SW2
> > !
> > enable password cisco
> > !
> > no aaa new-model
> > ip subnet-zero
> > no ip domain-lookup
> > !
> > !
> > !
> > !
> > !
> > !
> > no file verify auto
> > spanning-tree mode pvst
> > spanning-tree extend system-id
> > !
> > vlan internal allocation policy ascending
> > !
> > !
> > interface Loopback0
> > ip address 150.1.8.8 255.255.255.0
> > !
> > interface Port-channel1
> > switchport trunk encapsulation isl
> > switchport mode trunk
> > !
> > interface FastEthernet0/1
> > !
> > interface FastEthernet0/2
> > switchport access vlan 26
> > !
> > interface FastEthernet0/3
> > !
> > interface FastEthernet0/4
> > !
> > interface FastEthernet0/5
> > !
> > interface FastEthernet0/6
> > switchport trunk encapsulation dot1q
> > switchport trunk native vlan 6
> > switchport mode trunk
> > switchport nonegotiate
> > !
> > interface FastEthernet0/7
> > !
> > interface FastEthernet0/8
> > switchport access vlan 52
> > !
> > interface FastEthernet0/9
> > !
> > interface FastEthernet0/10
> > !
> > interface FastEthernet0/11
> > !
> > interface FastEthernet0/12
> > !
> > interface FastEthernet0/13
> > switchport trunk encapsulation isl
> > switchport mode trunk
> > channel-group 1 mode on
> > !
> > interface FastEthernet0/14
> > switchport trunk encapsulation isl
> > switchport mode trunk
> > channel-group 1 mode on
> > !
> > interface FastEthernet0/15
> > switchport trunk encapsulation isl
> > switchport mode trunk
> > channel-group 1 mode on
> > !
> > interface FastEthernet0/16
> > shutdown
> > !
> > interface FastEthernet0/17
> > shutdown
> > !
> > interface FastEthernet0/18
> > shutdown
> > !
> > interface FastEthernet0/19
> > shutdown
> > !
> > interface FastEthernet0/20
> > shutdown
> > !
> > interface FastEthernet0/21
> > shutdown
> > !
> > interface FastEthernet0/22
> > !
> > interface FastEthernet0/23
> > !
> > interface FastEthernet0/24
> > !
> > interface GigabitEthernet0/1
> > !
> > interface GigabitEthernet0/2
> > !
> > interface Vlan1
> > no ip address
> > shutdown
> > !
> > interface Vlan8
> > ip address 132.1.8.8 255.255.255.0
> > !
> > interface Vlan783
> > ip address 204.12.1.8 255.255.255.0
> > !
> > ip classless
> > ip http server
> > ip http secure-server
> > !
> > control-plane
> > !
> > !
> > line con 0
> > exec-timeout 0 0
> > privilege level 15
> > logging synchronous
> > line vty 0 4
> > password cisco
> > login
> > line vty 5 15
> > password cisco
> > login
> > !
> > end
> >
> > SW2#sh int tru
> >
> > Port        Mode         Encapsulation  Status        Native vlan
> > Fa0/6       on           802.1q         trunking      6
> > Po1         on           isl            trunking      1
> >
> > Port        Vlans allowed on trunk
> > Fa0/6       1-4094
> > Po1         1-4094
> >
> > Port        Vlans allowed and active in management domain
> > Fa0/6       1,3,5-6,8,10,26,33,52,255,783
> > Po1         1,3,5-6,8,10,26,33,52,255,783
> >
> > Port        Vlans in spanning tree forwarding state and not pruned
> > Fa0/6       1,3,5-6,8,10,26,33,52,255,783
> > Po1         1,3,5,10,33,52,255,783
> >
> > SW2(config-if)#do sh vl
> >
> > VLAN Name                             Status    Ports
> > ---- -------------------------------- ---------
> > -------------------------------
> > 1    default                          active    Fa0/1, Fa0/3, Fa0/4,
> > Fa0/5
> >                                                 Fa0/7, Fa0/9, Fa0/10,
> > Fa0/11
> >                                                 Fa0/12, Fa0/16, Fa0/17,
> > Fa0/18
> >                                                 Fa0/19, Fa0/20, Fa0/21,
> > Fa0/22
> >                                                 Fa0/23, Fa0/24, Gi0/1,
> > Gi0/2
> > 3    VLAN0003                         active
> > 5    VLAN0005                         active
> > 6    VLAN0006                         active
> > 8    VLAN0008                         active
> > 10   VLAN0010                         active
> > 26   VLAN0026                         active    Fa0/2
> > 33   VLAN0033                         active
> > 52   VLAN0052                         active    Fa0/8
> > 255  VLAN0255                         active
> > 783  VLAN0783                         active
> > 1002 fddi-default                     act/unsup
> > 1003 token-ring-default               act/unsup
> > 1004 fddinet-default                  act/unsup
> > 1005 trnet-default                    act/unsup
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html