GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: GRE Tunneling for ipv6 posted 02/24/2007
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


GRE/IPv4 Tunnel:

interface Tunnel0
 no ip address
 ipv6 address 2001:0DB8:1111:2222::1/64
 tunnel source Ethernet0/0
 tunnel destination 10.0.0.2
 tunnel mode gre ip


GRE/IPv6 Tunnel:

interface Tunnel0
 ip address 10.1.1.1 255.255.255.0
 tunnel source Ethernet0/0
 tunnel destination 2001:DB8:1111:2222::1
 tunnel mode gre ipv6
!
interface Ethernet0/0
 no ip addres
 ipv6 address 2001:DB8:1111:1111::1/64


There quite a few examples!

http://www.cisco.com/univercd/cc/td/doc/product/software/ios124/124cg/hif_c/
inb_tun.htm#wp1064149

Darrin


-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of
nhatphuc
Sent: Thursday, February 22, 2007 9:01 AM
To: Cisco certification
Subject: GRE Tunneling for ipv6

Hi GS,

In Cisco Press Self-Study Implementing IPv6 Network book, there's a scenario
deploying ipv6 over gre tunnel.

Cisco uses the following configuration:

RouterR1#configure terminal
RouterR1(config)#int tunnel0
RouterR1(config-if)#ipv6 address 3ffe:b00:ffff:2::1/64
RouterR1(config-if)#tunnel source 206.123.31.200
RouterR1(config-if)#tunnel destination 132.214.1.10
RouterR1(config-if)#tunnel mode gre ipv6
RouterR2(config-if)#exit

I think command "tunnel mode gre ipv6" is used when tunneling is created
over ipv6 network

If so the correct configuration should be:

1. change tunnel source and destination addresses to ipv6 address
or
2. change mode to "tunnel mode gre" (this is default on int tunnel)

Am I correct?

Thanks

Phuc

_______________________________________________________________________
Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html