GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: Cisco IP Phone posted 02/16/2007
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Hi Antonio,

By default, the port is not trusted. All traffic is sent through one
egress queue. Use the COS keyword to classify ingress packets with CoS
values. The egress queue assigned to the packet is based on the packet
CoS value. When this keyword is entered, the traffic is sent through the
four QoS queues mls qos trust device cisco-phone

Let say this is an important person PC attached to the Phone (like
Brad's computers, and we want him to have all this QoS Values changed,
(he take so much BW of the internet conection :P)  and we want to give
him something better than the default CoS of 0 (he had 5 ;)), well we
can change the  default CoS of the switchport: mls qos cos 1
  
The problem is that Brad is smart enough to make his PC mark traffic as
CoS   5,   but 5 is only voice, but he does not remember that we have
one more card we can use, so we can instruct the  phone to override his
markings using the switchport priority extend cos 1, and no matter what
he does his data will come as COS 1 then I let him mark himself with
whatever value he want... heheheh hope he does not read this ;)

Now if you want to trust the phone, then you can use this - mls qos
trust device cisco-phone 

To verify the configuration of all this thing

show interfaces fa 0/4 switchport
show mls qos interface fa 0/4

Example Configuration:

Switch(config)# mls qos
Switch(config)# interface fastethernet 0/4
Switch(config-if)# switchport voice vlan 110
Switch(config-if)# switchport access vlan 10
Switch(config-if)# mls qos trust cos
Switch(config-if)# mls qos trust device cisco-phone
Switch(config-if)# ctrl-Z
Switch# show interfaces fastethernet 0/4

Switch# show mls qos interface fastethernet 0/4
FastEthernet0/4
trust state: trust cos
trust mode: trust cos
COS override: dis
default COS: 0
pass-through: none
trust device: cisco-phone


HTH

Thanks,
Victor Cappuccio.
Network Learning Inc - A Cisco Sponsored Organization (SO) YES! We take
Cisco Learning credits!
victor@xxxxxxxxxxxxxx
http://www.ccbootcamp.com (Cisco Training and Rental Racks)
http://www.ccbootcamp.com/groupstudy.html (groupstudy member discounts!)
Voice: 702-968-5100
FAX: 702-446-8012


-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of
Antonio Soares
Sent: Saturday, February 17, 2007 11:11 PM
To: ccielab@xxxxxxxxxxxxxx
Subject: RE: Cisco IP Phone
Importance: Low

Hello GS,

May have I have some inputs about this ? I'm almost sure but I don't
have
means to test it.

Thanks.
Antonio

-----Original Message-----
From: Antonio Soares [mailto:amsoares@xxxxxxxxxx] 
Sent: sexta-feira, 16 de Fevereiro de 2007 1:18
To: 'ccielab@xxxxxxxxxxxxxx'
Subject: Cisco IP Phone

Dear GS,

Question: i need to assign CoS=1 to traffic coming from a device
connected
to a 7960 IP Phone and trust the Voice Traffic CoS. I see 3 options: use
"mls qos cos 1" if the traffic is untagged, "switchport priority extend
cos
1" if the traffic is tagged or both commands if i don't know about
tagging.
Is this correct ?

+++++++++++++++++++++++++++++++++++++++++++++++++
#1 The traffic coming from the device is untagged

Rack1SW1#sh runn int g0/7
Building configuration...

Current configuration : 170 bytes
!
interface GigabitEthernet0/7
 switchport access vlan 17
 switchport mode access
 switchport voice vlan 7
 mls qos cos 1
 mls qos trust cos
 spanning-tree portfast
end

Rack1SW1#sh mls qos int g0/7
GigabitEthernet0/7
trust state: trust cos
trust mode: trust cos
trust enabled flag: ena
COS override: dis
default COS: 1
DSCP Mutation Map: Default DSCP Mutation Map
Trust device: none
qos mode: port-based

Rack1SW1#sh int g0/7 switchport | inc Appliance
Appliance trust: none
Rack1SW1#
+++++++++++++++++++++++++++++++++++++++++++++++++
#2 The traffic coming from the device is tagged

Rack1SW1#


Rack1SW1#sh runn int g0/7
Building configuration...

Current configuration : 189 bytes
!
interface GigabitEthernet0/7
 switchport access vlan 17
 switchport mode access
 switchport voice vlan 7
 switchport priority extend cos 1
 mls qos trust cos
 spanning-tree portfast
end

Rack1SW1#sh mls qos int g0/7
GigabitEthernet0/7
trust state: trust cos
trust mode: trust cos
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
Trust device: none
qos mode: port-based

Rack1SW1#sh int g0/7 switchport | inc Appliance
Appliance trust: 1
Rack1SW1#
+++++++++++++++++++++++++++++++++++++++++++++++++
#3 The traffic coming from the device may be tagged or untagged

Rack1SW1#sh runn int g0/7   
Building configuration...

Current configuration : 204 bytes
!
interface GigabitEthernet0/7
 switchport access vlan 17
 switchport mode access
 switchport voice vlan 7
 switchport priority extend cos 1
 mls qos cos 1
 mls qos trust cos
 spanning-tree portfast
end

Rack1SW1#sh mls qos int g0/7
GigabitEthernet0/7
trust state: trust cos
trust mode: trust cos
trust enabled flag: ena
COS override: dis
default COS: 1
DSCP Mutation Map: Default DSCP Mutation Map
Trust device: none
qos mode: port-based

Rack1SW1#sh int g0/7 switchport | inc Appliance
Appliance trust: 1
Rack1SW1#
+++++++++++++++++++++++++++++++++++++++++++++++++


Thanks,
Antonio

_______________________________________________________________________
Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html