GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: ICMP showing encapsulation failed posted 01/27/2007
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Try to change change CAT1 to client mode and watch vlan database
population...

sh vtp stat
sh vlan
sh span vlan 30
ping


-----Original Message-----
From: Michael Zuo [mailto:mzuo@xxxxxxxxxxx] 
Sent: Saturday, January 27, 2007 9:07 PM
To: Alex Ouraev; ccielab@xxxxxxxxxxxxxx
Subject: RE: ICMP showing encapsulation failed

After UDLD aggressive on f0/14 from both sides, nothing happens.

Also, I think VTP is not a factor here since both switches already have
vlan 30.  but there is the debug output:

CAT1(config-if)#do sh vtp stat
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 11
VTP Operating Mode              : Transparent
VTP Domain Name                 : LAB1
VTP Pruning Mode                : Enabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x6E 0x16 0x30 0x8E 0xA5 0xBC 0xE9
0x99
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
CAT1(config-if)#

CAT2(config)#do sh vtp stat
VTP Version                     : 2
Configuration Revision          : 10
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 11
VTP Operating Mode              : Server
VTP Domain Name                 : LAB1
VTP Pruning Mode                : Enabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x2E 0x05 0x19 0x29 0x6C 0xB6 0x69
0x18
Configuration last modified by 172.16.110.129 at 3-22-93 04:47:07
Local updater ID is 172.16.20.10 on interface Vl10 (lowest numbered VLAN
interfa
ce found)


thanks

-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of
Alex Ouraev
Sent: Saturday, January 27, 2007 5:49 PM
To: ccielab@xxxxxxxxxxxxxx
Subject: RE: ICMP showing encapsulation failed

Could you show vtp info?
do sh vtp stat

... also turn on udld on both switches f0/14

-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of
Michael Zuo
Sent: Saturday, January 27, 2007 8:38 PM
To: Muizebelt Danny; ccielab groupstudy; Sergey Golovanov
Subject: RE: ICMP showing encapsulation failed

I have narrowed problem down to two adjacent switches can not ping each
other over the trunk link and collected debug info as follows (note that
the ARP debug shows that CAT2 responded to ARP but CAT1 never received
the response.  Also the trunk link between the two is f0/14 on both
sides, I verified the physical connection by shut/no shut on the
interface and watch the same interface go up and down on the other
switch):


CAT1(config-if)#do sh vlan

VLAN Name                             Status    Ports
---- -------------------------------- ---------
-------------------------------
1    default                          active    Fa0/1, Fa0/3, Fa0/5,
Fa0/7
                                                Fa0/9, Fa0/10, Fa0/11,
Fa0/12
                                                Fa0/15, Fa0/16, Fa0/17,
Fa0/18
                                                Fa0/19, Fa0/20, Fa0/21,
Fa0/24
                                                Gi0/1, Gi0/2
10   NET-10                           active    Fa0/2
20   NET-20                           active    Fa0/6
30   NET-30                           active    Fa0/4
40   NET-40                           active
101  VLAN0101                         active
102  VLAN0102                         active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
3000 VLAN3000                         active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1
Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------
------
1    enet  100001     1500  -      -      -        -    -        0
0

CAT1(config-if)#do sh run int vlan 30
Building configuration...

Current configuration : 63 bytes
!
interface Vlan30
 ip address 172.16.34.10 255.255.255.0
end

CAT1(config-if)#
CAT1(config-if)#
CAT1(config-if)#
CAT1(config-if)#do sh int trun

Port        Mode         Encapsulation  Status        Native vlan
Fa0/8       on           802.1q         trunking      1
Fa0/13      on           isl            trunking      1
Fa0/14      on           802.1q         trunking      1
Fa0/22      desirable    802.1q         trunking      1
Fa0/23      desirable    802.1q         trunking      1

Port      Vlans allowed on trunk
Fa0/8       1-4094
Fa0/13      10
Fa0/14      1,20,30,40
Fa0/22      1-4094
Fa0/23      1-4094

Port        Vlans allowed and active in management domain
Fa0/8       1,10,20,30,40,101-102,3000
Fa0/13      10
Fa0/14      1,20,30,40
Fa0/22      1,10,20,30,40,101-102,3000
Fa0/23      1,10,20,30,40,101-102,3000

Port        Vlans in spanning tree forwarding state and not pruned

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/8       1,10,20,30,40,101-102,3000
Fa0/13      10
Fa0/14      1,20,30,40
Fa0/22      1,10,20,30,40,101-102,3000
Fa0/23      1,10,20,30,40,101-102,3000
CAT1(config-if)#do sh span vlan 30

VLAN0030
  Spanning tree enabled protocol ieee
  Root ID    Priority    32798
             Address     0011.20a9.9280
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32798  (priority 32768 sys-id-ext 30)
             Address     0011.20a9.9280
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- --------
--------------------------------
Fa0/4            Desg FWD 19        128.4    P2p
Fa0/8            Desg FWD 19        128.8    P2p
Fa0/14           Desg FWD 19        128.14   P2p
Fa0/22           Desg FWD 19        128.22   P2p
Fa0/23           Desg FWD 19        128.23   P2p

CAT1(config-if)#do deb arp
ARP packet debugging is on
CAT1(config-if)#do ping 172.16.34.11

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.34.11, timeout is 2 seconds:

00:28:03: IP ARP: creating incomplete entry for IP address: 172.16.34.11
interfa
ce Vlan30
00:28:03: IP ARP: sent req src 172.16.34.10 0011.20a9.9280,
                 dst 172.16.34.11 0000.0000.0000 Vlan30.
00:28:05: IP ARP: sent req src 172.16.34.10 0011.20a9.9280,
                 dst 172.16.34.11 0000.0000.0000 Vlan30.
00:28:07: IP ARP: sent req src 172.16.34.10 0011.20a9.9280,
                 dst 172.16.34.11 0000.0000.0000 Vlan30.
00:28:09: IP ARP: sent req src 172.16.34.10 0011.20a9.9280,
                 dst 172.16.34.11 0000.0000.0000 Vlan30.
00:28:11: IP ARP: sent req src 172.16.34.10 0011.20a9.9280,
                 dst 172.16.34.11 0000.0000.0000 Vlan30.
Success rate is 0 percent (0/5)
CAT1(config-if)#



CAT2(config-if)#do sh vlan

VLAN Name                             Status    Ports
---- -------------------------------- ---------
-------------------------------
1    default                          active    Fa0/2, Fa0/4, Fa0/6,
Fa0/7
                                                Fa0/8, Fa0/9, Fa0/10,
Fa0/11
                                                Fa0/12, Fa0/15, Fa0/16,
Fa0/17
                                                Fa0/18, Fa0/19, Fa0/20,
Fa0/21
                                                Fa0/24, Gi0/1, Gi0/2
10   NET-10                           active
20   NET-20                           active    Fa0/3
30   NET-30                           active    Fa0/5
40   NET-40                           active    Fa0/1
101  VLAN0101                         active
102  VLAN0102                         active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1
Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------
------
1    enet  100001     1500  -      -      -        -    -        0
0
10   enet  100010     1500  -      -      -        -    -        0
0

CAT2(config-if)#do sh run int vlan 30
Building configuration...

Current configuration : 63 bytes
!
interface Vlan30
 ip address 172.16.34.11 255.255.255.0
end

CAT2(config-if)#do sh int trun

Port        Mode         Encapsulation  Status        Native vlan
Fa0/13      on           isl            trunking      1
Fa0/14      on           802.1q         trunking      1
Fa0/22      desirable    802.1q         trunking      1
Fa0/23      desirable    802.1q         trunking      1

Port      Vlans allowed on trunk
Fa0/13      10
Fa0/14      1,20,30,40
Fa0/22      1-4094
Fa0/23      1-4094

Port        Vlans allowed and active in management domain
Fa0/13      10
Fa0/14      1,20,30,40
Fa0/22      1,10,20,30,40,101-102
Fa0/23      1,10,20,30,40,101-102

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/13      10
Fa0/14      1
Fa0/22      1

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/23      1
CAT2(config-if)#do sh span vlan 30

VLAN0030
  Spanning tree enabled protocol ieee
  Root ID    Priority    32798
             Address     0011.20a9.9280
             Cost        19
             Port        14 (FastEthernet0/14)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32798  (priority 32768 sys-id-ext 30)
             Address     0011.5c63.0e00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- --------
--------------------------------
Fa0/5            Desg FWD 19        128.5    P2p
Fa0/14           Root FWD 19        128.14   P2p
Fa0/22           Desg FWD 19        128.22   P2p
Fa0/23           Desg FWD 19        128.23   P2p

CAT2(config-if)#do deb arp
ARP packet debugging is on
CAT2(config-if)#
00:28:09: IP ARP: rcvd req src 172.16.34.10 0011.20a9.9280, dst
172.16.34.11 Vla
n30
00:28:09: IP ARP: sent rep src 172.16.34.11 0011.5c63.0e00,
                 dst 172.16.34.10 0011.20a9.9280 Vlan30
CAT2(config-if)#
00:28:11: IP ARP: rcvd req src 172.16.34.10 0011.20a9.9280, dst
172.16.34.11 Vla
n30
00:28:11: IP ARP: sent rep src 172.16.34.11 0011.5c63.0e00,
                 dst 172.16.34.10 0011.20a9.9280 Vlan30
CAT2(config-if)#
00:28:13: IP ARP: rcvd req src 172.16.34.10 0011.20a9.9280, dst
172.16.34.11 Vla
n30
00:28:13: IP ARP: sent rep src 172.16.34.11 0011.5c63.0e00,
                 dst 172.16.34.10 0011.20a9.9280 Vlan30
CAT2(config-if)#
00:28:15: IP ARP: rcvd req src 172.16.34.10 0011.20a9.9280, dst
172.16.34.11 Vla
n30
00:28:15: IP ARP: sent rep src 172.16.34.11 0011.5c63.0e00,
                 dst 172.16.34.10 0011.20a9.9280 Vlan30
CAT2(config-if)#
00:28:17: IP ARP: rcvd req src 172.16.34.10 0011.20a9.9280, dst
172.16.34.11 Vla
n30
00:28:17: IP ARP: sent rep src 172.16.34.11 0011.5c63.0e00,
                 dst 172.16.34.10 0011.20a9.9280 Vlan30
CAT2(config-if)#

-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of
Michael Zuo
Sent: Saturday, January 27, 2007 5:12 PM
To: Muizebelt Danny; ccielab groupstudy; Sergey Golovanov
Subject: RE: ICMP showing encapsulation failed

I checked the following items and they all seemed OK:

1. all trunk interfaces are "trunking" under "show int trun"
2. vlan 30 is configured on both CAT1 and CAT2
3. all used interfaces are "FWD" under "show span vlan 30"
4. all interfaces are full duplex and 100 mbps under "show interface"

I turned on "deb arp" on devices and noticed that:
1. when R4 is pinging CAT1, CAT1 does not see any ARP request
2. when CAT1 is pinging R4, R4 sees the ARP requests and responds, but
CAT1 does not see the response comes back

This seems that communication from R4 to CAT1 is blocked somehow.  Any
suggestions?

I also put in a temporary vlan 30 interface on CAT2, R4 can ping CAT2,
R3 can be ping CAT1, but just not across the trunk link which seems to
be cause. But I don't know why this is happening...

Thanks in advance ....


-----Original Message-----
From: Muizebelt Danny [mailto:Danny.Muizebelt@xxxxxxxxxx] 
Sent: Thursday, January 25, 2007 1:12 AM
To: Michael Zuo; ccielab groupstudy
Subject: RE: ICMP showing encapsulation failed

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

I think you didn't get an arp resolution for the 172.16.34.4 address,
that's why the encapsulation failed because there is no L3 to L2
mapping.

The reason why there is no arp resolution could be a problem with your
trunk, is it up? Is vlan 30 defined on both switches? Is the spanning
tree working properly?

Another thing I wanted to point out, if you statically configure duplex
settings on one side and leave the other side on auto then the auto side
will fall back to default half-duplex. Statically configuring duplex
settings switches off the auto negotiation. So either both sides on auto
or both statically configured.

 
Danny Muizebelt
CCIE #17353

- -----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of
Michael Zuo
Sent: Donnerstag, 25. Jdnner 2007 08:22
To: ccielab groupstudy
Subject: ICMP showing encapsulation failed

Hi group,



I am scratching my head on this one (probably something basic), please
help! And thanks in advance....





R3(f0/1)---------(f0/4)CAT1(f0/14)-----------(f0/14)CAT2(f0/5)----------
- -----R4(f0/0)



When I ping from R3 to R4, I get encapsulation failed message on R3:



R3(config-if)#do ping 172.16.34.4



Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.34.4, timeout is 2 seconds:



2d07h: IP: tableid=0, s=172.16.34.3 (local), d=172.16.34.4
(FastEthernet0/1), ro

uted via RIB

2d07h: IP: s=172.16.34.3 (local), d=172.16.34.4 (FastEthernet0/1), len
100, send

ing

2d07h: IP: s=172.16.34.3 (local), d=172.16.34.4 (FastEthernet0/1), len
100, enca

psulation failed.

2d07h: IP: tableid=0, s=172.16.34.3 (local), d=172.16.34.4
(FastEthernet0/1), ro

uted via RIB

2d07h: IP: s=172.16.34.3 (local), d=172.16.34.4 (FastEthernet0/1), len
100, send

Ing







Configuration:



R3:

=======

R3(config-router)#do sh run int f0/1

Building configuration...



Current configuration : 96 bytes

!

interface FastEthernet0/1

 ip address 172.16.34.3 255.255.255.0

 duplex auto

 speed auto

end



R3(config-router)#





CAT1:

========

CAT1(config)#do sh run int f0/4

Building configuration...



Current configuration : 97 bytes

!

interface FastEthernet0/4

 switchport access vlan 30

 switchport mode access

 duplex full

end



CAT1(config)#do sh run int f0/14

Building configuration...



Current configuration : 137 bytes

!

interface FastEthernet0/14

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 1,20,30,40

 switchport mode trunk



CAT1(config-if)#do sh run int vlan 30

Building configuration...



Current configuration : 63 bytes

!

interface Vlan30

 ip address 172.16.34.10 255.255.255.0

end





CAT2:

CAT2(config-if)#do sh run int f0/5

Building configuration...



Current configuration : 97 bytes

!

interface FastEthernet0/5

 switchport access vlan 30

 switchport mode access

 duplex full

end



CAT2(config-if)#do sh run int f0/14

Building configuration...



Current configuration : 137 bytes

!

interface FastEthernet0/14

 switchport trunk encapsulation dot1q

 switchport trunk allowed vlan 1,20,30,40

 switchport mode trunk

end



CAT2(config-if)#





R4

 =======

R4(config-router)#do sh run int f0/0

Building configuration...



Current configuration : 96 bytes

!

interface FastEthernet0/0

 ip address 172.16.34.4 255.255.255.0

 duplex auto

 speed auto

end



R4(config-router)#

_______________________________________________________________________
Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html

-----BEGIN PGP SIGNATURE-----
Version: 9.5.2 (Build 4075)

wsFVAwUBRbh0SwKu4mx4z4krAQgsjQ//ccVIiyhPdkRYp3No3KfGz3QS+zbBhh5C
FOl9OHs7r8nAXWuP6c1PKYs8VSOmWO4LefbzK1GbWd+lm+DSw85InKiOsNr4Huyk
gpQnTppWOqT/w7NT2dxqcvz5GWBoCe8h1Qqf9zszgbCdl31zEVjMDM6LdgXH5pHU
72UURTFoyXF9ILAkT2n/Qi27mLgxXu5Rpj7361yzQtZ6CG+9EtX8+AWz9xWHiOhw
/Dmps2BQNAK6MeVKaO1y9UpuhU7ZV/m66GdWuphQGkuLhIbGZpNSQB6BEe6SAlPr
yFOBeiQjv/5HSe8h8Emwofz9HtTukSKDH/JTNAszYUQUc5WNLt480a6XHWB8ZDrb
gkAuyZa9GCs3ZCXEYuCz9gFnL4UVYdlfNjQgKnxNmczi5pBN5+vxs9r2AZM7Su4M
xF+M8jYlaD8JarUKQuv1vT1+ZYPc6vnTRpmco7cANL/ud4SCc5qDUl2uAFToAmd0
SnaqPQp8/oRYWN5mW+KF1KE22x+R1wShscTeggbAuBzg0aVkgpzLo9TWfxm2ABAY
eLwf+mRsvoJDG7zQACTuFdKeWJfWO9oEpZrkL5++tA8AyyyoQ1ybJo1ITxKFJpuM
JaG1vfgLJrFVIct85GmX3DgWbKpWeGpdxzACjeaEBa6MHwsvwRwxvlnajM43AGhQ
gKskHicJcE8=
=lijY
-----END PGP SIGNATURE-----


------------------------------------------------------------------------
------------------------------------------------------------------------
-----
Diese Information ist vertraulich und ausschlie_lich zur Kenntnisnahme
durch den (die) genannten Adressaten bestimmt.
Wenn Sie nicht der vorgesehene Adressat sind, informieren Sie uns bitte
unverz|glich.
The information herein is confidential and intended solely for the
attention and use of the named addressee(s).
If you are not the intended recipient please inform us immediately.
------------------------------------------------------------------------
------------------------------------------------------------------------
-----

_______________________________________________________________________
Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html

_______________________________________________________________________
Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html

_______________________________________________________________________
Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html