GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: ICMP showing encapsulation failed posted 01/25/2007
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


your arp is failing, which probably means your traffic is not getting from R3 to R4 or from R4 to R3.

Run "debug arp" on R3 and R4. Ping from either end. Which device is not getting ARP messages?


--------------------------------------------------------------------
Sergey Golovanov, CCIEx5 (R&S/Security/Voice/Service Provider/Storage)
"Please, don't ask me for my ccie #, there are reasons why I can't release it"
ieMentor Instructor and Content Developer
sergey.golovanov@xxxxxxxxxxxx
http://www.iementor.com


>  -------Original Message-------
>  From: Michael Zuo <mzuo@xxxxxxxxxxx>
>  Subject: ICMP showing encapsulation failed
>  Sent: Jan 25 '07 02:22
>  
>  Hi group,
>  
>  
>  
>  I am scratching my head on this one (probably something basic), please
>  help! And thanks in advance....
>  
>  
>  
>  
>  
>  R3(f0/1)---------(f0/4)CAT1(f0/14)-----------(f0/14)CAT2(f0/5)----------
>  -----R4(f0/0)
>  
>  
>  
>  When I ping from R3 to R4, I get encapsulation failed message on R3:
>  
>  
>  
>  R3(config-if)#do ping 172.16.34.4
>  
>  
>  
>  Type escape sequence to abort.
>  
>  Sending 5, 100-byte ICMP Echos to 172.16.34.4, timeout is 2 seconds:
>  
>  
>  
>  2d07h: IP: tableid=0, s=172.16.34.3 (local), d=172.16.34.4
>  (FastEthernet0/1), ro
>  
>  uted via RIB
>  
>  2d07h: IP: s=172.16.34.3 (local), d=172.16.34.4 (FastEthernet0/1), len
>  100, send
>  
>  ing
>  
>  2d07h: IP: s=172.16.34.3 (local), d=172.16.34.4 (FastEthernet0/1), len
>  100, enca
>  
>  psulation failed.
>  
>  2d07h: IP: tableid=0, s=172.16.34.3 (local), d=172.16.34.4
>  (FastEthernet0/1), ro
>  
>  uted via RIB
>  
>  2d07h: IP: s=172.16.34.3 (local), d=172.16.34.4 (FastEthernet0/1), len
>  100, send
>  
>  Ing
>  
>  
>  
>  
>  
>  
>  
>  Configuration:
>  
>  
>  
>  R3:
>  
>  =======
>  
>  R3(config-router)#do sh run int f0/1
>  
>  Building configuration...
>  
>  
>  
>  Current configuration : 96 bytes
>  
>  !
>  
>  interface FastEthernet0/1
>  
>  ip address 172.16.34.3 255.255.255.0
>  
>  duplex auto
>  
>  speed auto
>  
>  end
>  
>  
>  
>  R3(config-router)#
>  
>  
>  
>  
>  
>  CAT1:
>  
>  ========
>  
>  CAT1(config)#do sh run int f0/4
>  
>  Building configuration...
>  
>  
>  
>  Current configuration : 97 bytes
>  
>  !
>  
>  interface FastEthernet0/4
>  
>  switchport access vlan 30
>  
>  switchport mode access
>  
>  duplex full
>  
>  end
>  
>  
>  
>  CAT1(config)#do sh run int f0/14
>  
>  Building configuration...
>  
>  
>  
>  Current configuration : 137 bytes
>  
>  !
>  
>  interface FastEthernet0/14
>  
>  switchport trunk encapsulation dot1q
>  
>  switchport trunk allowed vlan 1,20,30,40
>  
>  switchport mode trunk
>  
>  
>  
>  CAT1(config-if)#do sh run int vlan 30
>  
>  Building configuration...
>  
>  
>  
>  Current configuration : 63 bytes
>  
>  !
>  
>  interface Vlan30
>  
>  ip address 172.16.34.10 255.255.255.0
>  
>  end
>  
>  
>  
>  
>  
>  CAT2:
>  
>  CAT2(config-if)#do sh run int f0/5
>  
>  Building configuration...
>  
>  
>  
>  Current configuration : 97 bytes
>  
>  !
>  
>  interface FastEthernet0/5
>  
>  switchport access vlan 30
>  
>  switchport mode access
>  
>  duplex full
>  
>  end
>  
>  
>  
>  CAT2(config-if)#do sh run int f0/14
>  
>  Building configuration...
>  
>  
>  
>  Current configuration : 137 bytes
>  
>  !
>  
>  interface FastEthernet0/14
>  
>  switchport trunk encapsulation dot1q
>  
>  switchport trunk allowed vlan 1,20,30,40
>  
>  switchport mode trunk
>  
>  end
>  
>  
>  
>  CAT2(config-if)#
>  
>  
>  
>  
>  
>  R4
>  
>  =======
>  
>  R4(config-router)#do sh run int f0/0
>  
>  Building configuration...
>  
>  
>  
>  Current configuration : 96 bytes
>  
>  !
>  
>  interface FastEthernet0/0
>  
>  ip address 172.16.34.4 255.255.255.0
>  
>  duplex auto
>  
>  speed auto
>  
>  end
>  
>  
>  
>  R4(config-router)#
>  
>  _______________________________________________________________________
>  Subscription information may be found at:
>  http://www.groupstudy.com/list/CCIELab.html