GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: IOS DHCP issue posted 01/15/2007
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Here is a link that explains the DHCP process very clearly.

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080
0f0804.shtml#dhcppacket

The subnet mask is is carried in the DHCP packet from the server to the
client.



Tony Schaffran

Network Analyst

CCIE #11071

CCNP, CCNA, CCDA,

NNCDS, NNCSS, CNE, MCSE



www.cconlinelabs.com <http://www.cconlinelabs.com/>

Your #1 choice for online Cisco rack rentals.



-----Original Message-----
From: Jian Gu [mailto:guxiaojian@xxxxxxxxx]
Sent: Monday, January 15, 2007 2:04 PM
To: Tony Schaffran
Cc: Jim; ccie anees; ccielab@xxxxxxxxxxxxxx
Subject: Re: IOS DHCP issue


If you study DHCP packets carefully, you will notice that network mask is
not carried in any DHCP packets.


On 1/15/07, Tony Schaffran <  <mailto:groupstudy@xxxxxxxxxxxxxxxx>
groupstudy@xxxxxxxxxxxxxxxx> wrote:

There is still a problem with your dhcp pool not matching the subnet of
vlan3.

Tony Schaffran
Network Analyst
CCIE #11071
CCNP, CCNA, CCDA,
NNCDS, NNCSS, CNE, MCSE

www.cconlinelabs.com
Your #1 choice for online Cisco rack rentals.



-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of Jim
Sent: Monday, January 15, 2007 11:21 AM
To: ccie anees
Cc: ccielab@xxxxxxxxxxxxxx
Subject: Re: IOS DHCP issue


I tested the config through lab,  it seems to work.   Just like others
pointed to, there was issue before router rip betweening R1 and sw1,
because, R1 was sending unicast dhcp-offers to 129.1.3.7, but it didn't have
that route.  So it had no-where to send.  After turning on rip, it starts
working.    Here is the configuration and the debug output.


R1
####
interface FastEthernet0/0
ip address 129.1.17.1 255.255.255.0
!
no ip dhcp conflict logging
ip dhcp excluded-address 129.1.3.1 129.1.3.2
ip dhcp excluded-address 129.1.3.4 129.1.3.254
!
ip dhcp pool R3_Pool
  network 129.1.3.0 255.255.255.0
  default-router 129.1.3.7
!
router rip
no auto-summ
version 2
network 129.1.0.0

SW1
######
interface Vlan17
ip address 129.1.17.7 255.255.255.0
interface Vlan3
ip address 129.1.3.7 255.255.255.128
ip helper-address 129.1.17.1
router rip
no auto-summ
version 2
network 129.1.0.0

R3
###
interface FastEthernet3/0
ip address dhcp


Rack2R3(config)#int fa 0/0
Rack2R3(config-if)#ip add dhcp
Rack2R3(config-if)#
*Nov 30 16:41:52.994: %DHCP-6-ADDRESS_ASSIGN: Interface FastEthernet0/0
assigned DHCP address 129.1.3.3, mask 255.255.255.0, hostname Rack2R3


Rack2SW1(config-if)#
2d21h: DHCPD: setting giaddr to 129.1.3.7.
2d21h: DHCPD: BOOTREQUEST from
0063.6973.636f.2d30.3030.392e.3763.3735.2e35.3138.312d.4661.302f.30forwarded
to
129.1.17.1.
2d21h: DHCPD: forwarding BOOTREPLY to client 0009.7c75.5181.
2d21h: DHCPD: broadcasting BOOTREPLY to client 0009.7c75.5181.
2d21h: DHCPD: setting giaddr to 129.1.3.7.
2d21h: DHCPD: BOOTREQUEST from
0063.6973.636f.2d30.3030.392e.3763.3735.2e35.3138.312d.4661.302f.30forwarded

to
129.1.17.1.
2d21h: DHCPD: forwarding BOOTREPLY to client 0009.7c75.5181.
2d21h: DHCPD: broadcasting BOOTREPLY to client 0009.7c75.5181.

Rack2R1#
*Mar  3 21:52:27.594 : DHCPD: DHCPDISCOVER received from client
0063.6973.636f.2d30.3030.392e.3763.3735.2e35.3138.312d.4661.302f.30 through
relay 129.1.3.7.
*Mar  3 21:52:29.594: DHCPD: Sending DHCPOFFER to client
0063.6973.636f.2d30.3030.392e.3763.3735.2e35.3138.312d.4661.302f.30 (
129.1.3.3).
*Mar  3 21:52:29.594: DHCPD: unicasting BOOTREPLY for client
0009.7c75.5181to relay
129.1.3.7.
*Mar  3 21:52:29.602: DHCPD: DHCPREQUEST received from client
0063.6973.636f.2d30.3030.392e.3763.3735.2e35.3138.312d.4661.302f.30.
*Mar  3 21:52:29.602: DHCPD: Sending DHCPACK to client
0063.6973.636f.2d30.3030.392e.3763.3735.2e35.3138.312d.4661.302f.30 (
129.1.3.3).
*Mar  3 21:52:29.602: DHCPD: unicasting BOOTREPLY for client
0009.7c75.5181to relay
129.1.3.7.

_______________________________________________________________________
Subscription information may be found at:
http://www.groupstudy.com/list/CCIELab.html

_______________________________________________________________________
Subscription information may be found at:
http://www.groupstudy.com/list/CCIELab.html