GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: ospf wildcard bits posted 01/05/2007
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Hello Frank,



What I noticed is that it wouldn't work like that for Ethernet
interfaces, but serial interfaces can belong to same subnet. Reason I
would say because Ethernet Interfaces were designed to belong to a
single subnet (that's what Ethernet is all about anyway - single
broadcast domain); But Serial interfaces have the capability to belong
to same and different subnets.



Any contrary opinion will be highly regarded



Try your configuration using serial interfaces and let me know how you
get on... Below is what I lab'ed up on my router



************************************************************************
****

Rack1R1#sh ip int b

Interface                  IP-Address      OK? Method Status
Protocol

FastEthernet0/0            unassigned      YES unset  administratively
down down

Serial1/0                  unassigned      YES unset  administratively
down down

Serial1/1                  unassigned      YES unset  administratively
down down

Serial1/2                  unassigned      YES unset  administratively
down down

Serial1/3                  unassigned      YES unset  administratively
down down

FastEthernet2/0            unassigned      YES unset  administratively
down down

Rack1R1#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Rack1R1(config)#int fa0/0

Rack1R1(config-if)#ip address 192.168.2.1 255.255.255.0

Rack1R1(config-if)#no shut

Rack1R1(config-if)#exit

Rack1R1(config)#int f

*Mar  1 00:07:21.307: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed
state to up

*Mar  1 00:07:22.307: %LINEPROTO-5-UPDOWN: Line protocol on Interface
FastEthernet0/0, changed state to up

Rack1R1(config)#int fa2/0

Rack1R1(config-if)#ip address 192.168.2.2 255.255.255.0

% 192.168.2.0 overlaps with FastEthernet0/0

Rack1R1(config-if)#exit

Rack1R1(config)#int s1/0

Rack1R1(config-if)#ip address 192.168.3.1 255.255.255.0

Rack1R1(config-if)#no shut

Rack1R1(config-if)#exit

Rack1R1(config)#exit

*Mar  1 00:08:06.887: %LINK-3-UPDOWN: Interface Serial1/0, changed state
to up

Rack1R1(config)#int s1/1

Rack1R1(config-if)#

*Mar  1 00:08:09.903: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial1/0, changed state to up

Rack1R1(config-if)#ip address 192.168.3.2 255.255.255.0

Rack1R1(config-if)#exit

Rack1R1(config)#exit

Rack1R1#sh ip int b

Interface                  IP-Address      OK? Method Status
Protocol

FastEthernet0/0            192.168.2.1     YES manual up
up

Serial1/0                  192.168.3.1     YES manual up
up

Serial1/1                  192.168.3.2     YES manual administratively
down down

Serial1/2                  unassigned      YES unset  administratively
down down

Serial1/3                  unassigned      YES unset  administratively
down down

FastEthernet2/0            192.168.2.2     YES manual administratively
down down

Rack1R1#

************************************************************************
****



Many Thanks

_________________________________________________

Olayemi Salau

Network Analyst

I.T. Solutions Division

Southampton City Council

( 023 8083 4070   7  077 8811 2036 3 079 5825 7509

* olayemi.salau@xxxxxxxxxxxxxxxxxx

_________________________________________________

This e-mail is intended for the addressee only. If you are not the
intended recipient, please be aware that the unauthorised use or
disclosure of the information it contains, or the unauthorised copying
or re-transmission of the e-mail are strictly prohibited. Such action
may result in legal proceedings. If the e-mail has been sent to you in
error, please accept our apologies, advise the sender as soon as
possible and then delete the message. Under the Freedom of Information
Act 2000 / Data Protection Act 1998, the contents of this e-mail,
whether it is marked confidential or otherwise, may be disclosed. No
employee, Councillor or agent is authorised to conclude by e-mail any
binding agreement with another party on behalf of Southampton City
Council. The Council does not accept service by e-mail of court
proceedings, other processes or formal notices of any kind without
specific prior written agreement. E-mails to and from Southampton City
Council may be monitored in accordance with the law



-----Original Message-----
From: Frank [mailto:ocsic@xxxxxx]
Sent: 05 January 2007 11:09
To: Salau,Olayemi
Subject: Re: ospf wildcard bits



Salau,Olayemi schrieb:





Hi,



i don't know how you do that. Well that looks different for me :-):



Rack1R3#i

Interface IP-Address OK? Method Status Protocol

Ethernet0/0 162.1.38.3 YES manual up up

Ethernet0/1 unassigned YES unset administratively down down

Serial1/0 162.1.0.3 YES manual up up

Serial1/1 162.1.13.3 YES manual up up

Serial1/2 unassigned YES unset administratively down down

Serial1/3 unassigned YES unset administratively down down

Loopback0 150.1.3.3 YES manual up up

Rack1R3#c

Enter configuration commands, one per line. End with CNTL/Z.

Rack1R3(config)#int e0/1

Rack1R3(config-if)#ip addRack1R3#i

Interface IP-Address OK? Method Status Protocol

Ethernet0/0 162.1.38.3 YES manual up up

Ethernet0/1 unassigned YES unset administratively down down

Serial1/0 162.1.0.3 YES manual up up

Serial1/1 162.1.13.3 YES manual up up

Serial1/2 unassigned YES unset administratively down down

Serial1/3 unassigned YES unset administratively down down

Loopback0 150.1.3.3 YES manual up up

Rack1R3#c

Enter configuration commands, one per line. End with CNTL/Z.

Rack1R3(config)#int e0/1

Rack1R3(config-if)#ip address 162.1.38.2 255.255.255.0

% 162.1.38.0 overlaps with Ethernet0/0

Rack1R3(config-if)#





Frank







> Hello Frank

>

> Do you mean I can't configure 2 interfaces to belong to same subnet?

> Check this out... I configured s1/0 for 192.168.17.1 and S1/1 for

> 192.168.17.2; same subnet 192.168.17.0

>

> Rack1R2#conf t

>

> Enter configuration commands, one per line. End with CNTL/Z.

>

> Rack1R2(config)#int s1/0

>

> Rack1R2(config-if)#*ip address 192.168.17.1 255.255.255.0*

>

> Rack1R2(config-if)#int s1/1

>

> Rack1R2(config-if)#*ip address 192.168.17.2 255.255.255.0*

>

> Rack1R2(config-if)#exit

>

> Rack1R2(config)#end

>

> Rack1R2#sh

>

> *Mar 1 20:12:00.114: %SYS-5-CONFIG_I: Configured from console by
console

>

> Rack1R2#sh ip int b

>

> Interface IP-Address OK? Method Status Protocol

>

> FastEthernet0/0 150.1.29.1 YES NVRAM up up

>

> Serial1/0 192.168.17.1 YES manual up up

>

> Serial1/1 192.168.17.2 YES manual administratively down down

>

> Serial1/2 unassigned YES TFTP administratively down down

>

> Serial1/3 unassigned YES TFTP administratively down down

>

> Loopback0 29.29.2.2 YES NVRAM up up

>

> Loopback1 150.4.29.1 YES NVRAM up up

>

> Rack1R2#

>

> Yea, you're right about using wildcard mask, but is there any reason

> why you wouldn't use the 32bit wildcard?(ie. 0.0.0.0) for ospf network


> command?

>

> Many Thanks

>

> _________________________________________________

>

> Olayemi Salau

>

> Network Analyst

>

> I.T. Solutions Division

>

> Southampton City Council

>

> ( 023 8083 4070 7 077 8811 2036 3 079 5825 7509

>

> * olayemi.salau@xxxxxxxxxxxxxxxxxx

>

> _________________________________________________

>

> This e-mail is intended for the addressee only. If you are not the

> intended recipient, please be aware that the unauthorised use or

> disclosure of the information it contains, or the unauthorised copying


> or re-transmission of the e-mail are strictly prohibited. Such action

> may result in legal proceedings. If the e-mail has been sent to you in


> error, please accept our apologies, advise the sender as soon as

> possible and then delete the message. Under the Freedom of Information


> Act 2000 / Data Protection Act 1998, the contents of this e-mail,

> whether it is marked confidential or otherwise, may be disclosed. No

> employee, Councillor or agent is authorised to conclude by e-mail any

> binding agreement with another party on behalf of Southampton City

> Council. The Council does not accept service by e-mail of court

> proceedings, other processes or formal notices of any kind without

> specific prior written agreement. E-mails to and from Southampton City


> Council may be monitored in accordance with the law

>

> -----Original Message-----

> From: Frank [mailto:ocsic@xxxxxx]

> Sent: 05 January 2007 07:04

> To: Salau,Olayemi

> Subject: Re: ospf wildcard bits

>

> Salau,Olayemi schrieb:

>

> Hi,

>

> thanks four your answer.

>

> I knew this, that you just enable ospf on an interface. But it's not

>

> possible to have more than one address out of

>

> one subnet on an interface. So this does not matter as you say. When
you

>

> want to enable ospf for multiple

>

> interfaces you can create a wilcardmask, that matches more than one

>

> interface, but it't not possible to match

>

> more than one address out of the same network.

>

> Frank

>

> >

>

> > I would use

>

> >

>

> > router ospf 1

>

> >

>

> > netwo 150.1.1.1 0.0.0.0

>

> >

>

> > Remember under OSPF, network command enables routing process on

>

> > specified "interface", and not network.

>

> >

>

> > If you use 150.1.1.1 0.0.0.255, you're literally saying enable ospf
on

>

> > all interfaces within the 150.1.1.0 network. What if there is
another

>

> > interface 150.1.1.3 on this router in which you're not required to
run

>

> > OSPF on?

>

> >

>

> > So I would say use network 150.1.1.1 0.0.0.0 area X in other to
match

>

> > interface exactly.

>

> >

>

> > Many Thanks

>

> >

>

> > _________________________________________________

>

> >

>

> > Olayemi Salau

>

> >

>

> > Network Analyst

>

> >

>

> > I.T. Solutions Division

>

> >

>

> > Southampton City Council

>

> >

>

> > ( 023 8083 4070 7 077 8811 2036 3 079 5825 7509

>

> >

>

> > * olayemi.salau@xxxxxxxxxxxxxxxxxx

>

> >

>

> > _________________________________________________

>

> >

>

> > This e-mail is intended for the addressee only. If you are not the

>

> > intended recipient, please be aware that the unauthorised use or

>

> > disclosure of the information it contains, or the unauthorised
copying

>

> > or re-transmission of the e-mail are strictly prohibited. Such
action

>

> > may result in legal proceedings. If the e-mail has been sent to you
in

>

> > error, please accept our apologies, advise the sender as soon as

>

> > possible and then delete the message. Under the Freedom of
Information

>

> > Act 2000 / Data Protection Act 1998, the contents of this e-mail,

>

> > whether it is marked confidential or otherwise, may be disclosed. No

>

> > employee, Councillor or agent is authorised to conclude by e-mail
any

>

> > binding agreement with another party on behalf of Southampton City

>

> > Council. The Council does not accept service by e-mail of court

>

> > proceedings, other processes or formal notices of any kind without

>

> > specific prior written agreement. E-mails to and from Southampton
City

>

> > Council may be monitored in accordance with the law

>

> >

>

> > -----Original Message-----

>

> > From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf

>

> > Of Frank

>

> > Sent: 04 January 2007 12:53

>

> > To: ccielab@xxxxxxxxxxxxxx

>

> > Subject: ospf wildcard bits

>

> >

>

> > Hi,

>

> >

>

> > what does it mean if i have configure ospf network statements to
"match

>

> >

>

> > the interface exaclty"?

>

> >

>

> > interface s0/0

>

> >

>

> > ip add 150.1.1.1 255.255.255.0

>

> >

>

> > router ospf 1

>

> >

>

> > netwo 150.1.1.1 0.0.0.0

>

> >

>

> > or

>

> >

>

> > router ospf 1

>

> >

>

> > netwo 150.1.1.1 0.0.0.255

>

> >

>

> > The first configuration does match the ip address exactly and the
second

>

> >

>

> > does match the netmask directly.

>

> >

>

> > What should you choose. I know both are valid, but what would be the

>

> >

>

> > right one regarding to "exaclty

>

> >

>

> > match the interface"?

>

> >

>

> > Frank

>

> >

>

> >
_______________________________________________________________________

>

> >

>

> > Subscription information may be found at:

>

> >

>

> > http://www.groupstudy.com/list/CCIELab.html