GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: Re[2]: BGP local-as posted 12/10/2006
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


I did test these too, it did not work for me as well.
Somehow the far end's mis-configured AS number is not in any of the messages
I am receiving.
I can not catch what is the AS number he is expecting from me. I assume my
BGP process is happy because my config and the far end AS number is correct.
The far end BGP is not happy, and it know the local config and what is
receiving from me, and compares the data, and outputs the expected keyword.
But from my end, I can not see the expected info from me.

Thanks for the emails.


-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx]On Behalf Of
cadet
Sent: Sunday, December 10, 2006 10:40 AM
To: Nick Griffin
Cc: Ivan; ccielab@xxxxxxxxxxxxxx; CharlesB
Subject: Re[2]: BGP local-as


Hello !
it is not work in my test :(

for example:

r1(AS 111) ----- r2(AS 115)


R1 --- initiate bgp session
router bgp 111
 neighbor 11.11.2.2 remote-as 215 -- try establish session with AS 215
 neighbor 11.11.2.2 ebgp-multihop 255
 neighbor 11.11.2.2 update-source Loopback0

R2
router bgp 115
 neighbor 11.11.1.1 remote-as 111
 neighbor 11.11.1.1 transport connection-mode passive
 neighbor 11.11.1.1 ebgp-multihop 255
 neighbor 11.11.1.1 update-source Loopback0


So I SEE on R2 next log:
*Nov  9 00:38:28.228: tcp0: I ESTAB 11.11.1.1:34382 11.11.2.2:179 seq
2022724993
        DATA 45 ACK 4131500569 PSH  WIN 16384
*Nov  9 00:38:28.240: tcp0: O ESTAB 11.11.1.1:34382 11.11.2.2:179 seq
4131500569
        DATA 64 ACK 2022725038 PSH  WIN 16339
*Nov  9 00:38:28.248: tcp0: I ESTAB 11.11.1.1:34382 11.11.2.2:179 seq
2022725038
        DATA 23 ACK 4131500633 PSH  WIN 16320
*Nov  9 00:38:28.248: %BGP-3-NOTIFICATION: received from neighbor 11.11.1.1
2/2 (peer in wrong AS) 2 bytes 0073

 0073 =  115

 BUT I need see  D7 === 215

 Do you have any ideas ?


Hello Nick,

Sunday, December 10, 2006, 6:08:11 PM, you wrote:

> Perhaps an easier way to force the opposite peer to become the tcp server
in
> regards to the bgp, less margin for error this way:


> router bgp 300
> !
>  no synchronization
>  bgp log-neighbor-changes
>  neighbor 192.168.12.2 remote-as 200
>  neighbor 192.168.12.2 transport connection-mode passive <---------
>  no auto-summary

> This can also be done in a peer session template versus per neighbor.


> On 12/10/06, Ivan <ivan@xxxxxxx> wrote:
>>
>> You must force the remote peer to initiate BGP-session. Then in error
>> message
>> you see AS-number wich expect from you.
>> To achieve this try to apply outbound access-list to interface directed
to
>> remote peer
>>
>> access-list 150 deny ip host BGP_IP_ORIGIN host BGP_IP_PEER eq bgp
>> access-list 150 permit ip any any
>>
>> On Sunday 10 December 2006 11:53, CharlesB wrote:
>> > I am doing a task in IE labs.
>> >
>> > The task says, far end router admin mis-configured BGP AS number, and
>> they
>> > can not correct it now. Find a solution to peer with their router.
>> > And they indicate the far end configured AS, so we can put the local-as
>> XX
>> > to match with their config.
>> > Now, what if, we do not know what they put there.
>> > I keep using debug ip bgp on my end, but I can not see the info. I put
>> on
>> > my router wrong target AS number, wrong local-as etc. The result is
that
>> it
>> > is hard to figure out what AS they are expecting from me.
>> > If I go to far end and do the same debug I can see what was expected AS
>> > from me in that router, but this does not help the case I am trying to
>> > figure out.
>> > Am I missing something here?
>> > May be there is no solution to this? We must know their mistake, is
that
>> > correct?
>> > Any thoughts?
>> >
>> > _______________________________________________________________________
>> > Subscription information may be found at:
>> > http://www.groupstudy.com/list/CCIELab.html
>>
>> --
>> Ivan
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html

> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html


--
Best regards,
 cadet                            mailto:cadet22@xxxxxxxxx

_______________________________________________________________________
Subscription information may be found at:
http://www.groupstudy.com/list/CCIELab.html