GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: Mock lab 1 : TASK 1.3 (Router on a stick) posted 09/02/2006
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


   This is really a brilliant idea :)
 
   
  I tried it,  and it is working with vlan dot1q tag native command disabled 
   
   
  

sabrina pittarel <sabri_esame@xxxxxxxxx> wrote: Hi Ismail,
 thanks. Then it looks like your router wasn't able to assign not tagged traffic to the sub interface even if you had the "native" keyword in the encapsulation command. Sounds like a bug.
 But,
 you still have a way to configure your network to meet the requirement that native vlan traffic should be sent untagged. You could have configured R6 etherner interface:
 
 interface Ethernet0/0
    ip address 204.12.1.6 255.255.255.0
 
 No need for subinterface.
 
 Sabrina
     

----- Original Message ----
From: ismail el-shalh 
To: ccielab 
Sent: Saturday, September 2, 2006 12:26:07 PM
Subject: Re: Mock lab 1 : TASK 1.3 (Router on a stick)

Hi sabrina, Hi every one

Here is the correct configuration :
  (C3620-IS-M), Version 12.2(37)
     Rack1R6#show run int eth0/0.263
     
interface Ethernet0/0.263
   encapsulation dot1Q 263 native
   ip address 204.12.1.6 255.255.255.0
      end

 
  SW1
  Version 12.2(25)SEE2
   
  Rack1SW1#show vlan dot1q tag native 
  dot1q native vlan tagging is disabled
   
    interface FastEthernet0/6
   switchport trunk encapsulation dot1q
   switchport trunk native vlan 263
   switchport trunk allowed vlan 6,263
   switchport mode trunk
  end
   
  interface FastEthernet0/24
   description CONNECTED TO BB3
   switchport access vlan 263
       switchport mode access
 
  Rack1R6#ping 204.12.1.254 repeat 1  
   
  Type escape sequence to abort.
  Sending 1, 100-byte ICMP Echos to 204.12.1.254, timeout is 2 seconds:
  

  IP ARP: sent req src 204.12.1.6 0010.7b96.c921,
                   dst 204.12.1.254 0000.0000.0000 Ethernet0/0.263
  IP ARP rep filtered src 204.12.1.254 0000.0c09.f442, dst 204.12.1.6 0010.7b96.c921 wrong cable, interface Ethernet0/0.
  Success rate is 0 percent (0/1)
   
  Now this configuration should work if you have the correct  IOS/Router, as a remedy to my situation I had to enable vlan tagging globally on SW1 and this means that even the native vlan will be tagged.
   
  What I am expecting that R6 is still tagging the frames out of the Ethernet even though the native vlan keyword is configured under its Ethernet interface
   
  I may make sense because why  R6 start sending the frames normally after I enable vlan dot1q tag native command globally on SW1? , By enabling this command I am telling SW1 to tag all the frames including the vlans which is configured to be native.
    So when SW1 tag vlan 263 , it goes  to R6 tagged and R6 Identify this frame because R6 is expecting this frame to reach  tagged.
    After enabling tagging globally on SW1
 
  Rack1SW1#show vlan dot1q tag native 
  dot1q native vlan tagging is enabled
   
   
  Rack1R6#ping 204.12.1.254 repeat 1
   
  Type escape sequence to abort.
  Sending 1, 100-byte ICMP Echos to 204.12.1.254, timeout is 2 seconds:
  !
  Success rate is 100 percent (1/1), round-trip min/avg/max = 4/4/4 ms
  Rack1R6#
  IP ARP: rcvd req src 204.12.1.254 0000.0c09.f442, dst 204.12.1.54 Ethernet0/0.263
   
   
    
   
  Ismail El-Shalh
   
  

sabrina pittarel  wrote: Hi Ismail,
 for the benefit of other people reading your posts, can you confirm that the problem you were seeing during the Mock lab was caused by a missing "native" keyword under the "encapsulation" command on the ethernet subinterface of R6?
 Can you post the correct config?
 
 Sabrina

----- Original Message ----
From: ismail el-shalh 
To: ccielab 
Sent: Saturday, September 2, 2006 4:43:35 AM
Subject: Re: Mock lab 1 : TASK 1.3 (Router on a stick)

 I troubleshoot this yesterday for more than three hours I was trying to let  R6 communicate with BB3 while native vlan option is configured under the interfaces (SW1 and R6) without enabling the vlan dot1q tag native globally but it was not working.
 
 After all, I changed the router itself with more modern one (2600XM) and once I try it , it start working  without any problem , 
 
 In my lab R6 is 3620 with two Ethernet ports and is loaded with the IOS 12.2(37) , here is the error message I am getting out of it
  


IP ARP: sent req src 204.12.1.6 0010.7b96.c921,
                 dst 204.12.1.254 0000.0000.0000 Ethernet0/0.263
IP ARP rep filtered src 204.12.1.254 0000.0c09.f442, dst 204.12.1.6 0010.7b96.c921 wrong cable, interface Ethernet0/0.
IP ARP throttled out the ARP Request for 204.12.1.254.


Thanks to you all

Vazman  wrote: You can also use dot1q and tag the native vlan traffic using the command.
  
 Switch(config)#vlan dot1q tag native
  
 Of course, ISL seems to be the simpler solution.
  
 HTH

 
 On 9/2/06, srdja blagojevic  wrote: Ismail,

my interpretation of your task is:

"All traffic sent over this trunk should be tagged with a VLAN header" => 
use ISL encapsulation
"Do not use Dynamic Trunking protocol over this link" => switchport
nonegotiate

interface fa0/13
switchport trunk encapsulation isl
switchport mode trunk
switchport nonegotiate 

HTH,
Srdja

-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of
ismail el-shalh 
Sent: Saturday, September 02, 2006 01:50
To: ccielab
Subject: RE: Mock lab 1 : TASK 1.3 (Router on a stick)

The previous task states :

Configure a trunk between Sw1s interface F0/13 and Sw2s interface F0/13 
All traffic sent over this trunk should be tagged with a VLAN header
Do not use Dynamic Trunking protocol over this link


SW2-------TRUNK--------SW1------dot1q(native 263)------R6





--------------------------------- 
Do you Yahoo!?
Everyone is raving about the  all-new Yahoo! Mail.

_______________________________________________________________________
Subscription information may be found at:
 http://www.groupstudy.com/list/CCIELab.html

_______________________________________________________________________
Subscription information may be found at:
 http://www.groupstudy.com/list/CCIELab.html


 

         
---------------------------------
Talk is cheap. Use Yahoo! Messenger to make PC-to-Phone calls.  Great rates starting at 1"/min.

_______________________________________________________________________
Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html

_______________________________________________________________________
Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html


         
---------------------------------
 All-new Yahoo! Mail - Fire up a more powerful email and get things done faster.

_______________________________________________________________________
Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html

_______________________________________________________________________
Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html


 				
---------------------------------
Want to be your own boss? Learn how on  Yahoo! Small Business.