GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: frame-relay fragment & exclude voice pakkets from being fragmented posted 08/20/2006
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Udo,

As I read your solution below, you are putting all non-voice traffic into the frame class. All the outut would now be non-voice out the S0/0 interface, all of which would be fragmented to 40. Where does the voice traffic go now? 

As Scott had mentioned earlier yesterday, in order to get the voice traffic out without fragmentation, have to get into a priority queue. Scott suggested usage of LLQ and it was also suggested to use ip rtp priority queueuing (although it was unsure if this type of queue absolutely had the non-fragmentation that llq had, but no reason why it wouldn't).

HTH,
PD

-----Original Message-----
From: Udo Konstantin [mailto:ccie_groupstudy@xxxxxxxx] 
Sent: Sunday, August 20, 2006 1:30 AM
To: Scott Morris
Cc: 'Sidalo'; Paul Dardinski; 'Cisco certification'
Subject: RE: frame-relay fragment & exclude voice pakkets from being fragmented

Hi Scott,

the primary challenge was ....

traffic over 120kb lemgth should be fragmented and voice traffic should
never fragmented even if the packet length over 120 
Did you also have a solution for this ?I think this shoul be the
solution :

class-map match-all NO_VOICE
  match not ip rtp 16384 16383
!
!
policy-map FRAGMENT
  class NO_VOICE
!
!
interface Serial0/0
 ip address 192.168.1.1 255.255.255.0
 encapsulation frame-relay
 no ip split-horizon eigrp 100
 frame-relay map ip 192.168.1.1 102
 frame-relay map ip 192.168.1.2 102 broadcast
 frame-relay map ip 192.168.1.3 103 broadcast
 frame-relay interface-dlci 102
  class FRAG
 no frame-relay inverse-arp
!
!
!
map-class frame-relay FRAG
 service-policy output FRAGMENT
 frame-relay fragment 40

Udo

> So, to answer the question below, it's really quite simple:
> 
> class-map Voice
>  match access-list 101
> access-list 101 permit udp any any range 16384 32767 prec 5
> policy-map GoodVoice
>  class Voice
>   priority (some number here, which may be guessing, or information given
> other places!)
> 
> map-class frame-relay FragMe
>  frame-relay fragment 120
>  service-policy output GoodVoice
> 
> int s0/1/0
>  frame-relay interface-dlci 204
>   class FragMe
> 
> Or the map-class and service-policy could be applied per interface depending
> on what the exact scenario was.  In the end, the handling should be what we
> desire.
> 
> Obviously, pay attention to the scenario itself, but based on the generic
> information below this would be my approach.  (which, by the way, the "kb"
> part wouldn't be there!)
> 
>  
> Scott Morris, CCIE4 (R&S/ISP-Dial/Security/Service Provider) #4713, JNCIE
> #153, CISSP, et al.
> CCSI/JNCI-M/JNCI-J
> IPExpert VP - Curriculum Development
> IPExpert Sr. Technical Instructor
> smorris@xxxxxxxxxxxx
> http://www.ipexpert.com
>  
> 
> 
> -----Original Message-----
> From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of
> Sidalo
> Sent: Saturday, August 19, 2006 1:01 PM
> To: Paul Dardinski
> Cc: Cisco certification
> Subject: Re: frame-relay fragment & exclude voice pakkets from being
> fragmented
> 
> Obviously there is a reason this keep coming up, even though we havent see
> it in the big vendors lab workbooks.  (unless it has since been added)
> 
> I know for me, I would certainly figure this out before I go in for my next
> lab attempt.
> 
> On 8/19/06, Paul Dardinski <pauld@xxxxxxxxxxxxxxxx> wrote:
> >
> > I am confused. How does one apply frame fragmentation within the mqc?
> > Required for within map-class, correct? If within map-class, how would 
> > differentiate between packet sizes for selective fragmentation?
> >
> > -----Original Message-----
> > From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf 
> > Of Udo Konstantin
> > Sent: Saturday, August 19, 2006 10:54 AM
> > To: ccielab@xxxxxxxxxxxxxx
> > Subject: frame-relay fragment & exclude voice pakkets from being 
> > fragmented
> >
> > Hi group,
> >
> > I read this thread but right now I don't had a answer about the 
> > following requirements
> >
> > Traffic over 120 kb length should be fragmented, voice traffic should 
> > never fragmented, even if the packet length over 120 kb
> >
> > All other traff < 120 kb should not be fragmented
> >
> > My solution
> >
> > class-map DATA
> >         match packet length max 120000
> >
> > policy-map FRAG
> >         class DATA
> >         frame-relay fragment ?? <not sure about the size>
> >
> > interface Serial0/0
> > ip address 192.168.1.1 255.255.255.0
> > ip rtp header-compression
> > encapsulation frame-relay
> > frame-relay interface-dlci xxx
> >   class FRAG
> >
> > or should I configure
> > service-policy output FRAG (Interface Config Mode)
> >
> > Thanks...
> >
> > Udo
> >
> >
> >
> >
> >
> >
> >
> >
> > ___________________________________________________________
> > Der fr|he Vogel fdngt den Wurm. Hier gelangen Sie zum neuen Yahoo! Mail:
> > http://mail.yahoo.de
> >
> > ______________________________________________________________________
> > _ Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> > ______________________________________________________________________
> > _ Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> 
> _______________________________________________________________________
> Subscription information may be found at: 
> http://www.groupstudy.com/list/CCIELab.html
> 
> _______________________________________________________________________
> Subscription information may be found at: 
> http://www.groupstudy.com/list/CCIELab.html


	

	
		
___________________________________________________________ 
Der fr|he Vogel fdngt den Wurm. Hier gelangen Sie zum neuen Yahoo! Mail: http://mail.yahoo.de