GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: OT: DMVPN posted 03/20/2006
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Did you make sure you have this, I think this was already posted.



Hub:

Int tun 123

no ip next-hop-self eigrp 100

no ip split-horizon eigrp 100



Spoke:

Int tun 123

no ip next-hop-self eigrp 100



I'm not sure is you have this..





CC

  _____

From: Chris Broadway [mailto:midatlanticnet@xxxxxxxxx]
Sent: Monday, March 20, 2006 8:20 AM
To: Mark Lasarko
Cc: groupstudy@xxxxxxxxxxxxxxxxx; Chris Cole; ccielab@xxxxxxxxxxxxxx
Subject: Re: OT: DMVPN



All,

I switched the hub location in the DMVPN topology and I am still seeing
the same issue.  The spokes see the hub as an EIGRP neighbor that is up
but the hub doesn't see the spokes as an EIGRP neighbor at all.  How are
the spokes seeing the hub up but not vice versa:



Spokes

2821_CE_A#sh ip eigrp neighbors

IP-EIGRP neighbors for process 1

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q
Seq

                                            (sec)         (ms)       Cnt
Num

0   50.50.50.2              Tu0               12 00:00:40    1  5000  1
0



2610XM_CE_C#sh ip eigrp neighbors

IP-EIGRP neighbors for process 1

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q
Seq

                                            (sec)         (ms)       Cnt
Num

0   50.50.50.2              Tu0               14 00:00:42    1  5000  1
0







Hub

2610XM_CE_B#sh ip eigrp neighbors

IP-EIGRP neighbors for process 1

2610XM_CE_B#









Also, The spokes are bouncing the EIGRP adjacencies still....Any clue?
Here is one spoke and the hub partial configs:



Spoke

crypto isakmp policy 1

 authentication pre-share

crypto isakmp key cisco47 address 0.0.0.0 0.0.0.0

!

!

crypto ipsec transform-set trans2 esp-des esp-md5-hmac

!

crypto ipsec profile vpnprof

 set transform-set trans2

!

!

!

!

!

interface Tunnel0

 bandwidth 1000

 ip address 50.50.50.1 255.255.255.0

 no ip redirects

 ip mtu 1416

 ip nhrp authentication donttell

 ip nhrp map 50.50.50.2 10.10.8.2

 ip nhrp network-id 99

 ip nhrp holdtime 300

 ip nhrp nhs 50.50.50.2

 delay 1000

 tunnel source GigabitEthernet0/1

 tunnel mode gre multipoint

 tunnel key 100000

 tunnel protection ipsec profile vpnprof





2821_CE_A#sh run | b router eigrp

router eigrp 1

 network 9.9.9.9 0.0.0.0

 network 50.50.50.0 0.0.0.255

 no auto-summary

!

ip classless

ip route 10.10.0.0 255.255.0.0 10.10.5.1











Hub

!

crypto isakmp policy 1

 authentication pre-share

crypto isakmp key cisco47 address 0.0.0.0 0.0.0.0

!

!

crypto ipsec transform-set trans2 esp-des esp-md5-hmac

!

crypto ipsec profile vpnprof

 set transform-set trans2

!

!

!

!

!

interface Tunnel0

 bandwidth 1000

 ip address 50.50.50.2 255.255.255.0

 no ip redirects

 ip mtu 1416

 no ip next-hop-self eigrp 1

 ip nhrp authentication donttell

 ip nhrp map multicast dynamic

 ip nhrp network-id 99

 ip nhrp holdtime 300

 no ip split-horizon eigrp 1

 delay 1000

 tunnel source FastEthernet0/0

 tunnel mode gre multipoint

 tunnel key 100000

 tunnel protection ipsec profile vpnprof









2610XM_CE_B#sh run | b router eigrp 1

router eigrp 1

 network 12.12.12.12 0.0.0.0

 network 50.50.50.0 0.0.0.255

 no auto-summary

!

ip classless

ip route 10.10.0.0 255.255.0.0 10.10.8.1



 -Chris