GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: EIGRP and connected command posted 03/12/2006
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Zillah,

There is a caveat with redistributing using "connected" and using route-maps
to restrict the interfaces that get redistributed.

1. Redistributed connected routes into IGP1 on this router will not make it
into IGP2 on the next IGP2 router if IGP1&IGP2 are redistributed one into
the other on this router.
    - no cyclic redistribution, this is a standard redistribution rule when
done on the same router.

2. Redistibuted connected with route-map into IGP1, will always supercede
the redistribution of connected routes adverised into IGP2, when IGP2 is
    being redisributed into IGP1.

Using the network statemen if not resricted and it conform to your task will
save one from all these.

However, you can amend your route-maps and routing domain to counter these
caveats, but a the end of the day, it will requirement too many extral
keystrokes to accomplish compared to using the network statement.

Brian will explain better.

Illustration:

R1(eigrp1)------(eigrp1)R2(ospf1)------(ospf1)R3

R1#
Interface fa0/0
ip address 1.1.1.1 255.255.255.0
!
Interface fa0/1
ip address 2.2.2.2 255.255.255.0
!
router eigrp 1
network 1.1.1.1 0.0.0.0
network 2.2.2.2 0.0.0.0
!

R2:
Interface fa0/0
ip address 2.2.2.1 255.255.255.0
!
Interface fa0/1
ip address 3.3.3.3.2 255.255.255.0
!
Interface ser0/0
Ip address 4.4.4.4 255.255.255.0
!
router eigrp 1
network 2.2.2.1 0.0.0.0
redistribute connected route-map serial00
redistribute ospf 1
default-metric *********
!
route-map serial00 permit 10
match interface serial0/0
!
router ospf 1
network 3.3.3.2 0.0.0.0 area 0
redistribute eigrp 1 subnet
!
R3:
Interface fa0/0
ip address 3.3.3.1 255.255.255.0
!
router ospf 1
network 3.3.3.1 0.0.0.0 area 0.

Caveat 1 above:
You will not see redistributed route 4.4.4.0/24 in R3's routing table. Using
network statement instead redistribute connected route-map would have make
the results different.

Caveat 2 above:
You will not see ospf route 3.3.3.0/24 in R1's routing table, you will only
see the route to serial0/0.You must then permit the connected interface
represented by nework 3.3.3.0/24 in your route-map.

A simple network statement if allowed, will put all these to rest.

Since, I did not copy the above configures from a router, there might be
some typo or missing component parts, but this will suffice to illustrate my
point. I wish, I can run Cisco IOS on my notepad to check all the syntax,
etc.



HTH.

----- Original Message -----
From: "zillah" <forwardtruth@xxxxxxxxx>
To: "Brian Dennis" <bdennis@xxxxxxxxxxxxxxxxxxxxxx>;
<ccielab@xxxxxxxxxxxxxx>
Sent: Friday, February 17, 2006 5:20 AM
Subject: RE: EIGRP and connected command


> Thanks Brain
>
>   What about "connected" command (first part of my question)
>
> Brian Dennis <bdennis@xxxxxxxxxxxxxxxxxxxxxx> wrote:
>   If you need to redistribute only one interface in via connected, why
> wouldn't you use a route-map to allow only the interface you want to be
> redistributed in?
>
> HTH,
>
> Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
> bdennis@xxxxxxxxxxxxxxxxxxxxxx
>
> Internetwork Expert, Inc.
> http://www.InternetworkExpert.com
> Toll Free: 877-224-8987
> Direct: 775-745-6404 (Outside the US and Canada)
>
>
> -----Original Message-----
> From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of
> forwardtruth@xxxxxxxxx
> Sent: Thursday, February 16, 2006 10:33 PM
> To: ccielab@xxxxxxxxxxxxxx
> Subject: EIGRP and connected command
>
> IWEB- V1 Lab 5 Task 5.22-5.24
>
> R4:
> router ospf 1
> redistribute connected subnets route-map CONNECTED2OSPF
>
>
> 1- Do we use "connected" command as extra command----I know what is the
> use of this command (replacement of network command) ,,,because I have
> see this command has been used in some lab and it has not been used in
> other (to my "limit knowledge" all these labs have same requiremnet in
> this specific command).
>
> 2- The lab 5 has not stated that "route-map" to be used ,,,,why has it
> been used in this lab (5) ?
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
>
>
> ---------------------------------
>  Yahoo! Mail
>  Use Photomail to share photos without annoying attachments.
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html