GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: ospf network type & FR posted 02/03/2006
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Hi Siegfried,

The problem here is that your frame-relay configuration is wrong, when
you use a Hub and Spoke topology where all the interfaces are physical
(including the Hub interfaces, I mean interfaces because in this case you
have to have at least two interfaces on the Hub router) one for each
spoke, so in this case you don't even have to have the frame map
statement on the hub try to configure only the frame map on the spokes
pointing to each other (r4 with frame map to r5 and vice-versa and quite
the frame map statement on the hub router) and you will see everything
works fine, try to do a debug frame packet from your spoke when you ping
and you should probably see something like no frame map, but I really
think the solution for your problem I put it below.

If you have only one interface on the Hub router you should being using
sub interface instead of physical on the hub router so try to keep your
frame relay configuration on the hub but just change from interface
Serial0/1/0 (on R2) to interface Serial0/1/0.245 or something like this
and leave the frame map statements from hub to the spokes like you have
and try to ping again and I think everything should work, then please let
me know if it works.

Thanks,

Andy

  --------------------------------------------------------------------

  From:  Muhanad <mndnt@xxxxxxxxx>
  Reply-To:  Muhanad <mndnt@xxxxxxxxx>
  To:  siegfried.droogmans@xxxxxxxxx, ccielab@xxxxxxxxxxxxxx
  Subject:  Re: ospf network type & FR
  Date:  Fri, 3 Feb 2006 07:01:01 -0800 (PST)
  >I think its normal, your ip scheme reflect a multipoint scenario, so
  on spoke routers, u have to mention the multipoint option either in
  ip ospf command or the multipoint keyword for subinterfaces..
  >
  >   Regards.
  >
  >siegfried.droogmans@xxxxxxxxx wrote:
  >   Hi,
  >
  >can someone explain following behaviour:
  >
  >R2 is Hub
  >R4, R5 are spokes
  >only physical ports allowed
  >Hub ospf network type is PTMP
  >
  >
  >If I use OSPF network PTP on spokes I can NOT ping other spokes.
  (CASE 1)
  >
  >If I use OSPF network PTMP on spokes I CAN ping other spokes. (CASE
  2)
  >
  >Is this expected behaviour? I wouldn't expect the 'ip ospf network'
  command to have influence on icmp connectivity.
  >
  >CASE1:
  >------
  >R4(config-router)#
  >router ospf 1
  >log-adjacency-changes
  >network 150.50.100.0 0.0.0.255 area 0
  >network 200.0.0.0 0.0.0.255 area 0
  >
  >interface Serial0/0/0
  >ip address 150.50.100.4 255.255.255.0
  >encapsulation frame-relay
  >ip ospf network point-to-point
  >frame-relay map ip 150.50.100.2 401 broadcast
  >no frame-relay inverse-arp
  >
  >R5(config-router)#
  >router ospf 1
  >log-adjacency-changes
  >network 150.50.100.0 0.0.0.255 area 0
  >
  >interface Serial0/1/0
  >ip address 150.50.100.5 255.255.255.0
  >encapsulation frame-relay
  >ip ospf network point-to-point
  >frame-relay map ip 150.50.100.2 501 broadcast
  >no frame-relay inverse-arp
  >
  >
  >R2(config-router)#
  >router ospf 1
  >log-adjacency-changes
  >network 150.50.100.0 0.0.0.255 area 0
  >
  >interface Serial0/1/0
  >ip address 150.50.100.2 255.255.255.0
  >encapsulation frame-relay
  >ip ospf network point-to-multipoint
  >ip ospf hello-interval 10
  >frame-relay map ip 150.50.100.4 104 broadcast
  >frame-relay map ip 150.50.100.5 105 broadcast
  >no frame-relay inverse-arp
  >end
  >
  >
  >R2(config-if)#do sfm
  >Serial0/1/0 (up): ip 150.50.100.4 dlci 104(0x68,0x1880), static,
  >broadcast,
  >CISCO, status defined, active
  >Serial0/1/0 (up): ip 150.50.100.5 dlci 105(0x69,0x1890), static,
  >broadcast,
  >CISCO, status defined, active
  >
  >R4(config-if)#do sfm
  >Serial0/0/0 (up): ip 150.50.100.2 dlci 401(0x191,0x6410), static,
  >broadcast,
  >CISCO, status defined, active
  >
  >R5(config-if)#do sfm
  >Serial0/1/0 (up): ip 150.50.100.2 dlci 501(0x1F5,0x7C50), static,
  >broadcast,
  >CISCO, status defined, active
  >
  >R5(config-if)#do ping 150.50.100.4
  >Type escape sequence to abort.
  >Sending 5, 100-byte ICMP Echos to 150.50.100.4, timeout is 2
  seconds:
  >.....
  >Success rate is 0 percent (0/5)
  >
  >CASE 2:
  >-------
  >R4(config-if)#
  >router ospf 1
  >log-adjacency-changes
  >network 150.50.100.0 0.0.0.255 area 0
  >network 200.0.0.0 0.0.0.255 area 0
  >interface Serial0/0/0
  >ip address 150.50.100.4 255.255.255.0
  >encapsulation frame-relay
  >ip ospf network point-to-multipoint
  >frame-relay map ip 150.50.100.2 401 broadcast
  >no frame-relay inverse-arp
  >
  >R5(config-if)#
  >router ospf 1
  >log-adjacency-changes
  >network 150.50.100.0 0.0.0.255 area 0
  >interface Serial0/1/0
  >ip address 150.50.100.5 255.255.255.0
  >encapsulation frame-relay
  >ip ospf network point-to-multipoint
  >frame-relay map ip 150.50.100.2 501 broadcast
  >no frame-relay inverse-arp
  >
  >R2(config-if)#
  >router ospf 1
  >log-adjacency-changes
  >network 150.50.100.0 0.0.0.255 area 0
  >interface Serial0/1/0
  >ip address 150.50.100.2 255.255.255.0
  >encapsulation frame-relay
  >ip ospf network point-to-multipoint
  >frame-relay map ip 150.50.100.4 104 broadcast
  >frame-relay map ip 150.50.100.5 105 broadcast
  >no frame-relay inverse-arp
  >
  >R2(config-if)#do sfm
  >Serial0/1/0 (up): ip 150.50.100.4 dlci 104(0x68,0x1880), static,
  >broadcast,
  >CISCO, status defined, active
  >Serial0/1/0 (up): ip 150.50.100.5 dlci 105(0x69,0x1890), static,
  >broadcast,
  >CISCO, status defined, active
  >
  >R4(config)#do sfm
  >Serial0/0/0 (up): ip 150.50.100.2 dlci 401(0x191,0x6410), static,
  >broadcast,
  >CISCO, status defined, active
  >
  >R5(config-if)#do sfm
  >Serial0/1/0 (up): ip 150.50.100.2 dlci 501(0x1F5,0x7C50), static,
  >broadcast,
  >CISCO, status defined, active
  >
  >R4(config)#do ping 150.50.100.5
  >Type escape sequence to abort.
  >Sending 5, 100-byte ICMP Echos to 150.50.100.5, timeout is 2
  seconds:
  >!!!!!
  >Success rate is 100 percent (5/5), round-trip min/avg/max = 16/19/20
  ms
  >
  >I have rebooted several times.
  >SW is 12.4(3a) on all routers.
  >R2 is 3825, R4 and R5 are 2811
  >
  >cheers,
  >Siegfried
  >
  >_______________________________________________________________________
  >Subscription information may be found at:
  >http://www.groupstudy.com/list/CCIELab.html
  >
  >
  >
  >---------------------------------
  >  Yahoo! Mail - Helps protect you from nasty viruses.
  >
  >_______________________________________________________________________
  >Subscription information may be found at:
  >http://www.groupstudy.com/list/CCIELab.html