GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: OSPF redistribution question posted 12/20/2005
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


This should help:

hostname Rack1R4
!
interface Loopback0
 ip address 150.1.4.4 255.255.255.0
!
router ospf 1
 redistribute connected subnets route-map LOOP
 network 155.1.146.0 0.0.0.255 area 0
!
route-map LOOP permit 10
 match interface Loopback0
 set metric 0
!


Rack1R1#sho ip route ospf
     150.1.0.0/24 is subnetted, 2 subnets
O E2    150.1.4.0 [110/0] via 155.1.146.4, 00:00:07, Ethernet0/0
Rack1R1#


HTH,

Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
bdennis@xxxxxxxxxxxxxxxxxxxxxx 
 
Internetwork Expert, Inc. 
http://www.InternetworkExpert.com 
Toll Free: 877-224-8987 
Direct: 775-745-6404 (Outside the US and Canada) 
 

-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of
azhar mumtaz
Sent: Monday, December 19, 2005 11:12 PM
To: ccielab@xxxxxxxxxxxxxx
Subject: OSPF redistribution question

Hi Team:

R2----OSPF-----R3---loopback0

R3
router ospf 1
redistribute connected subnets route-map LOOP

route-map LOOP
Match interface loopback 0
set metric ?

Int loopback 0
ip address 192.168.1.1

Lets say we are doing a "resdribute connected" "match
interface loopback 0" into OSPF on R3 . can we see
this prefix as 110/0. I am not able to do it. I tried
setting the metric for this prefix on R3 to by doing
set metric ?

I used various options for set metric, setting the
metric -1 , +1 , 0 and so on, it does change the
metric for this prefix on R2, but R2 is never able to
see this prefix as 110/0

Any thoughts on this.

Best Regards
Azhar

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________________________________
Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html