GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: ISDN will not stay down posted 10/26/2005
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Good Point and good call........I'm well aware of what it does however I didnt realize you didnt have PPP enable. Thanks for the education, just trying to help you out.

jl
----- Original Message ----- From: "simon hart" <simon@xxxxxxxxxxx>
To: "joshua lauer" <jslauer@xxxxxxxxxxx>; "Group Study" <ccielab@xxxxxxxxxxxxxx>
Sent: Wednesday, October 26, 2005 10:46 AM
Subject: RE: ISDN will not stay down



Why??  I am not using PPP.   No peer neighbor route will only stop the far
end from installing a host route when PPP is enabled on the connection.

Simon

-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx]On Behalf Of
joshua lauer
Sent: 26 October 2005 15:41
To: simon hart; Group Study
Subject: Re: ISDN will not stay down


No peer neighbor route would be a good option here.


JL


----- Original Message ----- From: "simon hart" <simon@xxxxxxxxxxx> To: "Group Study" <ccielab@xxxxxxxxxxxxxx> Sent: Wednesday, October 26, 2005 10:26 AM Subject: ISDN will not stay down


Hi all,

I have a problem with keeping ISDN in the following configuration. I have
created a non-broadcast area between R4 and R5 for Ospf and also create
ospf
demand circuit on R5, however the circuit never goes down. It seems that
demand circuit does not like this typr of config.
Any ideas?


R5 config

interface BRI0/0
ip address 129.1.45.5 255.255.255.248
ip ospf network non-broadcast
ip ospf demand-circuit
dialer map ip 129.1.45.4 name Frame_R4 1111
dialer redial interval 10 attempts 3
dialer-group 1
isdn switch-type basic-ni
isdn spid1 2122


router ospf 100 router-id 150.1.5.5 log-adjacency-changes network 129.1.45.5 0.0.0.0 area 0 network 129.1.54.5 0.0.0.0 area 0 network 129.1.58.5 0.0.0.0 area 0 network 150.1.5.5 0.0.0.0 area 0 neighbor 129.1.45.4


R4 config


interface BRI0
ip address 129.1.45.4 255.255.255.248
ip ospf network non-broadcast
ip ospf priority 0
dialer map ip 129.1.45.5 name Rack1R5 2222
dialer-group 1
isdn switch-type basic-ni
isdn spid1 1211

router ospf 100
router-id 150.1.4.4
log-adjacency-changes
network 129.1.45.4 0.0.0.0 area 0
network 129.1.46.4 0.0.0.0 area 0
network 129.1.54.4 0.0.0.0 area 0
network 150.1.4.4 0.0.0.0 area 0

BRI0:1 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: ip (s=129.1.45.4, d=129.1.45.5)
Time until disconnect 107 secs
Connected to 2222 (Rack1R5)

Debug IP routing shows no change of routing updates (hence reconvergence
is
not keeping the line up)

Neighbor is established

If I look at the packets I can see that R4 and R5 are exchanging hello
packets every 30 seconds.

Oct 26 14:24:09.878: IP: s=129.1.45.4 (local), d=129.1.45.5 (BRI0), len
80,
sending, proto=89
Oct 26 14:24:24.318: IP: s=129.1.45.5 (BRI0), d=129.1.45.4, len 80, rcvd
0,
proto=89

So I guess the question is does ip ospf demand circuit work when the
circuit
is configured as non-broadcast??

Thanks

Simon

--
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.361 / Virus Database: 267.12.5/149 - Release Date: 25/10/2005


_______________________________________________________________________
Subscription information may be found at:
http://www.groupstudy.com/list/CCIELab.html

_______________________________________________________________________ Subscription information may be found at: http://www.groupstudy.com/list/CCIELab.html -- No virus found in this incoming message. Checked by AVG Free Edition. Version: 7.1.361 / Virus Database: 267.12.5/149 - Release Date: 25/10/2005

--
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.361 / Virus Database: 267.12.5/149 - Release Date: 25/10/2005