GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: Trouble with multicast over NBMA posted 10/04/2005
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Hi Mike,

Could you post the full configurations of router R1,R2 and R3? Please send
us the output of show frame map, show ip route, show ip pim neigh, show ip
mroute and show ip pim rp map. With these commands we can verify that basic
settings are configured correctly.

Please have a look at the advisories of Godswill Oletu and Bob Sinclair.
Please note that if you are going to use the "debug ip mpacket" command,
disable route-caching of multicast packets first. This is needed to see
mpackets in your output.

Regards,
Henk

-----Oorspronkelijk bericht-----
Van: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] Namens Mike
Flanagan
Verzonden: maandag 3 oktober 2005 22:54
Aan: Cisco certification
Onderwerp: Re: Trouble with multicast over NBMA

>   The hub is R2 and my intention was not to have a full mesh frame  
> relay cloud. So I corrected the map statements so now both spokes  
> map to each other through the hub. But I still have the same  
> results even after reloading all of the routers
>
>
>    Thanks,
>
>      Mike F.
>
>
>
> On Oct 3, 2005, at 10:13 AM, Godswill Oletu wrote:
>
>
>> Mike,
>>
>> The configuration at R1:
>>
>> frame-relay map ip 1.1.0.2 105 broadcast
>> frame-relay map ip 1.1.0.3 102
>>
>> And the other at R3:
>>
>> frame-relay map ip 1.1.0.1 201
>> frame-relay map ip 1.1.0.2 205 broadcast
>>
>> From your diagram, these should be spoke routers, the question  
>> then is how mand DLCIs you are annoucing to these spokes? You  
>> appear to be using two different DLCIs to map these spokes to the  
>> hub router and one set of the frame map commands is mising the  
>> 'broadcast' option.
>>
>> Or is this a full meshed network?
>>
>> There are couple of things, eg add the 'broadcast' keyword, check  
>> your layer 2 frame relay mapping and see what dlci is being used  
>> for encapsulation, for traffics from one spoke to the hub and to  
>> the other spoke.
>>
>> If this is not a meshed network, then using one DLCI will be the  
>> way to go.
>>
>> HTH
>> Godswill Oletu
>>
>>
>>
>>
>>
>>
>> ----- Original Message ----- From: "Mike Flanagan"  
>> <mikenoc@xxxxxxxxxxxxxx>
>> To: "Cisco certification" <ccielab@xxxxxxxxxxxxxx>
>> Sent: Monday, October 03, 2005 4:03 AM
>> Subject: Trouble with multicast over NBMA
>>
>>
>>
>>
>>>   Hello,
>>>
>>>  I originally posted this a few weeks ago and then got sick and  
>>> have  not touched this. What I am trying to do here is get  
>>> multicast  working over 3 routers. Router R2 is the hub and is  
>>> the mapping agent  and R1 and R3 are RP's for two different  
>>> multicast networks. If you  do a show ip rp map on R2 you see  
>>> that it has the two multicast  networks on it. if you do a show  
>>> ip mroute on and of these 3 routers  you do not see the networks  
>>> at all. I tried adding ip pim nbma mode  on R2 due to the fact  
>>> that you cannot announce a multicast group back  out an interface  
>>> that was learned. With the theory in mind of  changing the OIL  
>>> from using the interface to an IP address but that  did not work.  
>>> I am not sure if I am missing something simple "which  is highly  
>>> likely ;)" or if maybe I need to make a tunnel between R1  and R3.
>>>
>>>
>>>    Please advise.
>>>
>>>       Thanks,
>>>
>>>         Mike F.
>>>
>>>
>>>
>>>                R2
>>>            /          \
>>>         /               \
>>>   R1                   R3
>>>
>>>
>>> R1#sh run int ser 0/0.5
>>> Building configuration...
>>>
>>> Current configuration : 227 bytes
>>> !
>>> interface Serial0/0.5 multipoint
>>> ip address 1.1.0.1 255.255.255.0
>>> ip pim nbma-mode
>>> ip pim sparse-dense-mode
>>> ip ospf priority 0
>>> frame-relay map ip 1.1.0.2 105 broadcast
>>> frame-relay map ip 1.1.0.3 102
>>> end
>>>
>>> R1#
>>>
>>> ip pim send-rp-announce Loopback0 scope 16 group-list 11
>>> R1#
>>> R1#sh access-lists 11
>>> Standard IP access list 11
>>>     10 permit 224.0.0.0, wildcard bits 7.255.255.255
>>> R1#
>>>
>>>
>>>
>>> R1#sh ip pim nei
>>> PIM Neighbor Table
>>> Neighbor          Interface                Uptime/Expires     
>>> Ver   DR
>>> Address Prio/Mode
>>> 1.1.0.2           Serial0/0.5              00:09:09/00:01:20  
>>> v2     1 / DR S
>>> R1#
>>>
>>> R1#sh ip pim rp map
>>> PIM Group-to-RP Mappings
>>> This system is an RP (Auto-RP)
>>>
>>> R1#
>>>
>>>
>>> R1#sh ip mroute
>>> IP Multicast Routing Table
>>> Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C -  
>>> Connected,
>>>        L - Local, P - Pruned, R - RP-bit set, F - Register flag,
>>>        T - SPT-bit set, J - Join SPT, M - MSDP created entry,
>>>        X - Proxy Join Timer Running, A - Candidate for MSDP  
>>> Advertisement,
>>>        U - URD, I - Received Source Specific Host Report, Z -   
>>> Multicast Tunnel
>>>        Y - Joined MDT-data group, y - Sending to MDT-data group
>>> Outgoing interface flags: H - Hardware switched
>>> Timers: Uptime/Expires
>>> Interface state: Interface, Next-Hop or VCD, State/Mode
>>>
>>> (*, 224.0.1.39), 00:41:50/stopped, RP 0.0.0.0, flags: DC
>>>   Incoming interface: Null, RPF nbr 0.0.0.0
>>>   Outgoing interface list:
>>>     Serial0/0.5, Forward/Sparse-Dense, 00:41:50/00:00:00
>>>
>>> (1.1.1.1, 224.0.1.39), 00:41:24/00:02:35, flags: T
>>>   Incoming interface: Loopback0, RPF nbr 0.0.0.0
>>>   Outgoing interface list:
>>>     Serial0/0.5, Forward/Sparse-Dense, 00:41:24/00:00:00
>>>
>>> (*, 224.0.1.40), 00:42:19/stopped, RP 0.0.0.0, flags: DCL
>>>   Incoming interface: Null, RPF nbr 0.0.0.0
>>>   Outgoing interface list:
>>>     Serial0/0.5, Forward/Sparse-Dense, 00:41:54/00:00:00
>>>     Loopback0, Forward/Sparse-Dense, 00:42:20/00:00:00
>>>
>>> (1.1.2.2, 224.0.1.40), 00:04:26/00:02:37, flags: LT
>>>   Incoming interface: Serial0/0.5, RPF nbr 1.1.0.3
>>>   Outgoing interface list:
>>>     Loopback0, Forward/Sparse-Dense, 00:04:26/00:00:00
>>>
>>> R1#
>>>
>>>    -----------------------------------------
>>>
>>> R2#sh run int ser 0/0.1
>>> Building configuration...
>>>
>>> Current configuration : 202 bytes
>>> !
>>> interface Serial0/0.1 multipoint
>>> ip address 1.1.0.2 255.255.255.0
>>> ip pim nbma-mode
>>> ip pim sparse-dense-mode
>>> frame-relay map ip 1.1.0.1 501 broadcast
>>> frame-relay map ip 1.1.0.3 502 broadcast
>>> end
>>>
>>> R2#
>>>
>>> ip pim send-rp-discovery Loopback0 scope 16
>>>
>>>
>>> R2#sh ip pim nei
>>> PIM Neighbor Table
>>> Neighbor          Interface                Uptime/Expires     
>>> Ver   DR
>>> Address Prio/Mode
>>> 1.1.0.3           Serial0/0.1              00:06:28/00:01:31  
>>> v2     1 / DR S
>>> 1.1.0.1           Serial0/0.1              00:07:50/00:01:18  
>>> v2    1 / S
>>> R2#
>>>
>>> R2#sh ip pim rp map
>>> PIM Group-to-RP Mappings
>>> This system is an RP-mapping agent (Loopback0)
>>>
>>> Group(s) 224.0.0.0/5
>>>   RP 1.1.1.1 (?), v2v1
>>>     Info source: 1.1.1.1 (?), elected via Auto-RP
>>>          Uptime: 00:02:29, expires: 00:02:29
>>> Group(s) 232.0.0.0/5
>>>   RP 1.1.3.3 (?), v2v1
>>>     Info source: 1.1.3.3 (?), elected via Auto-RP
>>>          Uptime: 00:13:48, expires: 00:01:12
>>> R2#
>>>
>>>
>>>
>>>
>>> R2#sh ip mroute
>>> IP Multicast Routing Table
>>> Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C -  
>>> Connected,
>>>        L - Local, P - Pruned, R - RP-bit set, F - Register flag,
>>>        T - SPT-bit set, J - Join SPT, M - MSDP created entry,
>>>        X - Proxy Join Timer Running, A - Candidate for MSDP  
>>> Advertisement,
>>>        U - URD, I - Received Source Specific Host Report, Z -   
>>> Multicast Tunnel
>>>        Y - Joined MDT-data group, y - Sending to MDT-data group
>>> Outgoing interface flags: H - Hardware switched
>>> Timers: Uptime/Expires
>>> Interface state: Interface, Next-Hop or VCD, State/Mode
>>>
>>> (*, 224.0.1.39), 00:30:18/stopped, RP 0.0.0.0, flags: DCL
>>>   Incoming interface: Null, RPF nbr 0.0.0.0
>>>   Outgoing interface list:
>>>     Loopback0, Forward/Sparse-Dense, 00:30:18/00:00:00
>>>     Serial0/0.1, Forward/Sparse-Dense, 00:30:18/00:00:00
>>>
>>> (1.1.1.1, 224.0.1.39), 00:09:01/00:02:59, flags: LT
>>>   Incoming interface: Serial0/0.1, RPF nbr 1.1.0.1
>>>   Outgoing interface list:
>>>     Loopback0, Forward/Sparse-Dense, 00:09:01/00:00:00
>>>
>>> (1.1.2.2, 224.0.1.39), 00:00:25/00:02:35, flags: LT
>>>   Incoming interface: Loopback0, RPF nbr 0.0.0.0
>>>   Outgoing interface list:
>>>     Serial0/0.1, Forward/Sparse-Dense, 00:00:25/00:00:00
>>>
>>> (*, 224.0.1.40), 00:30:19/stopped, RP 0.0.0.0, flags: DCL
>>>   Incoming interface: Null, RPF nbr 0.0.0.0
>>>   Outgoing interface list:
>>>     Loopback0, Forward/Sparse-Dense, 00:30:19/00:00:00
>>>     Serial0/0.1, Forward/Sparse-Dense, 00:30:19/00:00:00
>>>
>>> (1.1.2.2, 224.0.1.40), 00:13:09/00:02:54, flags: L
>>>   Incoming interface: Loopback0, RPF nbr 0.0.0.0
>>>   Outgoing interface list:
>>>     Serial0/0.1, Forward/Sparse-Dense, 00:12:21/00:00:00
>>>
>>> R2#
>>>
>>>  -----------------------------------------
>>>
>>> R3#sh run int ser 0/0
>>> Building configuration...
>>>
>>> Current configuration : 318 bytes
>>> !
>>> interface Serial0/0
>>> ip address 1.1.0.3 255.255.255.0
>>> ip pim sparse-dense-mode
>>> encapsulation frame-relay
>>> ip ospf priority 0
>>> frame-relay map ip 1.1.0.1 201
>>> frame-relay map ip 1.1.0.2 205 broadcast
>>> no frame-relay inverse-arp
>>> frame-relay lmi-type cisco
>>> end
>>>
>>> R3#
>>>
>>>
>>> R3#sh ip pim nei
>>> PIM Neighbor Table
>>> Neighbor          Interface                Uptime/Expires     
>>> Ver   DR
>>> Address Prio/Mode
>>> 1.1.0.2           Serial0/0                00:13:08/00:01:17  
>>> v2    1 / S
>>> R3#
>>>
>>> R3#sh ip pim rp map
>>> PIM Group-to-RP Mappings
>>> This system is an RP (Auto-RP)
>>>
>>> R3#
>>>
>>> R3#sh ip pim rp map
>>> PIM Group-to-RP Mappings
>>> This system is an RP (Auto-RP)
>>>
>>> R3#
>>>
>>>
>>> R3#sh ip pim rp map
>>> PIM Group-to-RP Mappings
>>> This system is an RP (Auto-RP)
>>>
>>> R3#
>>>
>>> ip pim send-rp-announce Loopback0 scope 16 group-list 1
>>> R3#sh access-li
>>> R3#sh access-lists 1
>>> Standard IP access list 1
>>>     10 permit 232.0.0.0, wildcard bits 7.255.255.255
>>> R3#
>>>
>>> ____________________________________________________________________ 
>>> ___
>>> Subscription information may be found at: http:// 
>>> www.groupstudy.com/list/CCIELab.html

_______________________________________________________________________
Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html