GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: config - ISDN B-Channel 2 links - up ---> Doubt posted 08/17/2005
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Thanks Scott,

I remember that from your Bootcamp, concerned with two identical 64K 
paths:

==================
If you JUST use dialer load-threshold (and no ppp multilink) you will get
two identical 64K paths that your router/IGP see.
===============

Then, yesterday, I was trying to see it going on using a lab, but although 
I see two active channels on "show isdn active", I just see one route 
pointing to dialer interface.

I thought I should see two entries on the routing table. I am wondering if 
I am wrong expecting see this on routing table, although IOS 'see' two 
layer 3 path.

Am I missing some more point here?


Tests:

Config

Rack2R5#sh run int di 1
interface Dialer1
 description Testing Dialer Load-threshold without multilink
 ip address 148.5.45.1 255.255.255.0
 encapsulation ppp
 ip ospf cost 9999
 dialer pool 1
 dialer idle-timeout 100
 dialer string 4441111111
 dialer load-threshold 1 outbound
 dialer-group 7
 no peer neighbor-route
 ppp authentication chap

interface BRI0/0
 description testar dialer load-trheshold only on R5
 no ip address
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 555111111100
 isdn spid2 555222222200
 ppp authentication chap

Monitoring

Rack2R5#sir 148.5.14.0
Routing entry for 148.5.14.0/24
  Known via "ospf 1", distance 110, metric 10019, type extern 1
  Redistributing via eigrp 45
  Advertised by eigrp 45 metric 1000 10 255 1 1500
  Last update from 148.5.45.4 on Dialer1, 00:01:12 ago
  Routing Descriptor Blocks:
  * 148.5.45.4, from 4.4.4.4, 00:01:12 ago, via Dialer1
      Route metric is 10019, traffic share count is 1

Rack2R5#
Rack2R5#sh is ac
--------------------------------------------------------------------------------
                                ISDN ACTIVE CALLS
--------------------------------------------------------------------------------
Call    Calling      Called       Remote  Seconds Seconds Seconds Charges
Type    Number       Number       Name    Used    Left    Idle 
Units/Currency
--------------------------------------------------------------------------------
Out   ---N/A---  4441111111      Rack2R4     2235      71      28      0
Out   ---N/A---  4441111111      Rack2R4       78      94       5      0
--------------------------------------------------------------------------------

Rack2R5#
Rack2R5#sh dialer

BRI0/0:1 - dialer type = ISDN
Idle timer (100 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: Dialing on overload
Interface bound to profile Di1
Time until disconnect 96 secs
Current call connected 00:01:26
Connected to 4441111111 (Rack2R4)

BRI0/0:2 - dialer type = ISDN
Idle timer (100 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: Dialing on overload
Interface bound to profile Di1
Time until disconnect 63 secs
Current call connected 00:37:25
Connected to 4441111111 (Rack2R4)






PPP Multilink minimum links works pretty well (after reloading the router 
:) ):

interface Dialer2
 description Testing Multilink Minimum links
 ip address 148.5.45.2 255.255.255.0
 encapsulation ppp
 ip ospf cost 9999
 dialer pool 2
 dialer string 4441111111
 dialer-group 6
 no peer neighbor-route
 ppp authentication chap
 ppp multilink
 ppp multilink links minimum 2
end

Rack2R5#sh is ac
--------------------------------------------------------------------------------
                                ISDN ACTIVE CALLS
--------------------------------------------------------------------------------
Call    Calling      Called       Remote  Seconds Seconds Seconds Charges
Type    Number       Number       Name    Used    Left    Idle 
Units/Currency
--------------------------------------------------------------------------------
Out   ---N/A---  4441111111      Rack2R4     6828 Unavail   -          0
Out   ---N/A---  4441111111      Rack2R4     6825 Unavail   -          0


Rack2R5#sh dialer

BRI0/0:1 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: ip (s=148.5.45.2, d=224.0.0.5)
Interface bound to profile Di2
Current call connected 01:54:07
Connected to 4441111111 (Rack2R4)

BRI0/0:2 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is multilink member
Dial reason: Multilink bundle below min-links
Interface bound to profile Di2
Current call connected 01:54:04
Connected to 4441111111 (Rack2R4)



Cordially,
------------------------------------------------------------------
 Gladston 



"Scott Morris" <swm@xxxxxxxxxx> 
16/08/2005 23:21
Please respond to
<swm@xxxxxxxxxx>


To
Alaerte Gladston Vidali/Brazil/IBM@xxxxx, "'Arun Arumuganainar'" 
<aarumuga@xxxxxxxxxxx>
cc
<ccielab@xxxxxxxxxxxxxx>, <nobody@xxxxxxxxxxxxxx>
Subject
RE: config - ISDN B-Channel 2 links - up ---> Doubt






At a very simple viewpoint, it's Layer 2 versus Layer 3.

If you JUST use dialer load-threshold (and no ppp multilink) you will get
two identical 64K paths that your router/IGP see.  You'll do Layer 3 load
balancing at that point.

If you use dialer load-threshold WITH ppp multilink you will get the Layer 
2
splitting as you have noted, which gets seen by your router/IGP as a 
single
128K interface.

Links minimum (or variants thereof) will determine how many links must be
active BEFORE a ppp multilink bundle is considered to be a success.  (e.g.
you require 3 but only get 2, then the world is not good)

"ppp multilink load-threshold" will do the same thing that dialer
load-threshold does, but it requires that ppp multilink be negotiated 
first.
So you'll never get L3 load balancing no matter what your config on that
one.

HTH,

Scott

-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of
gladston@xxxxxxxxxx
Sent: Tuesday, August 16, 2005 4:17 PM
To: Arun Arumuganainar
Cc: ccielab@xxxxxxxxxxxxxx; nobody@xxxxxxxxxxxxxx
Subject: Fw: config - ISDN B-Channel 2 links - up ---> Doubt

Hi,

I just remember that Solies talks about this subject. Her books has an
example using both, ppp multilink and dialer load-threshold at the same
time:

ppp multilink
dialer load-threshold ...

I have heard that 'ppp multilink link minimum...' works better. But on
tests, both have their problems, specially when config are changed,
sometimes requiring a reload on the router. (that just happened today when 
I
was testing to check this threat...after removing 'dialer load-threshold'
and configuring 'ppp multilink' and 'ppp multilink minimum...' the ISDN 
stop
working, just displaying that there was no free channel to dial)

I am not sure yet what happens if just configuring 'dialer load-threshold'
concerned to the distribution of packets along the two channels.

With ppp multilink it is clear that IOS fragments packets, split them over
the two channels, and the remote router reassembles them.
But how packet are sent across the two channels when using only dialer
load-threshold?

Any feedback appreciated.

Cordially,
------------------------------------------------------------------
Gladston

----- Forwarded by Alaerte Gladston Vidali/Brazil/IBM on 16/08/2005 17:08
-----

Alaerte Gladston Vidali/Brazil/IBM
16/08/2005 17:03

To
"Arun Arumuganainar" <aarumuga@xxxxxxxxxxx> cc ccielab@xxxxxxxxxxxxxx,
nobody@xxxxxxxxxxxxxx Subject
Re: Re: config - ISDN B-Channel 2 links - up ---> Doubt





Hi Arun,

Sorry, I made a mistake. When using 'dialer idle-threshold.." there is two
channel, not two entries on the routing table.

If I am not mistaken, Multilink PPP load balance using both channels, 
while
BOD does not get load balancing. The second channel is used only when the
first is 'full'.

I hope we get more feeback on this.


============================================================================
======
Bandwidth on demand (BOD) is a Cisco proprietary implementation that 
allows
the aggregation of multiple B channels into a single logical connection.
This implementation is widely used in Cisco-centric networks

The implementation of Cisco's BOD solution is accomplished through the
dialer load- threshold command

Multilink PPP is a specification that enables the bandwidth aggregation of
multiple B channels into one logical pipe. Its mission is comparable to 
that
of Cisco's BOD.
More specifically, the
Multilink PPP feature provides load-balancing functionality over multiple
wide area network
(WAN) links, while providing multivendor interoperability, packet
fragmentation and proper sequencing, and load calculation on both inbound
and outbound traffic Cisco's implementation of Multilink PPP supports the
fragmentation and packet sequencing specifications in RFC 1717. Multilink
PPP enables packets to be fragmented and the fragments to be sent (at the
same time) over multiple point-to-point links to the same remote addres
============================================================================
======

This discussion says:

===========================================================
quoted from
http://www.groupstudy.com/archives/ccielab/200406/msg00697.html

int bri0
dialer load-threshold 10

and

int bri0
ppp multilink
ppp multilink load-threshold 10


Both will add a second channel when the load reaches 10/255, however in 
the
first case you don't really have a ppp multlink, only two seperate 
channels.
=======================================================================


Thanks,
Alaerte





"Arun Arumuganainar" <aarumuga@xxxxxxxxxxx> Sent by: nobody@xxxxxxxxxxxxxx
13/08/2005 01:49
Please respond to
"Arun Arumuganainar" <aarumuga@xxxxxxxxxxx>


To
Alaerte Gladston Vidali/Brazil/IBM@xxxxx, <ccielab@xxxxxxxxxxxxxx>
cc

Subject
Re: Re: config - ISDN B-Channel 2 links - up ---> Doubt






Hmmm ... I am not an Expert on ISDN . But this is what my understanding
!!!

There are two ways of configuring Bandwidth aggrigation  1) PPP Multilink
and 2) BOD . Functionality wise both are exactly the same .

Two Channels to same destination
1 Route in the routing table .

But the difference between them is that PPP multilink is standard fromat
while BOD is cisco properitary !!!

Note : BOD is used when both the ends are CISCO !!! If you are dialing in
to
non cisco devices PPP multilink is the only option

Thanks and Regards
Arun
----- Original Message -----
From: <gladston@xxxxxxxxxx>
To: <ccielab@xxxxxxxxxxxxxx>
Sent: Friday, August 12, 2005 11:46 PM
Subject: Re: Re: config - ISDN B-Channel 2 links - up ---> Doubt


> Arun,
>
> Would you agree with Shanky?
>
> I am not sure if you stating a different point.
>
> Configuring 'dialer load-threshold..' without 'ppp multilink':
> -- two channels to the same destination
> -- two entries on the routing table
>
> On the other hand, configuring 'dialer load-threshold..' with 'ppp
multilink':
>
> -- two channels to the same destination
> -- one entry on the routing table
>
> Could you think about an example when 'dialer load-threshold' without
ppp
multilink would be used?
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

_______________________________________________________________________
Subscription information may be found at:
http://www.groupstudy.com/list/CCIELab.html

_______________________________________________________________________
Subscription information may be found at:
http://www.groupstudy.com/list/CCIELab.html