GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: FR Traffic Shaping Tc posted 11/10/2004
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Bc = CIR * Tc/1000 however there is a maximum Tc per CIR.  As CIR goes
up Tc must go down.  Byte Limit is simply Bc + Be expressed in bytes.
See the below output for more info.

Router(config-map-class)#frame-relay cir 640000                  
Router(config-map-class)#do show traffic-shape | exclude 10[2-5] 

Interface   Se0/0
       Access Target    Byte   Sustain   Excess    Interval  Increment
Adapt
VC     List   Rate      Limit  bits/int  bits/int  (ms)      (bytes)
Active
113           640000    10000  640000    0         125       10000     -

Router(config-map-class)#frame-relay cir 640008                  
Router(config-map-class)#do show traffic-shape | exclude 10[2-5] 

Interface   Se0/0
       Access Target    Byte   Sustain   Excess    Interval  Increment
Adapt
VC     List   Rate      Limit  bits/int  bits/int  (ms)      (bytes)
Active
113           640008    5040   640008    0         63        5040      -

Router(config-map-class)#frame-relay cir 1280000                 
Router(config-map-class)#do show traffic-shape | exclude 10[2-5] 

Interface   Se0/0
       Access Target    Byte   Sustain   Excess    Interval  Increment
Adapt
VC     List   Rate      Limit  bits/int  bits/int  (ms)      (bytes)
Active
113           1280000   10080  1280000   0         63        10080     -

Router(config-map-class)#frame-relay cir 1280008                 
Router(config-map-class)#do show traffic-shape | exclude 10[2-5] 

Interface   Se0/0
       Access Target    Byte   Sustain   Excess    Interval  Increment
Adapt
VC     List   Rate      Limit  bits/int  bits/int  (ms)      (bytes)
Active
113           1280008   5120   1280008   0         32        5120      -

Router(config-map-class)#frame-relay cir 2560000                 
Router(config-map-class)#do show traffic-shape | exclude 10[2-5] 

Interface   Se0/0
       Access Target    Byte   Sustain   Excess    Interval  Increment
Adapt
VC     List   Rate      Limit  bits/int  bits/int  (ms)      (bytes)
Active
113           2560000   10240  2560000   0         32        10240     -

Router(config-map-class)#frame-relay cir 2560008                 
Router(config-map-class)#do show traffic-shape | exclude 10[2-5] 

Interface   Se0/0
       Access Target    Byte   Sustain   Excess    Interval  Increment
Adapt
VC     List   Rate      Limit  bits/int  bits/int  (ms)      (bytes)
Active
113           2560008   5120   2560008   0         16        5120      -



HTH,

Brian McGahan, CCIE #8593
bmcgahan@xxxxxxxxxxxxxxxxxxxxxx 

Internetwork Expert, Inc.
http://www.InternetworkExpert.com
Toll Free: 877-224-8987 x 705
Outside US: 775-826-4344 x 705
24/7 Support: http://forum.internetworkexpert.com
Live Chat: http://www.internetworkexpert.com/chat/


> -----Original Message-----
> From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf
Of
> Georg Pauwen
> Sent: Wednesday, November 10, 2004 9:50 AM
> To: chalermchai.hoonpongsimanont@xxxxxxxxxxxxxx;
ccielab@xxxxxxxxxxxxxx
> Subject: RE: FR Traffic Shaping Tc
> 
> Hello Chalermchai,
> 
> for speeds below 650kbps, the Bc defaults to 1/8 of the configured
CIR.
> For
> speeds above 650kbps, the Bc defaults to 1/16 of the configured CIR.
> Check this link to a very excellent explanation from Internetwork
Experts
> (slide 7 talks about the various defaults for the Bc).
> 
> http://www.internetworkexpert.com/resources/01700368.htm
> 
> Regards,
> 
> Georg
> 
> >From: "Hoonpongsimanont, Chalermchai"
> ><chalermchai.hoonpongsimanont@xxxxxxxxxxxxxx>
> >Reply-To: "Hoonpongsimanont, Chalermchai"
> ><chalermchai.hoonpongsimanont@xxxxxxxxxxxxxx>
> >To: "'Group Study'" <ccielab@xxxxxxxxxxxxxx>
> >Subject: FR Traffic Shaping Tc
> >Date: Wed, 10 Nov 2004 14:23:06 +0700
> >
> >Hi all,
> >
> >I am confused with Frame Relay Traffic Shaping Tc interval. I think
> router
> >will automatically calculate Tc from configured CIR and Bc by
> >
> >Bc = CIR * Tc
> >
> >This is not working as expected on my router.
> >
> >Rack1R5#show traffic-shape serial0/0.35
> >
> >Interface   Se0/0.35
> >        Access Target    Byte   Sustain   Excess    Interval
Increment
> >Adapt
> >VC     List   Rate      Limit  bits/int  bits/int  (ms)      (bytes)
> >Active
> >503           768000    6048   96000     0         63        6048
-
> >
> >I configured target rate of 768000, Bc of 96000, therefore I expected
to
> >see
> >Tc of 96000/768000 = 1/8 second = 125 ms. But on my router, Tc is 64
ms.
> >
> >It's working fine on another subinterface.
> >
> >
> >Rack1R5#show traffic-shape serial0/0.54
> >
> >Interface   Se0/0.54
> >        Access Target    Byte   Sustain   Excess    Interval
Increment
> >Adapt
> >VC     List   Rate      Limit  bits/int  bits/int  (ms)      (bytes)
> >Active
> >504           768000    960    7680      0         10        960
-
> >
> >Could this be a software bug? I'm using 12.2(15)T14.
> >Thanks in advance,
> >
> >Cheers,
> >David
> >
> >Here's configuration.
> >
> >!
> >  class-map match-all voice
> >   match  dscp cs5
> >!
> >!
> >  policy-map voice-go-first
> >   class voice
> >    priority 256
> >   class class-default
> >    fair-queue
> >  policy-map mark-default
> >   class class-default
> >    set dscp cs1
> >!
> >!
> >interface Serial0/0
> >  no ip address
> >  encapsulation frame-relay
> >  frame-relay traffic-shaping
> >  no frame-relay inverse-arp
> >!
> >interface Serial0/0.35 point-to-point
> >  ip address 163.1.35.5 255.255.255.0
> >  ip router isis
> >  isis circuit-type level-2-only
> >  frame-relay interface-dlci 503
> >   class R3R5
> >!
> >interface Serial0/0.54 point-to-point
> >  ip address 163.1.54.5 255.255.255.0
> >  ip router isis
> >  ip pim dense-mode
> >  backup interface BRI0/0
> >  isis circuit-type level-2-only
> >  frame-relay de-group 1 504
> >  frame-relay interface-dlci 504
> >   class R4R5
> >!
> >!
> >map-class frame-relay R4R5
> >  frame-relay end-to-end keepalive mode request
> >  frame-relay cir 768000
> >  frame-relay bc 7680
> >  frame-relay be 0
> >  service-policy output voice-go-first
> >  frame-relay fragment 960
> >!
> >map-class frame-relay R3R5
> >  frame-relay cir 768000
> >  frame-relay bc 96000
> >  frame-relay be 0
> >  service-policy input mark-default
> >
>
>_______________________________________________________________________
> >Subscription information may be found at:
> >http://www.groupstudy.com/list/CCIELab.html
> 
> _________________________________________________________________
> MSN Messenger : discutez en direct avec vos amis !
> http://www.msn.fr/msger/default.asp
> 
>
_______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html