GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: FR Traffic Shaping Tc posted 11/10/2004
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Hi,

Many thanks to you. :-)

Interface   Se0/0.35
       Access Target    Byte   Sustain   Excess    Interval  Increment Adapt
VC     List   Rate      Limit  bits/int  bits/int  (ms)      (bytes)
Active
503           768000    10000  80007     0         104       9984      -  


Interface   Se0/0.35
       Access Target    Byte   Sustain   Excess    Interval  Increment Adapt
VC     List   Rate      Limit  bits/int  bits/int  (ms)      (bytes)
Active
503           768000    5000   80008     0         52        4992      -   

This is interesting. Looks like if byte limit is more than 10000, router
will divide things by two.

Cheers,
David

-----Original Message-----
From: Tiean [mailto:noktes@xxxxxxxxxxxxx] 
Sent: Wednesday, November 10, 2004 9:19 PM
To: Hoonpongsimanont, Chalermchai; Nico van Niekerk; 'Group Study'
Subject: Re: FR Traffic Shaping Tc

Can you try this? Change Bc to 80007 and 80008. And compare the Byte limit
output. I guess that as long as the byte limit is not more than 10000 so it
uses your parameter to calculate Tc.  But I don't know why either.

Tiean



----- Original Message ----- 
From: "Hoonpongsimanont, Chalermchai"
<chalermchai.hoonpongsimanont@xxxxxxxxxxxxxx>
To: "Nico van Niekerk" <nico@xxxxxxxxxxxxxxxx>; "'Group Study'"
<ccielab@xxxxxxxxxxxxxx>
Sent: Wednesday, November 10, 2004 8:50 AM
Subject: RE: FR Traffic Shaping Tc


> Nothing has changed. I tried fragment 1500, and 960.
>
> -----Original Message-----
> From: Nico van Niekerk [mailto:nico@xxxxxxxxxxxxxxxx]
> Sent: Wednesday, November 10, 2004 8:40 PM
> To: Hoonpongsimanont, Chalermchai; 'Group Study'
> Subject: RE: FR Traffic Shaping Tc
>
> What happens if you put a "frame-relay fragment" under the R3R5 map-class?
>
> > -----Original Message-----
> > From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx]On Behalf Of
> > Nico van Niekerk
> > Sent: Thursday, 11 November 2004 12:22 AM
> > To: Hoonpongsimanont, Chalermchai; 'Group Study'
> > Subject: RE: FR Traffic Shaping Tc
> >
> >
> > I don't know why your Byte Limit is 6048, but if you take 6048*8 /
768000
> > you get the Bc of 63ms.
> >
> > > -----Original Message-----
> > > From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx]On Behalf Of
> > > Hoonpongsimanont, Chalermchai
> > > Sent: Wednesday, 10 November 2004 6:23 PM
> > > To: 'Group Study'
> > > Subject: FR Traffic Shaping Tc
> > >
> > >
> > > Hi all,
> > >
> > > I am confused with Frame Relay Traffic Shaping Tc interval. I
> > think router
> > > will automatically calculate Tc from configured CIR and Bc by
> > >
> > > Bc = CIR * Tc
> > >
> > > This is not working as expected on my router.
> > >
> > > Rack1R5#show traffic-shape serial0/0.35
> > >
> > > Interface   Se0/0.35
> > >        Access Target    Byte   Sustain   Excess    Interval
> > > Increment Adapt
> > > VC     List   Rate      Limit  bits/int  bits/int  (ms)      (bytes)
> > > Active
> > > 503           768000    6048   96000     0         63        6048
> > >      -
> > >
> > > I configured target rate of 768000, Bc of 96000, therefore I
> > > expected to see
> > > Tc of 96000/768000 = 1/8 second = 125 ms. But on my router, Tc is 64
ms.
> > >
> > > It's working fine on another subinterface.
> > >
> > >
> > > Rack1R5#show traffic-shape serial0/0.54
> > >
> > > Interface   Se0/0.54
> > >        Access Target    Byte   Sustain   Excess    Interval
> > > Increment Adapt
> > > VC     List   Rate      Limit  bits/int  bits/int  (ms)      (bytes)
> > > Active
> > > 504           768000    960    7680      0         10
 960       -
> > >
> > > Could this be a software bug? I'm using 12.2(15)T14.
> > > Thanks in advance,
> > >
> > > Cheers,
> > > David
> > >
> > > Here's configuration.
> > >
> > > !
> > >  class-map match-all voice
> > >   match  dscp cs5
> > > !
> > > !
> > >  policy-map voice-go-first
> > >   class voice
> > >    priority 256
> > >   class class-default
> > >    fair-queue
> > >  policy-map mark-default
> > >   class class-default
> > >    set dscp cs1
> > > !
> > > !
> > > interface Serial0/0
> > >  no ip address
> > >  encapsulation frame-relay
> > >  frame-relay traffic-shaping
> > >  no frame-relay inverse-arp
> > > !
> > > interface Serial0/0.35 point-to-point
> > >  ip address 163.1.35.5 255.255.255.0
> > >  ip router isis
> > >  isis circuit-type level-2-only
> > >  frame-relay interface-dlci 503
> > >   class R3R5
> > > !
> > > interface Serial0/0.54 point-to-point
> > >  ip address 163.1.54.5 255.255.255.0
> > >  ip router isis
> > >  ip pim dense-mode
> > >  backup interface BRI0/0
> > >  isis circuit-type level-2-only
> > >  frame-relay de-group 1 504
> > >  frame-relay interface-dlci 504
> > >   class R4R5
> > > !
> > > !
> > > map-class frame-relay R4R5
> > >  frame-relay end-to-end keepalive mode request
> > >  frame-relay cir 768000
> > >  frame-relay bc 7680
> > >  frame-relay be 0
> > >  service-policy output voice-go-first
> > >  frame-relay fragment 960
> > > !
> > > map-class frame-relay R3R5
> > >  frame-relay cir 768000
> > >  frame-relay bc 96000
> > >  frame-relay be 0
> > >  service-policy input mark-default
> > >
> > >
_______________________________________________________________________
> > > Subscription information may be found at:
> > > http://www.groupstudy.com/list/CCIELab.html
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html