GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: dhcp and address negotiation over an isdn link posted 11/05/2004
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


	The dhcp proxy command isn't required.  DHCP relay is enabled by
the ip dhcp-server command.

R3--34.0.0.0/8--R4--45.0.0.0/8--R5

R3 is the DHCP server, R5 is the DHCP client

R3#
ip dhcp excluded-address 45.0.0.1 45.0.0.4
!
ip dhcp pool POOL
   network 45.0.0.0 255.0.0.0
!
ip route 0.0.0.0 0.0.0.0 34.0.0.4

R4#
ip dhcp-server 34.0.0.3
!
interface BRI0/0
 ip address 45.0.0.4 255.0.0.0
 encapsulation ppp
 dialer map ip 45.0.0.5 broadcast 5272015
 isdn switch-type basic-ni
 isdn spid1 5272014
 peer default ip address dhcp

R5#
interface BRI0/0
 ip address negotiated
 encapsulation ppp
 dialer map ip 45.0.0.4 broadcast 5272014
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 5272015
!
dialer-list 1 protocol ip permit
ip route 0.0.0.0 0.0.0.0 BRI0/0 45.0.0.4

Rack1R5#show ip int brief | include (Method|BRI0/0 )
Interface                  IP-Address      OK? Method Status
Protocol
BRI0/0                     unassigned      YES IPCP   up
up      
Rack1R5#debug ppp negotiation
PPP protocol negotiation debugging is on
Rack1R5#ping 45.0.0.4 repeat 1

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 45.0.0.4, timeout is 2 seconds:
.
Success rate is 0 percent (0/1)
Rack1R5#
*Mar  1 21:13:16.006: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state
to up
*Mar  1 21:13:16.010: BR0/0:1 PPP: Using dialer call direction
*Mar  1 21:13:16.010: BR0/0:1 PPP: Treating connection as a callout
*Mar  1 21:13:16.010: BR0/0:1 PPP: Phase is ESTABLISHING, Active Open
*Mar  1 21:13:16.014: BR0/0:1 PPP: No remote authentication for call-out
*Mar  1 21:13:16.014: BR0/0:1 LCP: O CONFREQ [Closed] id 4 len 10
*Mar  1 21:13:16.014: BR0/0:1 LCP:    MagicNumber 0x0B655E46
(0x05060B655E46)
*Mar  1 21:13:16.026: BR0/0:1 LCP: I CONFREQ [REQsent] id 3 len 10
*Mar  1 21:13:16.026: BR0/0:1 LCP:    MagicNumber 0x5512B12A
(0x05065512B12A)
*Mar  1 21:13:16.026: BR0/0:1 LCP: O CONFACK [REQsent] id 3 len 10
*Mar  1 21:13:16.026: BR0/0:1 LCP:    MagicNumber 0x5512B12A
(0x05065512B12A)
*Mar  1 21:13:16.026: BR0/0:1 LCP: I CONFACK [ACKsent] id 4 len 10
*Mar  1 21:13:16.030: BR0/0:1 LCP:    MagicNumber 0x0B655E46
(0x05060B655E46)
*Mar  1 21:13:16.030: BR0/0:1 LCP: State is Open
*Mar  1 21:13:16.030: BR0/0:1 PPP: Phase is FORWARDING, Attempting
Forward
*Mar  1 21:13:16.034: BR0/0:1 PPP: Phase is ESTABLISHING, Finish LCP
*Mar  1 21:13:16.034: BR0/0:1 PPP: Phase is UP
*Mar  1 21:13:16.034: BR0/0:1 IPCP: O CONFREQ [Closed] id 1 len 10
*Mar  1 21:13:16.038: BR0/0:1 IPCP:    Address 0.0.0.0 (0x030600000000)
*Mar  1 21:13:16.038: BR0/0:1 CDPCP: O CONFREQ [Closed] id 1 len 4
*Mar  1 21:13:16.038: BR0/0:1 PPP: Process pending packets
*Mar  1 21:13:16.042: BR0/0:1 IPCP: I CONFREQ [REQsent] id 1 len 10
*Mar  1 21:13:16.042: BR0/0:1 IPCP:    Address 45.0.0.4 (0x03062D000004)
*Mar  1 21:13:16.046: BR0/0:1 IPCP: O CONFACK [REQsent] id 1 len 10
*Mar  1 21:13:16.046: BR0/0:1 IPCP:    Address 45.0.0.4 (0x03062D000004)
*Mar  1 21:13:16.046: BR0/0:1 CDPCP: I CONFREQ [REQsent] id 1 len 4
*Mar  1 21:13:16.050: BR0/0:1 CDPCP: O CONFACK [REQsent] id 1 len 4
*Mar  1 21:13:16.050: BR0/0:1 CDPCP: I CONFACK [ACKsent] id 1 len 4
*Mar  1 21:13:16.050: BR0/0:1 CDPCP: State is Open
*Mar  1 21:13:16.050: BR0/0:1 IPCP: I CONFNAK [ACKsent] id 1 len 10
*Mar  1 21:13:16.050: BR0/0:1 IPCP:    Address 45.0.0.5 (0x03062D000005)
*Mar  1 21:13:16.050: BR0/0:1 IPCP: O CONFREQ [ACKsent] id 2 len 10
*Mar  1 21:13:16.054: BR0/0:1 IPCP:    Address 45.0.0.5 (0x03062D000005)
*Mar  1 21:13:16.062: BR0/0:1 IPCP: I CONFACK [ACKsent] id 2 len 10
*Mar  1 21:13:16.062: BR0/0:1 IPCP:    Address 45.0.0.5 (0x03062D000005)
*Mar  1 21:13:16.062: BR0/0:1 IPCP: State is Open
*Mar  1 21:13:16.066: BR0/0 IPCP: Install negotiated IP interface
address 45.0.0.5
*Mar  1 21:13:16.070: BR0/0 IPCP: Install route to 45.0.0.4
*Mar  1 21:13:16.070: BR0/0:1 IPCP: Add link info for cef entry 45.0.0.4
*Mar  1 21:13:17.034: %LINEPROTO-5-UPDOWN: Line protocol on Interface
BRI0/0:1, changed state to up

Rack1R5#show ip int brief | include (Method|BRI0/0 )
*Mar  1 21:13:22.006: %ISDN-6-CONNECT: Interface BRI0/0:1 is now
connected to 5272014 
Rack1R5#show ip int brief | include (Method|BRI0/0 )
Interface                  IP-Address      OK? Method Status
Protocol
BRI0/0                     45.0.0.5        YES IPCP   up
up      
Rack1R5#ping 45.0.0.4                               

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 45.0.0.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/36/52 ms


HTH,

Brian McGahan, CCIE #8593
bmcgahan@xxxxxxxxxxxxxxxxxxxxxx 

Internetwork Expert, Inc.
http://www.InternetworkExpert.com
Toll Free: 877-224-8987 x 705
Outside US: 775-826-4344 x 705
24/7 Support: http://forum.internetworkexpert.com
Live Chat: http://www.internetworkexpert.com/chat/


> -----Original Message-----
> From: Edwards, Andrew M [mailto:andrew.m.edwards@xxxxxxxxxx]
> Sent: Friday, November 05, 2004 4:25 PM
> To: Brian McGahan
> Subject: RE: dhcp and address negotiation over an isdn link
> 
> Not personally.  But... I do know that I need too.  Why?  Do you have
> any insight into our dilemna?
> 
> -----Original Message-----
> From: Brian McGahan [mailto:bmcgahan@xxxxxxxxxxxxxxxxxxxxxx]
> Sent: Friday, November 05, 2004 2:16 PM
> To: Edwards, Andrew M; ccie2be; ccielab@xxxxxxxxxxxxxx
> Subject: RE: dhcp and address negotiation over an isdn link
> 
> 
> Andrew,
> 
> 	Have you tried this config? :)
> 
> Brian McGahan, CCIE #8593
> bmcgahan@xxxxxxxxxxxxxxxxxxxxxx
> 
> Internetwork Expert, Inc.
> http://www.InternetworkExpert.com
> Toll Free: 877-224-8987 x 705
> Outside US: 775-826-4344 x 705
> 24/7 Support: http://forum.internetworkexpert.com
> Live Chat: http://www.internetworkexpert.com/chat/
> 
> 
> > -----Original Message-----
> > From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf
> Of
> > Edwards, Andrew M
> > Sent: Friday, November 05, 2004 3:14 PM
> > To: ccie2be; ccielab@xxxxxxxxxxxxxx
> > Subject: RE: dhcp and address negotiation over an isdn link
> >
> > Well, I guess its kind of caveat emptor...
> >
> > But, I think between the two of us we've nailed this one.
> >
> > With R4 being negotiate, R5 has to be setup for both ip dhcp-server
> and
> > ip dhcp-proxy.
> >
> > If R4 were an ip add dhcp-client though... R5 would need
> helper-address.
> >
> > Of course, its blind leading the blind here... But I do know a bit
> about
> > DHCP. 8)
> >
> >
> > -----Original Message-----
> > From: ccie2be [mailto:ccie2be@xxxxxxxxxx]
> > Sent: Friday, November 05, 2004 12:16 PM
> > To: Edwards, Andrew M; ccielab@xxxxxxxxxxxxxx
> > Subject: Re: dhcp and address negotiation over an isdn link
> >
> >
> > Hi Andrew,
> >
> > I was thinking about what you said below about using the command, ip
> > address-pool dhcp-proxy-client.  And, it made me wonder if I was
> > thinking about this all wrong.
> >
> > Initially, I was thinking that once the link between R4 and R5 came
> up,
> > R4 because it has ip address negotiated configured on it becomes a
> dhcp
> > client and therefore would send out a dhcp request.
> >
> > But, maybe this is wrong because R4 is connecting to R5 via PPP and
> > using PPP to negotiate an ip address.  In other words, R4 isn't a
> really
> > dhcp client so it doesn't send out a dhcp request for an address.
> >
> > But, now, looking at R5's configuration.  It has the interface
> command,
> > peer default ip address dhcp, on it's Dialer interface which means
it
> > should use dhcp to get and assign an ip address to R4 when it gets a
> > dhcp request from R4.  But, because R4 isn't really (or rather R4
> > doesn't consider itself) a dhcp client, R4 never sends a dhcp
request.
> >
> > Therefore, for R5 to get an ip address for R4, it must send a dhcp
> > request on R4's behalf to the dhcp server and that's why the global
> > command, ip address-pool dhcp-proxy-client, is needed.
> >
> > Realize that I'm completely making this up, but it seems plausible.
> Am
> > I getting warm?
> >
> > Thanks, Tim
> > ----- Original Message -----
> > From: "Edwards, Andrew M" <andrew.m.edwards@xxxxxxxxxx>
> > To: "ccie2be" <ccie2be@xxxxxxxxxx>; <ccielab@xxxxxxxxxxxxxx>
> > Sent: Friday, November 05, 2004 1:54 PM
> > Subject: RE: IEWB lab 13 dhcp & isdn task 4.3 and task 12.1
> >
> >
> > My thoughts....
> >
> > On R5, you need ip helper-address to R1.
> >
> > R5 is connecting to R4 on the callback but the DHCP lease is not
being
> 
> > negotiated.  R5 see's the R4 request but it can't do anything with
> it...
> >
> > So, get R5 to encapsulate (unicast) and forward the local link
> broadcast
> > from R4 for a DHCP Lease Request.  Once you see NCP on the BRI link
> > negotiate the Network Control Protocol address received from R1 you
> will
> > get connectivity at layer 3 between r4 and r5.
> >
> > Alternatively, if you want to specify the IP address of the DHCP
> server,
> > you will need to use the global ip address-pool dhcp-proxy-client
> > command to specify that R5 should proxy DHCP requests on behalf of
> > locally connected clients.  Two ways to do the same thing.... One
> being
> > more efficient (I think the later).
> >
> > HTH,
> >
> > andy
> >
> > -----Original Message-----
> > From: ccie2be [mailto:ccie2be@xxxxxxxxxx]
> > Sent: Friday, November 05, 2004 6:57 AM
> > To: Group Study
> > Subject: Fw: IEWB lab 13 dhcp & isdn task 4.3 and task 12.1
> >
> >
> > Hey guys,
> >
> > In the isdn portion of this task, I needed to configure dialer
> profiles
> > on both R4 and R5, have R5 call R4 and then make R4 hangup and
> callback
> > R5.  I got this part to work.  To confirm that this was working I
> used,
> > isdn test call int bri 0/0 5272034 and enabled debug dialer on R4.
> When
> > I reviewed the debug logs, I could see the call from R5 connect,
then
> > disconnect and then R4 callback R5.
> >
> >
> > However, I also needed to configure R4 to get it's dialer's
interface
> ip
> > address from a dhcp server directly connected to R5.
> >
> > I also enabled debug dhcp on R4 and R5, but I can't tell from the
> debug
> > out what's really going on. So, I don't know if R4 ever really got
an
> ip
> > address.
> >
> > I've configured R4 and R5 as shown is the SG, but the dhcp part
> doesn't
> > seem to working, although I'm not 100% sure.  Once the link was up
> after
> > R4 called back R5, I did several pings but those never were
> successful.
> >
> > I was struggling with this for hours but never got pings to work
> across
> > the isdn link, so I'm hoping someone can help me understand what's
> going
> > on.
> >
> > Here's some output from deb dhcp on R5:
> >
> > *Mar  1 07:08:42.478:    DHCP Lease server: 0.0.0.0, state: 1
> Selecting
> > *Mar  1 07:08:42.478:    DHCP transaction id: FCC10C
> > *Mar  1 07:08:42.478:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0
> > secs
> > *Mar  1 07:08:42.478:    Next timer fires after: 00:00:03
> > *Mar  1 07:08:42.478:    Retry count: 2   Client-ID:
> > cisco-139.3.45.5-BRI0/0:1
> > *Mar  1 07:08:42.478: DHCP: SDiscover: sending 285 byte length DHCP
> > packet *Mar  1 07:08:42.478: DHCP: SDiscover 285 bytes *Mar  1
> > 07:08:53.078: DHCP: QScan: Purging entry *Mar  1 07:08:53.078: DHCP:
> > deleting entry 622AE8CC 0.0.0.0 from list *Mar  1 07:08:53.078: Temp
> IP
> > addr: 0.0.0.0  for peer on Interface: unknown *Mar  1 07:08:53.078:
> Temp
> > sub net mask: 0.0.0.0
> > *Mar  1 07:08:53.078:    DHCP Lease server: 0.0.0.0, state: 8
Purging
> > *Mar  1 07:08:53.078:    DHCP transaction id: FCC107
> > *Mar  1 07:08:53.078:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0
> > secs
> > *Mar  1 07:08:53.078:    No timer running
> > *Mar  1 07:08:53.078:    Retry count: 0   Client-ID:
> > *Mar  1 07:08:57.178: DHCP: QScan: Purging entry
> > *Mar  1 07:08:57.178: DHCP: deleting entry 629D70C0 0.0.0.0 from
list
> > *Mar  1 07:08:57.178: Temp IP addr: 0.0.0.0  for peer on Interface:
> > unknown *Mar  1 07:08:57.178: Temp  sub net mask: 0.0.0.0
> > *Mar  1 07:08:57.178:    DHCP Lease server: 0.0.0.0, state: 8
Purging
> > *Mar  1 07:08:57.178:    DHCP transaction id: FCC108
> > *Mar  1 07:08:57.178:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0
> > secs
> > *Mar  1 07:08:57.178:    No timer running
> > *Mar  1 07:08:57.178:    Retry count: 0   Client-ID:
> > *Mar  1 07:09:01.278: DHCP: QScan: Purging entry
> > *Mar  1 07:09:01.278: DHCP: deleting entry 622AE168 0.0.0.0 from
list
> > *Mar  1 07:09:01.278: Temp IP addr: 0.0.0.0  for peer on Interface:
> > unknown *Mar  1 07:09:01.278: Temp  sub net mask: 0.0.0.0
> > *Mar  1 07:09:01.278:    DHCP Lease server: 0.0.0.0, state: 8
Purging
> > *Mar  1 07:09:01.278:    DHCP transaction id: FCC109
> > *Mar  1 07:09:01.278:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0
> > secs
> > *Mar  1 07:09:01.278:    No timer running
> > *Mar  1 07:09:01.278:    Retry count: 0   Client-ID:
> > *Mar  1 07:09:05.378: DHCP: QScan: Purging entry
> > *Mar  1 07:09:05.378: DHCP: deleting entry 622A94C8 0.0.0.0 from
list
> > *Mar  1 07:09:05.378: Temp IP addr: 0.0.0.0  for peer on Interface:
> > unknown *Mar  1 07:09:05.378: Temp  sub net mask: 0.0.0.0
> > *Mar  1 07:09:05.378:    DHCP Lease server: 0.0.0.0, state: 8
Purging
> > *Mar  1 07:09:05.378:    DHCP transaction id: FCC10A
> > *Mar  1 07:09:05.378:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0
> > secs
> > *Mar  1 07:09:05.378:    No timer running
> > *Mar  1 07:09:05.378:    No timer running
> > *Mar  1 07:09:09.478: DHCP: QScan: Purging entry
> > *Mar  1 07:09:09.478: DHCP: deleting entry 629D34B0 0.0.0.0 from
list
> > *Mar  1 07:09:09.478: Temp IP addr: 0.0.0.0  for peer on Interface:
> > unknown *Mar  1 07:09:09.478: Temp  sub net mask: 0.0.0.0
> > *Mar  1 07:09:09.478:    DHCP Lease server: 0.0.0.0, state: 8
Purging
> > *Mar  1 07:09:09.478:    DHCP transaction id: FCC10B
> > *Mar  1 07:09:09.478:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0
> > secs
> > *Mar  1 07:09:09.478:    No timer running
> > *Mar  1 07:09:09.478:    Retry count: 0   Client-ID:
> > *Mar  1 07:09:13.578: DHCP: QScan: Purging entry
> > *Mar  1 07:09:13.578: DHCP: deleting entry 629D3684 0.0.0.0 from
list
> > *Mar  1 07:09:13.578: Temp IP addr: 0.0.0.0  for peer on Interface:
> > BRI0/0:1 *Mar  1 07:09:13.578: Temp  sub net mask: 0.0.0.0
> > *Mar  1 07:09:13.578:    DHCP Lease server: 0.0.0.0, state: 8
Purging
> > *Mar  1 07:09:13.578:    DHCP transaction id: FCC10C
> > *Mar  1 07:09:13.578:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0
> > secs
> > *Mar  1 07:09:13.578:    No timer running
> > *Mar  1 07:09:13.578:    Retry count: 0   Client-ID:
> > cisco-139.3.45.5-BRI0/0:1
> > *Mar  1 07:10:18.866: %ISDN-6-DISCONNECT: Interface BRI0/0:1
> > disconnected from 5272034 , call lasted 120 seconds *Mar  1
> > 07:10:18.918: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to
> down
> > *Mar  1 07:10:18.922: %DIALER-6-UNBIND: Interface BR0/0:1 unbound
from
> 
> > profile D i1
> >
>
************************************************************************
> > *****
> > ********************
> >
> > I also did a deb dhcp on R1, the dhcp server, but got nothing at
all.
> >
> > Here's R4's config. R4 is the dhcp client and is suppose to get an
ip
> > address assigned to it dialer interface.
> >
> >
> > interface Dialer1
> >  ip address negotiated
> >  encapsulation ppp
> >  dialer pool 1
> >  dialer string 5272035
> >  dialer caller 5272035 callback
> >
> > Here's R5's config:
> >
> > ip dhcp-server 139.3.15.1
> >
> > interface Dialer1
> >  ip address 139.3.45.5 255.255.255.0
> >  encapsulation ppp
> >  dialer pool 1
> >  dialer string 5272034
> >  dialer-group 1
> >  peer default ip address dhcp
> >
> > Here's R1's config. R1 is the dhcp server.
> >
> > ip dhcp excluded-address 139.3.45.5 139.3.45.255
> > ip dhcp excluded-address 139.3.45.0 139.3.45.3
> > !
> > ip dhcp pool FOR-R4
> >    network 139.3.45.0 255.255.255.0
> >
> > Here's the topology:
> >
> > R4 --- isdn ---- R5 --- f/r --- R1
> >
> > I'm not running any routing protocols, but R5 and R1 can ping each
> > other.
> >
> > R5 can call R4.  When it does, R4 takes the call, hangup, and calls
R5
> 
> > back. But, once the call is connected, R4 and R5 still can't ping
each
> 
> > other.  A debug on R5 shows the pings are "unroutable".  I don't
know
> > why since, of course, R4 and R5 are directly connected via the isdn
> > link.
> >
> > Can anybody help me understand what's going on here with dhcp and
the
> > ping problem?
> >
> > Thanks for any insight.
> >
> > Tim
> >
> >
>
_______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> >
>
_______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html