GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: more dialer watch woes posted 08/26/2004
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Hmm, in this case it would not be connected, it would be ospf intraarea.
But serial route will not be installed because that would be inter area.
(Your remote loopback is in the same area as your isdn link!)
Move the remote loopback into some other ospf area and you should be fine...

Larry Metzger wrote:

Here's the configuration I used (different IP addresses, same idea)
**
Before adding dialer map without link failure .....
r2#sh ip route
     170.1.0.0/16 is variably subnetted, 4 subnets, 4 masks
C       170.1.150.0/27 is directly connected, Serial0.1
C       170.1.200.0/30 is directly connected, BRI0
O IA    170.1.5.5/32 [110/65] via 170.1.150.5, 00:00:54, Serial0.1 <====
O IA    170.1.100.0/24 [110/74] via 170.1.150.5, 00:00:54, Serial0.1
--------------
r5#sh ip route
     170.1.0.0/16 is variably subnetted, 5 subnets, 4 masks
C       170.1.150.0/27 is directly connected, Serial0.1
C       170.1.200.1/32 is directly connected, BRI0
C       170.1.200.0/30 is directly connected, BRI0
C       170.1.5.0/24 is directly connected, Loopback0
C       170.1.100.0/24 is directly connected, Ethernet0
--------------

Before adding dialer map with link failure .....

r2#sh ip route
     170.1.0.0/16 is variably subnetted, 3 subnets, 3 masks
C       170.1.200.0/30 is directly connected, BRI0
C       170.1.5.5/32 is directly connected, BRI0  <====
O IA    170.1.100.0/24 [110/1572] via 170.1.200.2, 00:04:10, BRI0
--------------

Router 2 Configuration
hostname r2
!
username r5 password 0 ipexpert
!
interface Serial0
 no ip address
 encapsulation frame-relay
!
interface Serial0.1 point-to-point
 ip address 170.1.150.2 255.255.255.224
 frame-relay interface-dlci 105
!
interface BRI0
 ip address 170.1.200.1 255.255.255.252
 encapsulation ppp
 dialer map ip 170.1.5.5 name r5 broadcast **11
 dialer map ip 170.1.200.2 name r5 broadcast **11
 dialer watch-group 1
 dialer-group 1
 isdn switch-type basic-net3
 ppp authentication chap
!
router ospf 100
 log-adjacency-changes
 network 170.1.150.0 0.0.0.31 area 345
 network 170.1.200.0 0.0.0.3 area 45
!
dialer watch-list 1 ip 170.1.5.5 255.255.255.255
dialer-list 1 protocol ip deny
!
end
-------------------
Router 5 Configuration
hostname r5
!
username r2 password 0 ipexpert
!
interface Loopback0
 ip address 170.1.5.5 255.255.255.0
!
interface Ethernet0
 ip address 170.1.100.5 255.255.255.0
!
interface Serial0
 no ip address
 encapsulation frame-relay
!
interface Serial0.1 point-to-point
 ip address 170.1.150.5 255.255.255.224
 frame-relay interface-dlci 501
!
interface BRI0
 ip address 170.1.200.2 255.255.255.252
 encapsulation ppp
 dialer map ip 170.1.200.1 name r2 broadcast
 dialer-group 1
 isdn switch-type basic-net3
 ppp authentication chap
!
router ospf 100
 log-adjacency-changes
 network 170.1.5.5 0.0.0.0 area 45
 network 170.1.100.0 0.0.0.255 area 0
 network 170.1.150.0 0.0.0.31 area 345
 network 170.1.200.0 0.0.0.3 area 45
!
dialer-list 1 protocol ip deny
!
end
-----------------
************************************
************************************
On R2 add to BRI0 interface
dialer map ip 170.1.5.0 name r5 broadcast **11

After adding dialer map with link failure
r2#sh ip route
     170.1.0.0/16 is variably subnetted, 3 subnets, 3 masks
C       170.1.200.0/30 is directly connected, BRI0
C       170.1.5.0/32 is directly connected, BRI0  <=======
O IA    170.1.100.0/24 [110/1572] via 170.1.200.2, 00:00:08, BRI0
************************************

-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of
Ronnie Higginbotham
Sent: Tuesday, August 24, 2004 9:35 AM
Cc: ccielab@xxxxxxxxxxxxxx
Subject: Re: more dialer watch woes

Can you post your configs and routing tables. Host and remote router
----- Original Message ----- From: "Larry Metzger" <larrymetzger@xxxxxxxxxxxxx>
To: "'Carlos G Mendioroz'" <tron@xxxxxxxxxxx>; "'marc van hoof'"
<mvh@xxxxxxxxxxxxxxx>
Cc: <ccielab@xxxxxxxxxxxxxx>
Sent: Tuesday, August 24, 2004 10:20 AM
Subject: RE: more dialer watch woes




I worked on this and found if you put a second dialer map statement in
the system will work.
Dialer map ip 150.4.3.0 name remote-router broadcast 5555555

The 150.4.3.0/32 route comes in as connected and allows everything to
work correctly.

Larry
-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf

Of


Carlos G Mendioroz
Sent: Tuesday, August 24, 2004 4:49 AM
To: marc van hoof
Cc: ccielab@xxxxxxxxxxxxxx
Subject: Re: more dialer watch woes

Connected because it's in your BRI network ?
Why are you using that IP then, and not a remote loopback that will

not


have this problem ?

marc van hoof wrote:


Dialer watch doesn't like me very much..

Here's the current situation

R4 is watching a /32 route that it is receiving via ospf.



Dialer watch-list 1 ip 150.4.3.3

Int bri 0/0

Dialer watch-group 1

So as a result of this, I need to have that route in a dialer map

statement


Int bri 0/0

Dialer map ip 150.4.3.3 name remote-router broadcast 5555555

So when the route is up, everything is going well, and when it fails

the


dialer watch kicks in and connects the isdn circuit.

But then I get a connected host route via the bri interface:

Rack4R4#show ip route 150.4.3.3

Routing entry for 150.4.3.3/32

Known via "connected", distance 0, metric 0 (connected, via

interface)


 Routing Descriptor Blocks:
 * directly connected, via BRI0/0
     Route metric is 0, traffic share count is 1

Rack4R4#

So when the ospf route reappears, it never makes it into the route

table as


there is a lower administrative distance route in there already.
Consequently, the dialer watch service never realizes the primary is

back


up.

Any help appreciated !!

-marc.



_______________________________________________________________________

Please help support GroupStudy by purchasing your study materials

from:


http://shop.groupstudy.com

Subscription information may be found at:
http://www.groupstudy.com/list/CCIELab.html


-- Carlos G Mendioroz <tron@xxxxxxxxxxx> LW7 EQI Argentina



_______________________________________________________________________


Please help support GroupStudy by purchasing your study materials

from:


http://shop.groupstudy.com

Subscription information may be found at:
http://www.groupstudy.com/list/CCIELab.html



_______________________________________________________________________


Please help support GroupStudy by purchasing your study materials

from:


http://shop.groupstudy.com

Subscription information may be found at:
http://www.groupstudy.com/list/CCIELab.html


_______________________________________________________________________
Please help support GroupStudy by purchasing your study materials from:
http://shop.groupstudy.com

Subscription information may be found at: http://www.groupstudy.com/list/CCIELab.html

_______________________________________________________________________
Please help support GroupStudy by purchasing your study materials from:
http://shop.groupstudy.com

Subscription information may be found at: http://www.groupstudy.com/list/CCIELab.html


-- Carlos G Mendioroz <tron@xxxxxxxxxxx> LW7 EQI Argentina