GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: Routers going crazy (ISIS??)-IE11-5.21 posted 06/13/2004
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Yups somehow that's what is happening. With a debug I can see that the
router is just processing the clns packets at FR level all the time.  So
much so that a "Undebug" command does not work on the console and I have
to telnet back in the router and stop the debug.
And I just got a confirmation that this is happening on 2600's as well
with the specified isis timers.

Smiles,
Mohit. 

-----Original Message-----
From: Joe Chang [mailto:changjoe@xxxxxxxxxxxxx] 
Sent: Sunday, June 13, 2004 5:55 PM
To: Sharma, Mohit; MMoniz; Ty; Ccielab@xxxxxxxxxxxxxx
Subject: Re: Routers going crazy (ISIS??)-IE11-5.21

The isis hello intervals are in the range of seconds. Should that
interfere with icmp?

----- Original Message -----
From: "Sharma, Mohit" <mohit.sharma@xxxxxx>
To: "MMoniz" <ccie2002@xxxxxxxxxxxxxxx>; "Joe Chang"
<changjoe@xxxxxxxxxxxxx>; "Ty" <tycampbell@xxxxxxxxxxx>;
"Ccielab@xxxxxxxxxxxxxx" <ccielab@xxxxxxxxxxxxxx>
Sent: Sunday, June 13, 2004 6:44 AM
Subject: RE: Routers going crazy (ISIS??)-IE11-5.21


Hi All,

Thanx for your replies.

I found out that this problem has something to do with the aggressive
isis hello interval and multipliers. This was due to a task from IE
workbook and that's why the timers had to be set that way. BUT after
some time the routers were just busy sending out the clns packets (as
seen from the debug) and really delaying the IP ICMP packets.

I took these commands out of the interface and the routers worked fine.
I put them back and the rtd jumped to double and became very slow. I did
wait for them to go down again though.

I have only 7500's and 2500's in my lab. So not sure if this behavior
could occur on 2600's also.

If so then GOD save us in the exam.

Smiles,
Mohit.
-----Original Message-----
From: MMoniz [mailto:ccie2002@xxxxxxxxxxxxxxx]
Sent: Saturday, June 12, 2004 11:46 PM
To: Joe Chang; Ty; Sharma, Mohit; Ccielab@xxxxxxxxxxxxxx
Subject: RE: Routers going crazy (ISIS??)

hmmmm...is it just ICMP traffic that doesn't work or any IP? Try to
telnet to one of the spokes and debug ip packet.
What does the command sho isis top show?

-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx]On Behalf Of
Joe Chang
Sent: Saturday, June 12, 2004 4:25 PM
To: Ty; Sharma, Mohit; Ccielab@xxxxxxxxxxxxxx
Subject: Re: Routers going crazy (ISIS??)


Ah, sorry Ty.

----- Original Message -----
From: "Ty" <tycampbell@xxxxxxxxxxx>
To: "Joe Chang" <changjoe@xxxxxxxxxxxxx>; "Sharma, Mohit"
<mohit.sharma@xxxxxx>; "Ccielab@xxxxxxxxxxxxxx" <ccielab@xxxxxxxxxxxxxx>
Sent: Saturday, June 12, 2004 2:58 PM
Subject: Re: Routers going crazy (ISIS??)


> I know the AFI doesn't have to be the same..I just wanted him to try
> using the same AFI to see if this does change the result.
> ----- Original Message -----
> From: "Joe Chang" <changjoe@xxxxxxxxxxxxx>
> To: "Ty" <tycampbell@xxxxxxxxxxx>; "Sharma, Mohit"
> <mohit.sharma@xxxxxx>; "Ccielab@xxxxxxxxxxxxxx"
> <ccielab@xxxxxxxxxxxxxx>
> Sent: Saturday, June 12, 2004 1:16 PM
> Subject: Re: Routers going crazy (ISIS??)
>
>
> > Even if the AFIs are different, that should not affect connectivity
> (whether
> > that be CLNS or IP). AFI's don't identify subnets, but the router
itself.
> > Routers of different AFI's should be able to participate on the same
> subnet,
> > else there can be no L1-L2 links.
> >
> > ----- Original Message -----
> > From: "Ty" <tycampbell@xxxxxxxxxxx>
> > To: "Sharma, Mohit" <mohit.sharma@xxxxxx>; "Ccielab@xxxxxxxxxxxxxx"
> > <ccielab@xxxxxxxxxxxxxx>
> > Sent: Saturday, June 12, 2004 2:09 PM
> > Subject: Re: Routers going crazy (ISIS??)
> >
> >
> > > make your AFI in the NSAP the same...typically it is 47 or 49
> > >
> > > ie..i changed the AFI in your config below
> > >
> > > you may wany to make the system id 6 bytes
> > >
> > > typically i use
> > > AFI    Area       -------System ID---------         N Selector
> > > XX.   XXXX.   XXXX.   XXXX.  XXXX.         XX
> > >
> > > first 2 X's are AFI.
> > > next 4 is for area id
> > > next 12 are system id - must be unique to each system - last 2 are

> > > N selector..I typically leave these at 00
> > >
> > > here is how I usually do a net for ISIS
> > >
> > > int s0
> > > ip add 10.10.50.2 255.255.255.0
> > > ip router isis
> > >
> > > router isis
> > > net 49.0001.0100.1005.0002.00
> > >
> > > I typically transfor the IP address to equal 6 bytes ex  -
> > >
> > > 10.10.10.50.2 = 010 010 050 002 = 0100.1005.0002 for a system id
> > > :-)
> > >
> > > HTH!
> > >
> > >
> > >
> > >
> > > Rack1R3#
> > > router isis
> > >  net 47.0001.0001.0003.00
> > >  redistribute eigrp 101
> > >  passive-interface Loopback0
> > > !
> > >
> > > Rack1R4#
> > > router isis
> > >  net 47.0001.0001.0004.00
> > >  redistribute ospf 1
> > >  passive-interface Loopback0
> > >  no hostname dynamic
> > >
> > > Rack1R5#
> > > !
> > > router isis
> > >  net 47.0001.0001.0005.00
> > >  passive-interface Loopback0
> > >
> > >
> > >
> > > ----- Original Message -----
> > > From: "Sharma, Mohit" <mohit.sharma@xxxxxx>
> > > To: "Ty" <tycampbell@xxxxxxxxxxx>; "Ccielab@xxxxxxxxxxxxxx"
> > > <ccielab@xxxxxxxxxxxxxx>
> > > Sent: Saturday, June 12, 2004 12:54 PM
> > > Subject: RE: Routers going crazy (ISIS??)
> > >
> > >
> > > Here it is-
> > > Rack1R3#
> > > router isis
> > >  net 1e.0001.0001.0003.00
> > >  redistribute eigrp 101
> > >  passive-interface Loopback0
> > > !
> > >
> > > Rack1R4#
> > > router isis
> > >  net 28.0001.0001.0004.00
> > >  redistribute ospf 1
> > >  passive-interface Loopback0
> > >  no hostname dynamic
> > >
> > > Rack1R5#
> > > !
> > > router isis
> > >  net 32.0001.0001.0005.00
> > >  passive-interface Loopback0
> > > !
> > >
> > > Thanks,
> > > Mohit.
> > > -----Original Message-----
> > > From: Ty [mailto:tycampbell@xxxxxxxxxxx]
> > > Sent: Saturday, June 12, 2004 7:49 PM
> > > To: Sharma, Mohit; Ccielab@xxxxxxxxxxxxxx
> > > Subject: Re: Routers going crazy (ISIS??)
> > >
> > > could you include your isis config also ?
> > > ----- Original Message -----
> > > From: "Sharma, Mohit" <mohit.sharma@xxxxxx>
> > > To: "Ccielab@xxxxxxxxxxxxxx" <ccielab@xxxxxxxxxxxxxx>
> > > Sent: Saturday, June 12, 2004 12:31 PM
> > > Subject: Routers going crazy (ISIS??)
> > >
> > >
> > > > Hi All,
> > > > While doing a lab for ISIS my routers have suddenly gone
berserk.
> > > > I have this setup-
> > > > RTR3(7500)
> > > >    multipoint - multipoint
> > > > / \
> > > >      /FR   \FR
> > > >    RTR4(2500) RTR5(2500)
> > > > Serial0 Serial0
> > > > Till the time IP was there everything was working fine, after I
> > > > configured ISIS, I cant ping even the spokes that are directly
> > > > connected. Strangely the clns adjacency is ON, also when I ping
> > > > from
> > > > R3-R4 or R3-R5 I can see the packets coming back in the debug
> > > > but
ping
> > > > fails. Here are the configs-
> > > >
> > > > **********************************************
> > > > Rack1R3#interface Serial3/0
> > > >  no ip address
> > > >  encapsulation frame-relay
> > > >  serial restart-delay 0
> > > >  clockrate 64000
> > > >  no frame-relay inverse-arp
> > > > end
> > > >
> > > > interface Serial3/0.53 multipoint  ip address 164.1.35.3
> > > > 255.255.255.0  ip router isis  isis hello-multiplier 5  isis
> > > > hello-interval 1  frame-relay map clns 305 broadcast
> > > > frame-relay map ip 164.1.35.3 305 broadcast  frame-relay map ip
> > > > 164.1.35.5 305 broadcast
> > > >
> > > > interface Serial3/0.43 multipoint  ip address 164.1.34.3
> > > > 255.255.255.0  ip router isis  isis hello-multiplier 5  isis
> > > > hello-interval 1  frame-relay map clns 304 broadcast
> > > > frame-relay map ip 164.1.34.3 304 broadcast  frame-relay map ip
> > > > 164.1.34.4 304 broadcast
> > > >
> > > > ***********************************************
> > > > Rack1R4#
> > > > interface Serial0
> > > >  ip address 164.1.34.4 255.255.255.0  ip router isis
> > > > encapsulation frame-relay  no fair-queue  frame-relay map clns
> > > > 403 broadcast  frame-relay map ip 164.1.34.3 403 broadcast
> > > > frame-relay map ip 164.1.34.4 403 broadcast  no frame-relay
> > > > inverse-arp  isis hello-multiplier 5  isis hello-interval 1 End
> > > > Rack1R4#sh fram map Serial0 (up): CLNS dlci 403(0x193,0x6430),
> > > > static,
> > > >               broadcast,
> > > >               CISCO, status defined, active Serial0 (up): ip
> > > > 164.1.34.3 dlci 403(0x193,0x6430), static,
> > > >               broadcast,
> > > >               CISCO, status defined, active Serial0 (up): ip
> > > > 164.1.34.4 dlci 403(0x193,0x6430), static,
> > > >               broadcast,
> > > >               CISCO, status defined, active
> > > >
> > > > Rack1R4#sh clns nei
> > > >
> > > > System Id      Interface   SNPA                State  Holdtime
Type
> > > > Protocol
> > > > 0001.0001.0003 Se0         DLCI 403            Up     4
L2
> > > > IS-IS
> > > >
> > > > Rack1R4#ping 164.1.34.3
> > > >
> > > > Type escape sequence to abort.
> > > > Sending 5, 100-byte ICMP Echos to 164.1.34.3, timeout is 2
seconds:
> > > > .
> > > > 00:15:45: ICMP: echo reply rcvd, src 164.1.34.3, dst 164.1.34.4.
> > > > 00:15:47: ICMP: echo reply rcvd, src 164.1.34.3, dst 164.1.34.4
> > > > 00:15:48: ICMP: echo reply rcvd, src 164.1.34.3, dst
164.1.34.4..
> > > > 00:15:50: ICMP: echo reply rcvd, src 164.1.34.3, dst 164.1.34.4.
> > > > Success rate is 0 percent (0/5)
> > > > Rack1R4#
> > > > 00:16:02: ICMP: echo reply rcvd, src 164.1.34.3, dst 164.1.34.4
> > > > Rack1R4#
> > > > 00:16:04: ICMP: echo reply rcvd, src 164.1.34.3, dst 164.1.34.4
> > > > Rack1R4#
> > > > 00:16:06: ICMP: echo reply rcvd, src 164.1.34.3, dst 164.1.34.
> > > >
> > > >
> > >
************************************************************************
> > > >
> > > > The same is happening on R5. IP traffic over the FR cloud is not

> > > > "working" at all.
> > > > Could somebody please tell me what is happening here. I am going

> > > > BONKERS.
> > > >
> > > > Many Thanks,
> > > > Mohit
> > > > P.S. I did rebooot all the routers also.
> > > >
> > > > _______________________________________________
> > > > ______________________
> > > >
> > > > ******    _/          ******  |  Mohit Sharma
> > > > *****    _/            *****  |  Network Implementation
> > > Manager(Agilent
> > > > Account)
> > > > ****    _/_/_/  _/_/_/  ****  |  HP Operations
> > > > ****   _/  _/  _/  _/   ****  |
> > > > ****  _/  _/  _/_/_/    ****  |
> > > > *****        _/        *****  |
> > > > ******               *******  | email: mohit.sharma@xxxxxx
> > > >                               |
> > > >  i    n    v    e    n    t   | Germany.
> > > >
_____________________________________________________________________
> > > > "Choose a job you love, and you will never have to work a day in
your
> > > > life." -Confucius
> > > >
> > > >
> > >
_______________________________________________________________________
> > > > Please help support GroupStudy by purchasing your study
> > > > materials
> > > from:
> > > > http://shop.groupstudy.com
> > > >
> > > > Subscription information may be found at:
> > > > http://www.groupstudy.com/list/CCIELab.html
> > >
> > >
_______________________________________________________________________
> > > Please help support GroupStudy by purchasing your study materials
from:
> > > http://shop.groupstudy.com
> > >
> > > Subscription information may be found at:
> > > http://www.groupstudy.com/list/CCIELab.html